Pasting a URL directly in to Mozilla should open a new tab at that URL

VERIFIED WONTFIX

Status

()

--
enhancement
VERIFIED WONTFIX
16 years ago
16 years ago

People

(Reporter: swillison, Assigned: aaronlev)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
At the moment visiting a URL in the systel clip board involves selecting the
location bar, hitting paste, then hitting enter. I propose an enhancement
whereby selecting any part of the Mozilla browsing window (with the exception of
text entry areas such as forms) and hitting "paste" either opens the URL in the
current window or opens the URL in a new tab - preference to be set in Mozilla
preferences. This enhancement could be compared to bug 30088.

Comment 1

16 years ago
You can set in the preferences, that hitting 'CTRL+Enter' opens the page in a
new tab..

do you want a function like this?
(Reporter)

Comment 2

16 years ago
Not entirely - I'm talking about being able to select a Mozilla window, hit
CTRL+V (on Windows) and, provided the clipboard contains a valid URL, have the
browser go straight to that URL. This is purely a time saver - rather than
hitting CTRL+L (to get to the location bar), CTRL+V to paste the URL and Enter
to go there you could just hit CTRL+V and the browser would be smart enough to
guess what you wanted to do with the URL.

This is about as trivial an enhancement as you can get but I'm a big fan of
small details :)

Comment 3

16 years ago
No dup found and sounds like a nice idea

marking as NEW
(-> OS/PLATFORM -> ALL .. not only win32 users should have this feature ;) )
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All

Comment 4

16 years ago
Well, this is something I wouldn't like, since I often want to edit the URL
before pressing ENTER (or if I would want to open in in a different tab - that's
why we have the CTRL-ENTER). So it should definitely be an option. An immediate
reaction to a CTRL-V would be a surprise, and different from all other apps,
except on X-Windows (immediate paste mode, normally bound to the middle button).
In the case of X-Windows, I can understand it.

On the other hand, dropping an URL on top of Mozilla gives an immediate
response, because you don't have to 'confirm' a drop & drop. Isn't it possible
to drop items from the remote application directly onto Mozilla ? So, without
the CTRL-C ... CTRL-V sequence ?
What about;

If the URL (location) bar (or any text area/field) has the focus, the URL just
gets pasted into it, but if something else has, mozilla loads the URL as a new tab.

Comment 6

16 years ago
Oh, i didn't read carefully enough..
This works already on X, so unix isn't affected (setting back to win2000)

On X it works like this
-> Have a url in the clipboard and press the 3. button in the 'html widget'
This loads the URL.. 
I CTRL+V is imho bad, but mousebutton 3 would be also nice on win32..

But another problem is: most win users don't have a _real_ 3. mousebutton.. most
users have a doubleclick on this button..
-> Wontfix?

.. i thought that you wanted to be able to open 'unlinked' urls in a new tab
(for example hittin 3. mousebutton+ctrl) .. sorry.. :) damd drugs again!

Simon: Maybe you want to switch to unix? ;)
OS: All → Windows 2000
Hardware: All → PC
The middle button thing works on Windows too.  Just set 

user_pref("middlemouse.contentLoadURL", true);

(it's false by default on Windows, true by default on Linux).
(Assignee)

Comment 8

16 years ago
Why shouldn't 
user_pref("middlemouse.contentLoadURL", true);
be the default on all platforms?

Comment 9

16 years ago
I suspect windows users would scream bloody murder if it were made default on
Windows.  But you're welcome to try it. :-)

See also bug 105895, which makes ctrl-middleclick open the clipboard url in a
new tab (if middlemouse.contentLoadURL is set).  It's stalled waiting for sr;
vote for that bug or pester jag if you want it.
(Assignee)

Comment 10

16 years ago
You can use the prefs for the middle button.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WONTFIX
mass-verifying Wontfix bugs.

mail filter string for bugspam: Tursiopstruncatus
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.