Closed Bug 1575075 Opened 4 months ago Closed Last month

When putting an autoplaying video that's muted in PiP mode, it's impossible to unmute the video

Categories

(Toolkit :: Video/Audio Controls, enhancement)

enhancement
Not set

Tracking

()

RESOLVED FIXED
mozilla72
Tracking Status
firefox72 --- fixed

People

(Reporter: ehsan, Assigned: gl)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

It would be nice to add a control to unmute a video if it has been set as muted on the page, as is the common practice to allow video autoplayback, for example.

This bug is marked as a blocker on the WebRender picture caching improvements meta-bug. Was that an incorrect bug number?

Component: General → Video/Audio Controls
Product: Firefox → Toolkit

(In reply to Glenn Watson [:gw] from comment #1)

This bug is marked as a blocker on the WebRender picture caching improvements meta-bug. Was that an incorrect bug number?

My apologies!

Blocks: 1527926
No longer blocks: 1536360

I believe the muting capability can be controlled via the PiP indicator icon in the tab. I think that was the compromise that we came up with to avoid adding yet another icon to the tab.

Does clicking on the PiP indicator unmute the video for you in this scenario?

/cc'ing JSON_Voorhees and emanuela who had conversations about this a few months back when the PiP indicator was added.

ni?ing ehsan for the first part of comment 3.

Flags: needinfo?(ehsan)

(In reply to Mike Conley (:mconley) (:⚙️) from comment #3)

I believe the muting capability can be controlled via the PiP indicator icon in the tab. I think that was the compromise that we came up with to avoid adding yet another icon to the tab.

Does clicking on the PiP indicator unmute the video for you in this scenario?

I'm sorry, I'm not 100% sure which PiP indicator icon you're referring to. It is probably an icon that I have never noticed before (currently typing this on a Linux machine so can't test at the moment.)

Due to the fact that I haven't noticed the icon existing I'm gonna go on a stretch and claim that it is not a great solution to this problem. :-)

Flags: needinfo?(ehsan)
Assignee: nobody → gl
Status: NEW → ASSIGNED
Pushed by gluong@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3ac07ce7e004
Add an audio toggle button in PiP to mute and unmute a video. r=mconley
Status: ASSIGNED → RESOLVED
Closed: Last month
Resolution: --- → FIXED
Target Milestone: --- → mozilla72
You need to log in before you can comment on or make changes to this bug.