Closed Bug 1575090 Opened 1 year ago Closed 8 months ago

A dedicated worker's COEP must match its owner's COEP

Categories

(Core :: DOM: Workers, enhancement, P2)

enhancement

Tracking

()

RESOLVED FIXED
mozilla77
Tracking Status
firefox77 --- fixed

People

(Reporter: perry, Assigned: perry)

References

Details

Attachments

(3 files)

No description provided.
See Also: → 1562663
Summary: A dedicated worker's COEP must match its parent document's COEP → A dedicated worker's COEP must match its owner's COEP
Attachment #9093362 - Attachment description: Bug 1575090 - add NS_GetEffectiveCrossOriginEmbedderPolicy r?JuniorHsu → Bug 1575090 - add NS_GetCrossOriginEmbedderPolicyFromHeader r?JuniorHsu
See Also: 1562663
Pushed by pjiang@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/efb654c201a3
expose a response's COEP on nsIHttpChannelInternal r=JuniorHsu
https://hg.mozilla.org/integration/autoland/rev/224ad4adb49e
set COEP for all workers and enforce it when loading Dedicated Workers r=asuth
https://hg.mozilla.org/integration/autoland/rev/3791b3afbb44
add NS_GetCrossOriginEmbedderPolicyFromHeader r=JuniorHsu

Backed out for web platform failures on e.g. nested-sharedworker-success.https.html

backout: https://hg.mozilla.org/integration/autoland/rev/94dfbbd73b840ce18181b74660d65a665cca8563

push with failures: https://treeherder.mozilla.org/#/jobs?repo=autoland&group_state=expanded&searchStr=wpt16&revision=3791b3afbb448959bdb040ce7df20bb94dcf5bf1&selectedJob=272811751

failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=272811751&repo=autoland&lineNumber=3103

[task 2019-10-24T18:04:04.200Z] 18:04:04 INFO - TEST-START | /html/infrastructure/safe-passing-of-structured-data/shared-array-buffers/nested-sharedworker-success.https.html
[task 2019-10-24T18:04:04.200Z] 18:04:04 INFO - Closing window 18
[task 2019-10-24T18:04:34.901Z] 18:04:34 INFO - TEST-UNEXPECTED-TIMEOUT | /html/infrastructure/safe-passing-of-structured-data/shared-array-buffers/nested-sharedworker-success.https.html | expected OK
[task 2019-10-24T18:04:34.901Z] 18:04:34 INFO - TEST-INFO took 30703ms
[task 2019-10-24T18:04:35.561Z] 18:04:35 INFO - Closing logging queue
[task 2019-10-24T18:04:35.561Z] 18:04:35 INFO - queue closed
[task 2019-10-24T18:04:35.569Z] 18:04:35 INFO - Setting up ssl
[task 2019-10-24T18:04:35.584Z] 18:04:35 INFO - certutil |
[task 2019-10-24T18:04:35.605Z] 18:04:35 INFO - certutil |
[task 2019-10-24T18:04:35.620Z] 18:04:35 INFO - certutil |
[task 2019-10-24T18:04:35.620Z] 18:04:35 INFO - Certificate Nickname Trust Attributes
[task 2019-10-24T18:04:35.620Z] 18:04:35 INFO - SSL,S/MIME,JAR/XPI
[task 2019-10-24T18:04:35.620Z] 18:04:35 INFO -
[task 2019-10-24T18:04:35.620Z] 18:04:35 INFO - web-platform-tests CT,,
[task 2019-10-24T18:04:35.620Z] 18:04:35 INFO -
[task 2019-10-24T18:04:38.351Z] 18:04:38 INFO - adb Granting important runtime permissions to org.mozilla.geckoview.test
[task 2019-10-24T18:04:39.605Z] 18:04:39 INFO - adb launch_application: am start -W -n org.mozilla.geckoview.test/org.mozilla.geckoview.test.TestRunnerActivity -a android.intent.action.MAIN --es env9 MOZ_DISABLE_NONLOCAL_CONNECTIONS=1 --es env8 R_LOG_DESTINATION=stderr --es args "-no-remote -profile /sdcard/tests/profile --marionette about:blank" --es env3 MOZ_HIDE_RESULTS_TABLE=1 --es env2 R_LOG_VERBOSE=1 --es env1 MOZ_WEBRENDER=0 --es env0 MOZ_CRASHREPORTER=1 --es env7 MOZ_CRASHREPORTER_SHUTDOWN=1 --es env6 MOZ_IN_AUTOMATION=1 --es env5 MOZ_LOG=signaling:3,mtransport:4,DataChannel:4,jsep:4 --es env4 STYLO_THREADS=4 --ez use_multiprocess True --es env12 R_LOG_LEVEL=6 --es env11 MOZ_PROCESS_LOG=/tmp/tmppkXdd_pidlog --es env10 MOZ_CRASHREPORTER_NO_REPORT=1
[task 2019-10-24T18:04:41.093Z] 18:04:41 INFO - Starting runner
[task 2019-10-24T18:04:41.346Z] 18:04:41 INFO - TEST-START | /html/infrastructure/safe-passing-of-structured-data/shared-array-buffers/nested-worker-success.https.html
[task 2019-10-24T18:04:41.369Z] 18:04:41 INFO - Setting pref browser.tabs.remote.useCrossOriginOpenerPolicy (true)
[task 2019-10-24T18:04:41.426Z] 18:04:41 INFO - Setting pref browser.tabs.remote.useCrossOriginEmbedderPolicy (true)
[task 2019-10-24T18:04:41.461Z] 18:04:41 INFO - Setting pref javascript.options.shared_memory (true)
[task 2019-10-24T18:04:41.497Z] 18:04:41 INFO - Setting pref dom.postMessage.sharedArrayBuffer.withCOOP_COEP (true)
[task 2019-10-24T18:05:12.373Z] 18:05:12 INFO - TEST-UNEXPECTED-TIMEOUT | /html/infrastructure/safe-passing-of-structured-data/shared-array-buffers/nested-worker-success.https.html | expected OK

Flags: needinfo?(perry)

Clearing ni? because landing this depends on resolving the problem described in bug 1598131.

Flags: needinfo?(perry)
Pushed by nerli@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4517990fbcdd
expose a response's COEP on nsIHttpChannelInternal r=JuniorHsu,necko-reviewers,valentin
https://hg.mozilla.org/integration/autoland/rev/88592a8e23fe
set COEP for all workers and enforce it when loading Dedicated Workers r=asuth
https://hg.mozilla.org/integration/autoland/rev/6b2ed41d5714
add NS_GetCrossOriginEmbedderPolicyFromHeader r=JuniorHsu,necko-reviewers,valentin
Regressions: 1638377
You need to log in before you can comment on or make changes to this bug.