Closed Bug 1575175 Opened 2 years ago Closed 2 years ago

Memory counters have gcBytes fields that are now used for both GC heap and malloc memory

Categories

(Core :: JavaScript: GC, task, P3)

task

Tracking

()

RESOLVED FIXED
mozilla70
Tracking Status
firefox70 --- fixed

People

(Reporter: jonco, Assigned: jonco)

Details

Attachments

(1 file)

Steve mentioned in bug 1574694 that we use the name gcBytes to apply to byte counts for both GC heap and malloc memory now. We could do some renaming to make things clearer.

This renames:
HeapSize::gcBytes -> bytes (it's not just for GC heaps any more)
ZoneThreshold -> HeapThreshold (to go with HeapSize)
HeapThreshold::triggerBytes -> bytes (what else could it be?)

I renamed the ZoneAllocator members to make them more uniform/consitent so we now have gcHeapSize/gcHeapThreshold, mallocHeapSize/mallocHeapThreshold etc.

I also renamed the heap threshold classes.

Pushed by jcoppeard@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8a10768ff385
Rename memory counter classes now they're used for both GC and malloc heaps r=sfink
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70
Assignee: nobody → jcoppeard
You need to log in before you can comment on or make changes to this bug.