Closed Bug 1575196 Opened 2 years ago Closed 2 years ago

The blank space are not recognized if are added at the beginning or at the end of the password

Categories

(Firefox :: about:logins, defect, P2)

Desktop
All
defect

Tracking

()

VERIFIED FIXED
Firefox 70
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox68 --- unaffected
firefox69 --- disabled
firefox70 --- verified

People

(Reporter: srosu, Assigned: ntim)

References

Details

(Keywords: regression, Whiteboard: [passwords:management] [skyline])

Attachments

(2 files)

Attached video blankSpace_password.mp4

[Affected versions]:

  • Firefox latest Nightly 70.0a1 (2019-08-19) (64-bit)

[Affected Platforms]:

  • Mac 10.14
  • Windows 10 x64
  • Ubuntu 18.04 x64

[Prerequisites]:

  • The Firefox browser is opened.

[Steps to reproduce]:

  1. Navigate to “about:logins” page.
  2. Create a new login that contains a password with blank space characters at the beginning and the end. (e.g., “ 1234 “)
  3. Click on the Show Password button from “Login Item” mode.
  4. Observe the password.

[Expected result]:

  • The password is correctly displayed.

[Actual result]:

  • The blank space characters are not recognized.

[Notes]:

  • The blank space characters are recognized only if they are added inside of the password.
  • The issue is reproducible when creating a new login or editing an old one.
  • Attached a screen recording with the issue.

I think I saw that we were trimming the value now but that doesn't seem like a good idea for passwords. P2 since I think it's a regression compared to the old UI.

Keywords: regression
Priority: -- → P2
Assignee: nobody → ntim.bugs
Status: NEW → ASSIGNED
Pushed by ntim.bugs@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/c1046eea513e
Stop trimming passwords when saving them. r=MattN
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70

I have verified this issue and is no longer reproducible on the latest Nightly 70.0a1 (2019-08-23)(64-bit) build on Windows 7 x64, Mac 10.14 and Ubuntu 16.04 x64.

  • The blank space characters are now recognized.
Status: RESOLVED → VERIFIED
Component: Password Manager → about:logins
Product: Toolkit → Firefox
Target Milestone: mozilla70 → Firefox 70
You need to log in before you can comment on or make changes to this bug.