Closed Bug 1575203 Opened 1 year ago Closed 5 months ago

Intermittent devtools/client/inspector/markup/test/browser_markup_events_click_to_close.js | Test timed out -

Categories

(DevTools :: Inspector, defect, P5)

defect

Tracking

(firefox-esr60 unaffected, firefox-esr68 unaffected, firefox69 unaffected, firefox70 unaffected, firefox71 fixed)

RESOLVED FIXED
Firefox 71
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox69 --- unaffected
firefox70 --- unaffected
firefox71 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: fvsch)

Details

(Keywords: intermittent-failure, regression)

Attachments

(1 file)

Filed by: cbrindusan [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=262452269&repo=autoland
Full log: https://queue.taskcluster.net/v1/task/dYAP2nOPQ4G-K73pgme90Q/runs/0/artifacts/public/logs/live_backing.log


[task 2019-08-20T11:58:31.526Z] 11:58:31 INFO - TEST-START | devtools/client/inspector/markup/test/browser_markup_events_click_to_close.js
[task 2019-08-20T11:58:31.526Z] 11:58:31 INFO - Entering test bound
[task 2019-08-20T11:58:31.526Z] 11:58:31 INFO - Adding a new tab with URL: data:text/html;charset=utf-8,%0A%20%20%3Cbody%3E%0A%20%20%20%20%3Cdiv%20id=%22d1%22%20onclick=%22console.log(1)%22%3Etest%3C/div%3E%0A%20%20%20%20%3C!--%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20--%3E%0A%20%20%20%20%3C!--%20adding%20some%20comments%20to%20make%20sure%20%20%20%20%20%20--%3E%0A%20%20%20%20%3C!--%20the%20second%20event%20icon%20is%20not%20hidden%20by%20--%3E%0A%20%20%20%20%3C!--%20the%20tooltip%20of%20the%20first%20event%20icon%20%20%20%20--%3E%0A%20%20%20%20%3C!--%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20--%3E%0A%20%20%20%20%3Cdiv%20id=%22d2%22%20onclick=%22console.log(2)%22%3Etest%3C/div%3E%0A%20%20%3C/body%3E%0A
[task 2019-08-20T11:58:31.661Z] 11:58:31 INFO - Console message: [JavaScript Error: "uncaught exception: Object" {file: "resource://testing-common/PromiseTestUtils.jsm" line: 112}]
[task 2019-08-20T11:58:31.779Z] 11:58:31 INFO - Tab added and finished loading
[task 2019-08-20T11:58:31.779Z] 11:58:31 INFO - Opening the inspector
[task 2019-08-20T11:58:31.779Z] 11:58:31 INFO - Opening the toolbox
[task 2019-08-20T11:58:32.076Z] 11:58:32 INFO - GECKO(1679) | console.log: "[DISPATCH] action type:" "UPDATE_GRIDS"
[task 2019-08-20T11:58:32.076Z] 11:58:32 INFO - GECKO(1679) | console.log: "[DISPATCH] action type:" "CLEAR_FLEXBOX"
[task 2019-08-20T11:58:32.092Z] 11:58:32 INFO - GECKO(1679) | console.log: "[DISPATCH] action type:" "UPDATE_OFFSET_PARENT"
[task 2019-08-20T11:58:32.092Z] 11:58:32 INFO - GECKO(1679) | console.log: "[DISPATCH] action type:" "UPDATE_LAYOUT"
[task 2019-08-20T11:58:32.096Z] 11:58:32 INFO - Toolbox opened and focused
[task 2019-08-20T11:58:32.132Z] 11:58:32 INFO - Getting the markup-container for node #d1
[task 2019-08-20T11:58:32.132Z] 11:58:32 INFO - TEST-PASS | devtools/client/inspector/markup/test/browser_markup_events_click_to_close.js | Found markup-container for selector: #d1 -
[task 2019-08-20T11:58:32.132Z] 11:58:32 INFO - Getting the markup-container for node #d2
[task 2019-08-20T11:58:32.133Z] 11:58:32 INFO - GECKO(1679) | console.log: "[DISPATCH] action type:" "CLEAR_FLEXBOX"
[task 2019-08-20T11:58:32.160Z] 11:58:32 INFO - TEST-PASS | devtools/client/inspector/markup/test/browser_markup_events_click_to_close.js | Found markup-container for selector: #d2 -
[task 2019-08-20T11:58:32.160Z] 11:58:32 INFO - Click the event icon for the first element
[task 2019-08-20T11:58:32.188Z] 11:58:32 INFO - GECKO(1679) | console.log: "[DISPATCH] action type:" "UPDATE_OFFSET_PARENT"
[task 2019-08-20T11:58:32.188Z] 11:58:32 INFO - GECKO(1679) | console.log: "[DISPATCH] action type:" "UPDATE_LAYOUT"
[task 2019-08-20T11:59:16.635Z] 11:59:16 INFO - TEST-INFO | started process screencapture
[task 2019-08-20T11:59:16.726Z] 11:59:16 INFO - TEST-INFO | screencapture: exit 0
[task 2019-08-20T11:59:16.726Z] 11:59:16 INFO - TEST-UNEXPECTED-FAIL | devtools/client/inspector/markup/test/browser_markup_events_click_to_close.js | Test timed out -

Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → INCOMPLETE
Status: RESOLVED → REOPENED
Resolution: INCOMPLETE → ---

We're running out of vertical space to show this test's case HTML in the Markup View:

The horizontal scrollbar looks like a bug (there is no content to the right), and on top of that the patch in bug 1512513 makes the markup view 2px shorter. In the future we plan to make it 4px shorter still (using 28px toolbar instead of 24px).

Is there a way to increase the toolbox height for this test?
Edit: await pushPref("devtools.toolbox.footer.height", 400); looks good.

Assignee: nobody → florens
Status: REOPENED → ASSIGNED
Pushed by florens@fvsch.com:
https://hg.mozilla.org/integration/autoland/rev/a358c72a6f41
Set higher toolbox height in browser_markup_events_click_to_close; r=jdescottes
Status: ASSIGNED → RESOLVED
Closed: 5 months ago5 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 71
You need to log in before you can comment on or make changes to this bug.