Closed Bug 1575274 Opened 3 months ago Closed 3 months ago

WebSocket Inspector Test: Filtering using free text

Categories

(DevTools :: Netmonitor, enhancement, P2)

70 Branch
enhancement

Tracking

(firefox70 fixed)

RESOLVED FIXED
Firefox 70
Tracking Status
firefox70 --- fixed

People

(Reporter: tanhengyeow, Assigned: tanhengyeow)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_5) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/76.0.3809.100 Safari/537.36

Expected results:

Test - Filtering using free text

  • Create WS connection, send a couple of frames and filter using free text
  • Check that proper frames are displayed
Blocks: 1555643

Test for filtering messages using the filter input.

Pushed by jodvarko@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/bc05d6bf98ef
WebSocket Inspector Test: Filtering using free text. r=Honza

Backed out changeset bc05d6bf98ef (Bug 1575274) for browser_net-ws-filter-freetext.js failures

Push with failures: https://treeherder.mozilla.org/#/jobs?repo=autoland&fromchange=236e278e33a4871a38bcb4167ed868a952a31221&tochange=30cefc7ac14735dd10f7a3ac696f3db001761039&selectedJob=263081003

Backout link: https://hg.mozilla.org/integration/autoland/rev/30cefc7ac14735dd10f7a3ac696f3db001761039

Failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=263081003&repo=autoland&lineNumber=4270

[task 2019-08-23T06:56:38.773Z] 06:56:38 INFO - TEST-START | devtools/client/netmonitor/test/browser_net-ws-filter-freetext.js
[task 2019-08-23T06:56:38.995Z] 06:56:38 INFO - GECKO(2330) | ### XPCOM_MEM_BLOAT_LOG defined -- logging bloat/leaks to /tmp/tmpl5ge3B.mozrunner/runtests_leaks_tab_pid2493.log
[task 2019-08-23T06:56:39.197Z] 06:56:39 INFO - GECKO(2330) | Couldn't convert chrome URL: chrome://branding/locale/brand.properties
[task 2019-08-23T06:56:39.517Z] 06:56:39 INFO - GECKO(2330) | WARN 2019-08-23T06:56:39Z: audio_thread_priority::rt_linux: Could not make thread real-time.
[task 2019-08-23T06:56:39.518Z] 06:56:39 INFO - GECKO(2330) | WARN 2019-08-23T06:56:39Z: audioipc_client: Could not promote audio threads to real-time during initialization.
[task 2019-08-23T06:56:39.518Z] 06:56:39 INFO - GECKO(2330) | ++DOCSHELL 0x7fbac7eb6800 == 1 [pid = 2493] [id = {8c2bd349-5312-4dba-9ab8-110915438959}]
[task 2019-08-23T06:56:39.599Z] 06:56:39 INFO - GECKO(2330) | ++DOMWINDOW == 1 (0x7fbac8e87f20) [pid = 2493] [serial = 1] [outer = (nil)]
[task 2019-08-23T06:56:39.599Z] 06:56:39 INFO - GECKO(2330) | ++DOMWINDOW == 2 (0x7fbac87a5400) [pid = 2493] [serial = 2] [outer = 0x7fbac8e87f20]
[task 2019-08-23T06:56:39.780Z] 06:56:39 INFO - GECKO(2330) | ++DOMWINDOW == 3 (0x7fbac87b0400) [pid = 2493] [serial = 3] [outer = 0x7fbac8e87f20]
[task 2019-08-23T06:56:40.279Z] 06:56:40 INFO - GECKO(2330) | ++DOCSHELL 0x7f52d545b800 == 7 [pid = 2330] [id = {f82af4a0-2d47-4ccc-a07a-d4b4637a8be8}]
[task 2019-08-23T06:56:40.279Z] 06:56:40 INFO - GECKO(2330) | ++DOMWINDOW == 15 (0x7f52d5330880) [pid = 2330] [serial = 15] [outer = (nil)]
[task 2019-08-23T06:56:40.294Z] 06:56:40 INFO - GECKO(2330) | ++DOMWINDOW == 16 (0x7f52cf757400) [pid = 2330] [serial = 16] [outer = 0x7f52d5330880]
[task 2019-08-23T06:56:40.330Z] 06:56:40 INFO - GECKO(2330) | ++DOMWINDOW == 17 (0x7f52d830d400) [pid = 2330] [serial = 17] [outer = 0x7f52d5330880]
[task 2019-08-23T06:56:40.386Z] 06:56:40 INFO - GECKO(2330) | ++DOMWINDOW == 18 (0x7f52cf86ec00) [pid = 2330] [serial = 18] [outer = 0x7f52d5330880]
[task 2019-08-23T06:56:40.522Z] 06:56:40 INFO - GECKO(2330) | [Parent 2330, Main Thread] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80004005: file /builds/worker/workspace/build/src/dom/base/nsContentUtils.cpp, line 3683
[task 2019-08-23T06:56:40.620Z] 06:56:40 INFO - GECKO(2330) | ### XPCOM_MEM_BLOAT_LOG defined -- logging bloat/leaks to /tmp/tmpl5ge3B.mozrunner/runtests_leaks_tab_pid2523.log
[task 2019-08-23T06:56:40.758Z] 06:56:40 INFO - GECKO(2330) | Couldn't convert chrome URL: chrome://branding/locale/brand.properties
[task 2019-08-23T06:56:40.899Z] 06:56:40 INFO - GECKO(2330) | WARN 2019-08-23T06:56:40Z: audio_thread_priority::rt_linux: Could not make thread real-time.
[task 2019-08-23T06:56:40.899Z] 06:56:40 INFO - GECKO(2330) | WARN 2019-08-23T06:56:40Z: audioipc_client: Could not promote audio threads to real-time during initialization.
[task 2019-08-23T06:56:40.987Z] 06:56:40 INFO - GECKO(2330) | ++DOCSHELL 0x7f52ce5cf800 == 8 [pid = 2330] [id = {01618832-91c0-4577-b244-6e29f1069acf}]
[task 2019-08-23T06:56:40.988Z] 06:56:40 INFO - GECKO(2330) | ++DOMWINDOW == 19 (0x7f52d5330a60) [pid = 2330] [serial = 19] [outer = (nil)]
[task 2019-08-23T06:56:40.989Z] 06:56:40 INFO - GECKO(2330) | ++DOMWINDOW == 20 (0x7f52ce691c00) [pid = 2330] [serial = 20] [outer = 0x7f52d5330a60]
[task 2019-08-23T06:56:41.533Z] 06:56:41 INFO - GECKO(2330) | [Parent 2330, Main Thread] WARNING: NS_ENSURE_SUCCESS(rv, nullptr) failed with result 0x804B000A: file /builds/worker/workspace/build/src/extensions/permissions/nsPermission.cpp, line 42
[task 2019-08-23T06:56:41.533Z] 06:56:41 INFO - GECKO(2330) | [Parent 2330, Main Thread] WARNING: '!principal', file /builds/worker/workspace/build/src/netwerk/cookie/CookieSettings.cpp, line 132
[task 2019-08-23T06:56:41.533Z] 06:56:41 INFO - GECKO(2330) | [Parent 2330, Main Thread] WARNING: 'NS_FAILED(rv)', file /builds/worker/workspace/build/src/toolkit/components/antitracking/StorageAccess.cpp, line 33
[task 2019-08-23T06:56:41.536Z] 06:56:41 INFO - GECKO(2330) | [Parent 2330, Main Thread] WARNING: NS_ENSURE_SUCCESS(rv, nullptr) failed with result 0x804B000A: file /builds/worker/workspace/build/src/extensions/permissions/nsPermission.cpp, line 42
[task 2019-08-23T06:56:41.537Z] 06:56:41 INFO - GECKO(2330) | [Parent 2330, Main Thread] WARNING: '!principal', file /builds/worker/workspace/build/src/netwerk/cookie/CookieSettings.cpp, line 132
[task 2019-08-23T06:56:41.538Z] 06:56:41 INFO - GECKO(2330) | [Parent 2330, Main Thread] WARNING: 'NS_FAILED(rv)', file /builds/worker/workspace/build/src/toolkit/components/antitracking/StorageAccess.cpp, line 33
[task 2019-08-23T06:56:42.183Z] 06:56:42 INFO - GECKO(2330) | ++DOMWINDOW == 4 (0x7fbac8ef7000) [pid = 2493] [serial = 4] [outer = 0x7fbac8e87f20]
[task 2019-08-23T06:56:43.673Z] 06:56:43 INFO - GECKO(2330) | --DOCSHELL 0x7f5f608b3000 == 1 [pid = 2403] [id = {d3a961c1-f83c-4d91-be7b-523602d3c6bd}] [url = about:blank]
[task 2019-08-23T06:56:43.977Z] 06:56:43 INFO - TEST-INFO | started process screentopng
[task 2019-08-23T06:56:44.392Z] 06:56:44 INFO - TEST-INFO | screentopng: exit 0
[task 2019-08-23T06:56:44.393Z] 06:56:44 INFO - Buffered messages logged at 06:56:38
[task 2019-08-23T06:56:44.394Z] 06:56:44 INFO - Entering test bound
[task 2019-08-23T06:56:44.394Z] 06:56:44 INFO - Initializing a network monitor pane.
[task 2019-08-23T06:56:44.394Z] 06:56:44 INFO - Adding a new tab with URL: http://mochi.test:8888/browser/devtools/client/netmonitor/test/html_ws-test-page.html
[task 2019-08-23T06:56:44.395Z] 06:56:44 INFO - Buffered messages logged at 06:56:39
[task 2019-08-23T06:56:44.395Z] 06:56:44 INFO - Tab added and finished loading
[task 2019-08-23T06:56:44.396Z] 06:56:44 INFO - Net tab added successfully: http://mochi.test:8888/browser/devtools/client/netmonitor/test/html_ws-test-page.html
[task 2019-08-23T06:56:44.396Z] 06:56:44 INFO - Buffered messages logged at 06:56:41
[task 2019-08-23T06:56:44.397Z] 06:56:44 INFO - Network monitor pane shown successfully.
[task 2019-08-23T06:56:44.397Z] 06:56:44 INFO - Disabling cache and reloading page.
[task 2019-08-23T06:56:44.397Z] 06:56:44 INFO - Buffered messages logged at 06:56:42
[task 2019-08-23T06:56:44.399Z] 06:56:44 INFO - Request server0.conn0.netEvent4 for http://mochi.test:8888/browser/devtools/client/netmonitor/test/html_ws-test-page.html not yet done, keep waiting...
[task 2019-08-23T06:56:44.399Z] 06:56:44 INFO - Console message: [JavaScript Warning: "Relative positioning of table rows and row groups is now supported. This site may need to be updated because it may depend on this feature having no effect." {file: "resource://devtools/client/netmonitor/src/components/RequestListHeader.js" line: 440}]
[task 2019-08-23T06:56:44.399Z] 06:56:44 INFO - Got marker: dom-interactive
[task 2019-08-23T06:56:44.400Z] 06:56:44 INFO - Got marker: dom-complete
[task 2019-08-23T06:56:44.400Z] 06:56:44 INFO - Got two timeline markers, done waiting
[task 2019-08-23T06:56:44.405Z] 06:56:44 INFO - Request server0.conn0.netEvent4 for http://mochi.test:8888/browser/devtools/client/netmonitor/test/html_ws-test-page.html done
[task 2019-08-23T06:56:44.406Z] 06:56:44 INFO - All requests finished
[task 2019-08-23T06:56:44.406Z] 06:56:44 INFO - Cache disabled when the current and all future toolboxes are open.
[task 2019-08-23T06:56:44.407Z] 06:56:44 INFO - TEST-PASS | devtools/client/netmonitor/test/browser_net-ws-filter-freetext.js | Request to reconfigure the tab was recorded. -
[task 2019-08-23T06:56:44.407Z] 06:56:44 INFO - Clearing requests in the console client.
[task 2019-08-23T06:56:44.408Z] 06:56:44 INFO - Clearing requests in the UI.
[task 2019-08-23T06:56:44.408Z] 06:56:44 INFO - Starting test...
[task 2019-08-23T06:56:44.412Z] 06:56:44 INFO - Buffered messages logged at 06:56:43
[task 2019-08-23T06:56:44.413Z] 06:56:44 INFO - TEST-PASS | devtools/client/netmonitor/test/browser_net-ws-filter-freetext.js | There should be two requests -
[task 2019-08-23T06:56:44.417Z] 06:56:44 INFO - TEST-PASS | devtools/client/netmonitor/test/browser_net-ws-filter-freetext.js | There should be six frames -
[task 2019-08-23T06:56:44.418Z] 06:56:44 INFO - Console message: [JavaScript Warning: "Key event not available on some keyboard layouts: key=“r” modifiers=“accel,alt” id=“key_toggleReaderMode”" {file: "chrome://mochikit/content/tests/SimpleTest/EventUtils.js" line: 870}]
[task 2019-08-23T06:56:44.419Z] 06:56:44 INFO - Console message: [JavaScript Warning: "Key event not available on some keyboard layouts: key=“i” modifiers=“accel,alt,shift” id=“key_browserToolbox”" {file: "chrome://mochikit/content/tests/SimpleTest/EventUtils.js" line: 870}]
[task 2019-08-23T06:56:44.421Z] 06:56:44 INFO - TEST-PASS | devtools/client/netmonitor/test/browser_net-ws-filter-freetext.js | There should be two frames -
[task 2019-08-23T06:56:44.421Z] 06:56:44 INFO - Buffered messages finished
[task 2019-08-23T06:56:44.422Z] 06:56:44 INFO - TEST-UNEXPECTED-FAIL | devtools/client/netmonitor/test/browser_net-ws-filter-freetext.js | There should be two frames - Got 0, expected 2
[task 2019-08-23T06:56:44.423Z] 06:56:44 INFO - Stack trace:
[task 2019-08-23T06:56:44.423Z] 06:56:44 INFO - chrome://mochikit/content/browser-test.js:test_is:1595
[task 2019-08-23T06:56:44.424Z] 06:56:44 INFO - chrome://mochitests/content/browser/devtools/client/netmonitor/test/browser_net-ws-filter-freetext.js:null:81
[task 2019-08-23T06:56:44.425Z] 06:56:44 INFO - chrome://mochikit/content/browser-test.js:Tester_execTest/<:1350
[task 2019-08-23T06:56:44.425Z] 06:56:44 INFO - chrome://mochikit/content/browser-test.js:Tester_execTest:1385
[task 2019-08-23T06:56:44.426Z] 06:56:44 INFO - chrome://mochikit/content/browser-test.js:nextTest/<:1213
[task 2019-08-23T06:56:44.427Z] 06:56:44 INFO - chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<:805
[task 2019-08-23T06:56:44.427Z] 06:56:44 INFO - TEST-PASS | devtools/client/netmonitor/test/browser_net-ws-filter-freetext.js | The filter input is cleared -
[task 2019-08-23T06:56:44.428Z] 06:56:44 INFO - GECKO(2330) | --DOCSHELL 0x7fe74b3e1000 == 4 [pid = 2380] [id = {28cb9389-88a5-4560-abd2-5ec988f6e408}] [url = moz-extension://771497d6-2866-4b43-85b5-e2952237d4d8/_generated_background_page.html]
[task 2019-08-23T06:56:44.464Z] 06:56:44 INFO - Destroying the specified network monitor.
[task 2019-08-23T06:56:44.466Z] 06:56:44 INFO - Wait for completion of all NetworkUpdateEvents packets...
[task 2019-08-23T06:56:44.627Z] 06:56:44 INFO - All pending requests finished.
[task 2019-08-23T06:56:45.459Z] 06:56:45 INFO - Removing tab.
[task 2019-08-23T06:56:45.460Z] 06:56:45 INFO - Waiting for event: 'TabClose' on [object XULElement].
[task 2019-08-23T06:56:45.484Z] 06:56:45 INFO - Got event: 'TabClose' on [object XULElement].
[task 2019-08-23T06:56:45.506Z] 06:56:45 INFO - Tab removed and finished closing
[task 2019-08-23T06:56:45.507Z] 06:56:45 INFO - Leaving test bound

Flags: needinfo?(jodvarko)
Flags: needinfo?(E0032242)
Priority: -- → P3
Priority: P3 → P2

Comments about how to fix this added to Phab

Honza

Flags: needinfo?(jodvarko)

Updated the patch!

Flags: needinfo?(E0032242)
Pushed by jodvarko@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a57d69ecbda8
WebSocket Inspector Test: Filtering using free text. r=Honza
Status: UNCONFIRMED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 70
Assignee: nobody → E0032242
You need to log in before you can comment on or make changes to this bug.