Closed Bug 1575346 Opened 5 months ago Closed 5 months ago

The panel doesn't get resized correctly when going into a subpanel

Categories

(Firefox :: Site Identity, defect, P3)

defect

Tracking

()

VERIFIED FIXED
Firefox 70
Tracking Status
firefox70 --- verified

People

(Reporter: ehsan, Assigned: nhnt11)

References

(Blocks 1 open bug)

Details

(Whiteboard: [privacy-panel][skyline])

Attachments

(2 files)

Attached image Screenshot

STR:

  1. Go to https://www.cnn.com
  2. Open the protections panel.
  3. Click on the (i) icon to expand the header.
  4. Go to one of the subpanels (for example, Social Media Trackers, but doesn't matter which one).

There is a visible blank area to the bottom of the bottom at the "logical bottom" of the panel.

Please see the screenshot.

Hmm, actually this bug doesn't happen in the "Fingerprinters" and "Cryptominers" subpanels. https://senglehardt.com/test/trackingprotection/test_pages/fingerprinting_and_cryptomining_and_cookies.html is a good test page here.

Whiteboard: [privacy-panel][skyline]
Priority: -- → P3
Assignee: nobody → nhnt11
Status: NEW → ASSIGNED
Pushed by nhnt11@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/35ea0a1e1458
Add offset for info message when setting subview max-height. r=timhuang
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 70

I have managed to reproduce the issue in an older build of Fx70.0a1.
The issue is verified fixed using the latest Fx70.0a1 (buildID: 20190825213650) on windows 10, macOS 10.14.5 and Ubuntu 18.04. The "Manage Protection Settings" bar is correctly displayed at the bottom of the doorhanger.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.