If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Crash cancelling "New Account Setup" from mailto: link

VERIFIED DUPLICATE of bug 144908

Status

SeaMonkey
MailNews: Account Configuration
--
critical
VERIFIED DUPLICATE of bug 144908
15 years ago
13 years ago

People

(Reporter: Christopher Conway, Assigned: racham)

Tracking

({crash})

Trunk
PowerPC
Mac OS X
crash

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
I don't have an account set up in my Mozilla profile, because I don't use
Mail/News. If I accidentally click on a mailto: link, a Mail composer window
comes up with a "New Account Setup" pop-up. I click "Cancel" and a "Are you sure
you want to exit?" pop-up appears.  If I click "Cancel" again, the "New Account
Setup" dialogue reappears and then the whole application crashes. This is 100%
reproducible on my system.
(Reporter)

Comment 1

15 years ago
I have just confirmed that this DOES NOT happen when I open the Mail/News window
explicitly from the Window menu. It only happens when Mail/News is implicitly
opened by a "mailto:" link.
(Reporter)

Comment 2

15 years ago
I'm sorry, I forgot the Build ID: 2002052918, running on Mac OS 10.1.5.

Comment 3

15 years ago
When I do this I get the Create New Account dialogue. When I click cancel - it
just cancels :-). Are you sure you want to exit is not asked. Tested by clicking
on your name above.
Mozilla 2002071403 Mac OS X 10.1.5

Updated

15 years ago
Severity: normal → critical
Keywords: crash

Comment 4

15 years ago
Christopher, can you please attach a crash report (stack trace) generated by
this crash?
Keywords: stackwanted
(Reporter)

Comment 5

15 years ago
Created attachment 91394 [details]
stack trace
(Reporter)

Comment 6

15 years ago
Here's the highlights from the stack trace:

Exception:  EXC_BAD_ACCESS (0x0001)
Codes:      KERN_PROTECTION_FAILURE (0x0002) at 0x00000794

Thread 0 Crashed:
 #0   0x00000794 in 0x794
 #1   0x01efd110 in nsToolkit::GetTopWidget(OpaqueWindowPtr *, nsIWidget **)
 #2   0x01f13a90 in nsMacMessagePump::DoActivate(EventRecord &)
 #3   0x01f12a8c in nsMacMessagePump::DispatchEvent(int, EventRecord *)
 #4   0x01f12628 in nsAppShell::DispatchNativeEvent(int, void *)
 #5   0x01e4904c in nsXULWindow::ShowModal(void)
 #6   0x01e316c0 in nsWebShellWindow::ShowModal(void)
 #7   0x01e45d6c in nsContentTreeOwner::ShowAsModal(void)
 #8   0x01dd13f8 in nsWindowWatcher::OpenWindowJS(nsIDOMWindow *, char const *,
char const *, char const *, int, unsigned int, long *,  *)
 #9   0x028342d0 in OpenInternal__16GlobalWindowImplFRC9nsAStringRC9nsAStringRC9ns
 #10  0x0282f02c in GlobalWindowImpl::OpenDialog(nsIDOMWindow **)
 #11  0x005bce9c in XPTC_InvokeByIndex
 #12  0x005bcd90 in XPTC_InvokeByIndex
 #13  0x01c55594 in 0x1c55594
 #14  0x01c5ba2c in XPC_WN_CallMethod(JSContext *, JSObject *, unsigned int,
long *, long *)
 #15  0x01bd4c1c in js_Invoke
 #16  0x01bdccc4 in 0x1bdccc4
 #17  0x01bd5110 in js_Execute
 #18  0x01bb5c4c in JS_EvaluateUCScriptForPrincipals
 #19  0x0281f164 in nsJSContext::EvaluateString(nsAString const &, void *,
nsIPrincipal *, char const *)
 #20  0x0283529c in GlobalWindowImpl::RunTimeout(nsTimeoutImpl *)
 #21  0x02835ec0 in GlobalWindowImpl::TimerCallback(nsITimer *, void *)
 #22  0x00627804 in nsTimerImpl::Fire(void)
 #23  0x006279b8 in handleTimerEvent(TimerEventType *)

Comment 7

15 years ago
sounds identical to bug 138462, except you are crashing (that bug has a JS
exception where you crash).  I don't know why you're crashing, but I would bet
that the patch in that bug would fix your problems as it would never get to that
point (if nothing else).
Depends on: 138462
Keywords: stackwanted

Comment 8

15 years ago
This is a duplicate of bug 144908.

Comment 9

15 years ago

*** This bug has been marked as a duplicate of 144908 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 10

15 years ago
Verified duplicate.
Status: RESOLVED → VERIFIED

Updated

15 years ago
No longer depends on: 138462
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.