Closed Bug 1575516 Opened 4 months ago Closed 3 months ago

The “Discard Unsaved Changes?” pop-up is not displayed if the “Edit” mode of a saved login is opened while logging into the website using the credentials from the selected login

Categories

(Firefox :: about:logins, defect, P2)

70 Branch
Desktop
All
defect

Tracking

()

VERIFIED FIXED
Firefox 71
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox68 --- unaffected
firefox69 --- disabled
firefox70 --- verified
firefox71 --- verified

People

(Reporter: simona.rosu, Assigned: jaws)

References

Details

(Keywords: dataloss, Whiteboard: [passwords:management] [skyline])

Attachments

(2 files)

[Affected versions]:

  • Firefox latest Nightly 70.0a1 (2019-08-20) (64-bit)

[Affected Platforms]:

  • Mac 10.14
  • Windows 10 x64
  • Ubuntu 16.04 x64

[Prerequisites]:

  • Have at least one saved login.

[Steps to reproduce]:

  1. Open the latest Nightly browser with the profile from prerequisites.
  2. Navigate to "about:logins" page and click one of the saved logins.
  3. Click on the “Edit” button and edit the username and password.
  4. Click on the website address and logging in.
  5. Focus back to the “about:logins” page.
  6. Observe the behavior.

[Expected result]:

  • The “Discard Unsaved Changes?” pop-up is displayed.
  • The password and the username are not updated.
    Or
  • The “Edit” mode is still opened.

[Actual result]:

  • The “Edit” mode is dismissed.
  • The changes from the Username field are displayed until the page is refreshed or another login is selected.
  • The Password field seems to be unchanged, but if the “Edit” button is clicked the previously added characters to the password are displayed.

[Notes]:

  • This behavior does not affect the future logins on the website because the changes are not saved.
  • Attached a screen recording with the issue.
Keywords: dataloss
Priority: -- → P2

This is a bug in the loginModified function. It should check if the loginFromForm matches the updated login and prompt if it doesn't.

Assignee: nobody → jaws
Status: NEW → ASSIGNED
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8431f1da3dac
Show the Discard Changes dialog if a login is modified while being edited. r=MattN
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla71

I have verified this issue on the latest Nightly 71.0a1 (Build ID: 20190918100042) (64-bit) on Windows 7, MacOS 10.14 and Arch Linux 4.14.

  • The “Discard Unsaved Changes?” pop-up is correctly displayed if the “Edit” mode of a saved login is opened while logging into the website using the credentials from the selected login.
Status: RESOLVED → VERIFIED

I have verified this issue on the Firefox Beta 70.0b9 (Build ID: 20190923154733) (64-bit) on Windows 7, MacOS 10.14 and Arch 4.14.

  • The “Discard Unsaved Changes?” pop-up is correctly displayed if the “Edit” mode of a saved login is opened while logging into the website using the credentials from the selected login.
Component: Password Manager → about:logins
Product: Toolkit → Firefox
Target Milestone: mozilla71 → Firefox 71
Version: unspecified → 70 Branch
You need to log in before you can comment on or make changes to this bug.