Closed Bug 1575531 Opened 4 months ago Closed 3 months ago

First character in address bar text field is slightly cut off in compact density mode on low-DPI screens

Categories

(Core :: Graphics, defect, P2)

70 Branch
x86_64
macOS
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox69 --- unaffected
firefox70 - unaffected
firefox71 --- unaffected

People

(Reporter: ato, Unassigned)

Details

(Keywords: regression, regressionwindow-wanted)

Attachments

(5 files)

The first character in the address bar URL text field is seemingly
cut off by one or two pixels, causing the character’s antialiasing
to be missing on the left hand side. See the attached screenshots.

This is a recent regression, but I don’t have a regression range.

[Tracking Requested - why for this release]: UX glitch in address bar.

Keywords: regression

Closeup of previous screenshot shows that the ‘g’ is missing
antialiasing on the left hand side. Also quite noticable with the
‘c’ character.

Has Regression Range: --- → no
Component: Address Bar → Search

Dale, can you help find an owner for this issue?

Component: Search → Address Bar
Flags: needinfo?(adw)

Hmm, I can't reproduce this. I'm using a 2x ("Retina") screen though, and it looks from the screenshot like Andreas is on a 1x screen. That could be related. I can't reproduce it after setting layout.css.devPixelsPerPx = 1, either. They recently did some work on the identity and tracking-protection icons, so that's a possible cause.

Andreas, do you have any userChrome.css modifications? Is it possible for you to find a regression range?

Dao, can you reproduce this? Also possible it's Mac-only though...

Flags: needinfo?(dao+bmo)
Flags: needinfo?(ato)
Flags: needinfo?(adw)
Priority: -- → P2

(I’m away on holiday for a week without access to a low-DPI display,
but as adw mentioned I also cannot reproduce this on a high-DPI
display.)

I can't reproduce this on Ubuntu (100% scale).

The screenshot in comment 0 shows the UI density set to compact which I guess could also make a difference.

Flags: needinfo?(dao+bmo)

I’m back from holiday now.

(In reply to Dão Gottwald [::dao] from comment #6)

The screenshot in comment 0 shows the UI density set to compact
which I guess could also make a difference.

dao is entirely correct here, this is only reproducible with the UI
density set to compact in normal DPI.

Flags: needinfo?(ato)
Summary: First character in address bar text field is slightly cut off → First character in address bar text field is slightly cut off in compact density mode on low-DPI screens
Component: Address Bar → Graphics
Product: Firefox → Core

Jessie, can you help find someone to look into this?

Flags: needinfo?(jbonisteel)

Andreas - can you use Mozgregression to try and find a regression range?

Flags: needinfo?(jbonisteel) → needinfo?(ato)

(In reply to Andreas Tolfsen 「:ato」 from comment #5)

(I’m away on holiday for a week without access to a low-DPI display,
but as adw mentioned I also cannot reproduce this on a high-DPI
display.)

If anyone's needing to investigate this on a Retina-display machine, it's possible to reproduce this by checking the "Open in Low Resolution" option in the application's Get Info panel in the Finder.

Thanks for the tip, jfkthame!

It looks like this problem has resolved itself, as you can see from
the attached screenshot from 20190915214245 this morning.

Flags: needinfo?(ato)
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → WORKSFORME

Would you mind checking it one last time in beta 70?

Where do I find a build for beta 70?

Flags: needinfo?(lhenry)

Nevermind, found one on https://www.mozilla.org/en-US/firefox/channel/desktop/.

This is not reproducible on 70.0b9 (20190923154733) either.

Flags: needinfo?(ato)
You need to log in before you can comment on or make changes to this bug.