Closed Bug 1575658 Opened 2 years ago Closed 2 years ago

Move Firefox wordmark to browser/branding

Categories

(Firefox :: New Tab Page, enhancement, P1)

enhancement

Tracking

()

RESOLVED FIXED
Firefox 73
Iteration:
73.1 - Dec 2 - Dec 15
Tracking Status
firefox73 --- fixed

People

(Reporter: k88hudson, Assigned: emcminn)

References

Details

Attachments

(1 file)

The wordmark/logo that shows up on the new tab page when only search is enabled currently lives in browser/components/newtab/data/content/assets/firefox-wordmark.svg; we should move it to browser/branding.

Assignee: nobody → emcminn

Probably land bug 1574995 first then move the updated file to the correct location?

Depends on: 1574995
Iteration: --- → 71.1 - Sept 2 - 15
Priority: -- → P1

K8, is this something you/Emily are rocking out this iteration?

Flags: needinfo?(khudson)

Yep, just adding a second reviewer on this. Thanks!

Flags: needinfo?(khudson)
Iteration: 71.1 - Sept 2 - 15 → 71.2 - Sept 16 - 29
Flags: needinfo?(khudson)
Iteration: 71.2 - Sept 16 - 29 → 71.3 - Sept 30 - Oct 13

There's a r+ patch which didn't land and no activity in this bug for 2 weeks.
:emcminn, could you have a look please?
For more information, please visit auto_nag documentation.

Flags: needinfo?(emily)

Mardak - can you help this get some eyeballs on it? There's a r+ patch which didn't land and no activity in this bug for 2 weeks. And Kate's NI has been here for a bit. It's not urgent, but would be good to wrap up.

Flags: needinfo?(edilee)
Depends on: 1582879

Hey Jess, I was waiting for Bug 1582879 (which is now landed)

Flags: needinfo?(khudson)
Flags: needinfo?(emcminn)

The patch is close to landing but there was a slight bitrot since it was last touched in october. Looks like emily is assigned and can commandeer the revision to update and land.

Flags: needinfo?(edilee)
Iteration: 71.3 - Sept 30 - Oct 13 → 73.1 - Dec 2 - Dec 15

(In reply to Ed Lee :Mardak from comment #8)

The patch is close to landing but there was a slight bitrot since it was last touched in october. Looks like emily is assigned and can commandeer the revision to update and land.

Hi Ed, is there anything that needs to be done here besides updating/rebasing the patch? I think your last requested change has been taken care of; I don't see a reference to firefox-wordmark.svg in tools/lint/license.yml.

Flags: needinfo?(edilee)

Where are you checking tools/lint/license.yml? The latest change I see is the one that added the entry:

$ git log autoland tools/lint/license.yml
* d13aee4004c36 - Bug 1596911 - refresh the ignore list with the new exts r=Gijs (13 days ago) <Sylvestre Ledru>

https://hg.mozilla.org/mozilla-central/log/tip/tools/lint/license.yml

Flags: needinfo?(edilee) → needinfo?(emcminn)

(In reply to Ed Lee :Mardak from comment #10)

Where are you checking tools/lint/license.yml? The latest change I see is the one that added the entry:

$ git log autoland tools/lint/license.yml
* d13aee4004c36 - Bug 1596911 - refresh the ignore list with the new exts r=Gijs (13 days ago) <Sylvestre Ledru>

https://hg.mozilla.org/mozilla-central/log/tip/tools/lint/license.yml

Ah I see it now, I was looking at the wrong diff. My bad!

EDIT: Updated the diff and fixed license.yml, should be good to go :)

Flags: needinfo?(emcminn)

Hey Emily - what's the next steps to wrap this up? Are you working on it more in this iteration (73.2)?

Flags: needinfo?(emcminn)
Pushed by elee@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/695c718a37e4
Moved firefox-wordmark.svg to browser/branding r=MattN,Mardak

This should be all done, it just needed to be rebased because it had been stale for a while. I'm not able to land patches yet, but if someone else would like to do it it should be good to go :)

Flags: needinfo?(emcminn)
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 73
You need to log in before you can comment on or make changes to this bug.