Closed Bug 1575693 Opened 2 years ago Closed 2 years ago

browser.windows events no longer fire

Categories

(Thunderbird :: Add-Ons: Extensions API, defect)

defect
Not set
normal

Tracking

(thunderbird_esr6869+ fixed, thunderbird69 fixed, thunderbird70 fixed)

RESOLVED FIXED
Thunderbird 70.0
Tracking Status
thunderbird_esr68 69+ fixed
thunderbird69 --- fixed
thunderbird70 --- fixed

People

(Reporter: darktrojan, Assigned: darktrojan)

References

Details

(Keywords: regression)

Attachments

(1 file, 1 obsolete file)

We don't have a test on the windows API, and it's regressed. :-(

onCreated, onRemoved, and onFocusChanged don't fire, I assume because the of the changes to the event code in toolkit.

Blocks: 1575710
Attached patch 1575693-windows-events-1.diff (obsolete) — Splinter Review

I've copied what m-c has. (Test is mine.) We should've made this change ages ago, but didn't notice because there was no test.

Attachment #9087257 - Flags: review?(mkmelin+mozilla)
Attachment #9087257 - Flags: approval-comm-esr68?
Attachment #9087257 - Flags: approval-comm-beta?

Left some stray pieces behind from an earlier iteration.

Attachment #9087257 - Attachment is obsolete: true
Attachment #9087257 - Flags: review?(mkmelin+mozilla)
Attachment #9087257 - Flags: approval-comm-esr68?
Attachment #9087257 - Flags: approval-comm-beta?
Attachment #9087260 - Flags: review?(mkmelin+mozilla)
Attachment #9087260 - Flags: approval-comm-esr68?
Attachment #9087260 - Flags: approval-comm-beta?
Attachment #9087260 - Flags: review?(mkmelin+mozilla) → review+
Keywords: checkin-needed
Comment on attachment 9087260 [details] [diff] [review]
1575693-windows-events-2.diff

Should that go to ESR without much (on no) beta exposure? So far no one complained about the thing not working, right?
Attachment #9087260 - Flags: approval-comm-beta? → approval-comm-beta+

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/f4c0e4703937
Fix browser.windows events. r=mkmelin DONTBUILD

Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 70.0

I'd prefer it to be in a beta, but not if that prevents it making 68.1. It's a regression from 60, so we'd best not have it broken for too long.

Attachment #9087260 - Flags: approval-comm-esr68? → approval-comm-esr68+
You need to log in before you can comment on or make changes to this bug.