Closed Bug 1575785 Opened 1 year ago Closed 1 year ago

There should be a confirmation prompt when the user tries to Report a Broken site from the Tracking Protection panel

Categories

(Firefox :: Protections UI, enhancement, P3)

Desktop
All
enhancement

Tracking

()

VERIFIED FIXED
Firefox 72
Tracking Status
firefox70 --- wontfix
firefox71 --- wontfix
firefox72 --- verified

People

(Reporter: rares.doghi, Assigned: johannh)

Details

(Whiteboard: [privacy-panel][skyline])

Attachments

(1 file)

[Affected versions]:
Nightly 70.0a1

[Affected platforms]:
Platforms: All

Steps :

  1. Launch the Firefox browser and reach www.reddit.com
  2. Click on the Shield Icon from the URL bar.
  3. Click the "Site not Working?" link.
  4. Click on the "Send a report" link from the sub panel.
  5. Write any text in the text-area and click Send Report.

Expected Results :
A Confirmation prompt, or a Pop-up bubble or any type of confirmation should be displayed when the user clicks the Send report button.
"Your report has been sent", "Thank you for your Report" any message will do.

It could also be something like changing the "Send Report" button to a grey/disabled state without closing the panel, but it would still confuse the user without a confirmation message.

Actual Results :
The panel closes without confirmation, it might push the user to send the same report multiple times thinking he might have clicked outside of the box.

To be clear this isn't in the design spec but it's a nice suggestion, thanks. I'll add it to the triage...

Whiteboard: [privacy-panel][skyline]

Johann, is this still something you might want to aim at 70/skyline? Might be better to make a p2 and add it for 71 enhancements.

Flags: needinfo?(jhofmann)

We'll take a look...

Flags: needinfo?(jhofmann)
Priority: -- → P3
Flags: needinfo?(jhofmann)
Assignee: nobody → jhofmann
Status: NEW → ASSIGNED
Flags: needinfo?(jhofmann)
Pushed by jhofmann@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4905af6536bd
Show a confirmation hint when a user successfully submitted a breakage report. r=nhnt11
Pushed by jhofmann@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d08754485c25
Show a confirmation hint when a user successfully submitted a breakage report. r=nhnt11
Pushed by nhnt11@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/5f243fa3ab1e
Show a confirmation hint when a user successfully submitted a breakage report. r=nhnt11
Pushed by nhnt11@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/dde543f12c83
Show a confirmation hint when a user successfully submitted a breakage report. r=nhnt11
Flags: needinfo?(jhofmann)
Pushed by nhnt11@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/9c00153e7458
Show a confirmation hint when a user successfully submitted a breakage report. r=nhnt11
Pushed by nhnt11@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/8792937b0a60
Show a confirmation hint when a user successfully submitted a breakage report. r=nhnt11
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 72

Since the status are different for nightly and release, what's the status for beta?
For more information, please visit auto_nag documentation.

This issue is verified as fixed in our latest nightly build 72.0a1 (2019-11-27), Turned out better than what I had in mind :)

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.