Closed Bug 1575853 Opened 4 months ago Closed 4 months ago

XUL section sizes are being reported at 0 since August 15th

Categories

(Release Engineering :: Applications: MozharnessCore, defect)

defect
Not set

Tracking

(firefox70 fixed)

RESOLVED FIXED
Tracking Status
firefox70 --- fixed

People

(Reporter: mconley, Assigned: glandium)

References

(Regression)

Details

Attachments

(2 files)

Type: defect → task

I can't tell whether this could be a dup of bug 1571617 or not...

(In reply to Nathan Froyd [:froydnj] from comment #1)

I can't tell whether this could be a dup of bug 1571617 or not...

We switched to fetching artifacts which installs them in a different location. The code that uses rust-size needs to be updated on where to find it.

Type: task → defect
Flags: needinfo?(mh+mozilla)
Regressed by: 1573435

I wonder if a failure along those paths should be a bit more vocal...

How has this not caused alerts?

Flags: needinfo?(mh+mozilla) → needinfo?(igoldan)

Ah, I know why, because we're exactly in the case discussed in bug 1571617. I'm confused why the graph has values, though.

Flags: needinfo?(igoldan)

Scrap that, we're not in the case where the result is ignored entirely, we're still in the case where mozharness does return 0 in that case, so the graph does have values. So back with the question. How has this not caused alerts?

Flags: needinfo?(igoldan)
Pushed by mh@glandium.org:
https://hg.mozilla.org/integration/autoland/rev/c789725af1e4
Pick rust-size from the right place after bug 1573435. r=nalexander
Assignee: nobody → mh+mozilla
Component: General → Applications: MozharnessCore
Product: Core → Release Engineering
QA Contact: jlund

(In reply to Mike Hommey [:glandium] from comment #6)

Scrap that, we're not in the case where the result is ignored entirely, we're still in the case where mozharness does return 0 in that case, so the graph does have values. So back with the question. How has this not caused alerts?

The subtest wasn't configured to alert. If you look at its associated PERFHERDER_DATA section, you can see the config.

    {
      "subtests": [],
      "extraOptions": [
        "nightly"
      ],
      "shouldAlert": false,
      "name": "XUL section sizes",
      "value": 0
    },

The script that's outputting PERFHERDER_DATA should set "shouldAlert": true for "name": "XUL section sizes".

Flags: needinfo?(igoldan)
Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.