Closed Bug 1575868 Opened 1 year ago Closed 2 months ago

[meta] Make Picture-in-Picture Fission-compatible

Categories

(Toolkit :: Video/Audio Controls, task, P3)

task

Tracking

()

RESOLVED FIXED
Fission Milestone M6b

People

(Reporter: mconley, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: meta)

Unfortunately, while still a young feature, this was written because we had JSWindowActor support, so it also needs to be ported.

Priority: -- → P3
Depends on: 1576915, 1589517
Keywords: meta
Summary: Make Picture-in-Picture Fission-compatible → [meta] Make Picture-in-Picture Fission-compatible
Blocks: 1596790

PiP blocks enabling Fission in Nightly (M6).

Fission Milestone: --- → M6
Depends on: 1599795
Duplicate of this bug: 1615843
Blocks: 1614827
Duplicate of this bug: 1614827
Duplicate of this bug: 1621818

Tracking for Fission milestone M6c because making PiP Fission-compatible blocks enabling Fission in Nightly.

Fission Milestone: M6 → M6c
Depends on: 1648107
Duplicate of this bug: 1650587

PiP for Fission needs to be fixed for M6b. Mike, does it have any DOM dependency?

Fission Milestone: M6c → M6b
Flags: needinfo?(mconley)

(In reply to Neha Kochar [:neha] from comment #7)

PiP for Fission needs to be fixed for M6b. Mike, does it have any DOM dependency?

Not according to this:
https://bugzilla.mozilla.org/show_bug.cgi?id=1648107#c9

There's also this https://phabricator.services.mozilla.com/D86863

No longer blocks: 1596790

Nope, DOM dependencies are all cleared - once bug 1648107 is closed, we can probably close this meta out.

Flags: needinfo?(mconley)

PiP appears to be compatible with Fission now. I think we're done here.

Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.