Closed Bug 1575905 Opened 1 year ago Closed 11 months ago

Surface enable/disable actions in Themes Manager

Categories

(Toolkit :: Add-ons Manager, enhancement, P1)

enhancement

Tracking

()

RESOLVED FIXED
mozilla72
Tracking Status
firefox72 --- fixed

People

(Reporter: amyt, Assigned: mstriemer)

References

(Depends on 1 open bug)

Details

Attachments

(7 files)

The enable/disable actions are currently in the meatball menu of the themes list view. We would like to surface them one level higher so users can enable and disable themes without having to click into the meatball menu.

Flags: needinfo?(emanuela)
Priority: -- → P1
See Also: → 1565057
Assignee: nobody → mstriemer

Per 9/26/19 meeting:

  • Change "Enabled" section header to "Your Active Theme"
  • Change "Disabled" section header to "Other Installed Themes"
  • Add "Disable" button to the current theme
  • Add "Enable" button to themes listed under "Your Themes"
  • Meatball menu options should be "Remove" and "Manage"
  • Add theme skeleton to the 3 default themes

Emanuela to attach sketches, Jeff to review proposed copy changes above.

Flags: needinfo?(jpfaller)

Can we consider "Your Themes" instead of "Your Theme Collection"? The term "collection" can be confused with the AMO feature.

Yep, edited comment 1 with the update.

For Disabled Themes, can we do "Installed Themes"

Flags: needinfo?(jpfaller)

How about "Your Active Theme" for the current theme, and "Other Installed Themes" for the disabled themes?

Flags: needinfo?(jpfaller)

I'm fine with that!

Flags: needinfo?(jpfaller)
Attached image dark-theme.svg

Skeleton Dark Theme

Flags: needinfo?(emanuela)
Attached image light-theme.svg

Skeleton light theme

Attached image default-theme.svg

Skeleton default theme

Attached image themes-ui-2019.jpg

Reference mock.

Not included in the mock but included in the actual page is the section Recommended Themes below Other Installed Themes.

See Also: → 1570792
Pushed by mstriemer@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/13d8e61774f1
Part 1: Show theme previews for built-in themes, hide theme icons r=rpl,Gijs
https://hg.mozilla.org/integration/autoland/rev/67f284b0e4c2
Part 2: Surface enable/disable button on theme cards r=rpl,Gijs
Pushed by csabou@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/58af480a23ba
Part 1: Show theme previews for built-in themes, hide theme icons r=rpl,Gijs
https://hg.mozilla.org/integration/autoland/rev/2283d57d384b
Part 2: Surface enable/disable button on theme cards r=rpl,Gijs
Status: NEW → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla72

Hello,

Verified the fix on the latest Nightly (72.0a1/20191126212708) under Windows 10 Pro 64-bit and MacOS Catalina 10.15.

Going over several variants of the layout of the Themes Manager which were proposed throughout the comments in this ticket and the state of the Themes Manager on the latest Nightly, the following were observed:

  • in what regards the buttons to enable/disable themes present on the themes cards, these have been detailed in Comment 10 of https://bugzilla.mozilla.org/show_bug.cgi?id=1570792
  • the headers proposed for the Enabled and Disabled themes are not present. The old ones are still used.
  • built-in themes have previews now

Please see the attached screenshot for further details.

Can you please confirm that these are intended changes before changing the status of the bug? Thank you!

Flags: needinfo?(mstriemer)
Depends on: 1599813

That's correct. I filed bug 1599813 since the headings should've been updated, but I forgot about it.

Flags: needinfo?(mstriemer)

Hello,

I will verify this fix after the dependency (https://bugzilla.mozilla.org/show_bug.cgi?id=1599813) has been fixed and validated.

Duplicate of this bug: 1516355
See Also: → 1505781
You need to log in before you can comment on or make changes to this bug.