Closed Bug 1575910 Opened Last month Closed 29 days ago

Implement button positioning in login-item per design spec

Categories

(Toolkit :: Password Manager, enhancement, P1)

enhancement

Tracking

()

VERIFIED FIXED
mozilla70
Tracking Status
firefox70 --- verified
firefox71 --- verified

People

(Reporter: ntim, Assigned: ntim)

References

Details

(Whiteboard: [skyline] [passwords:management] )

Attachments

(2 files)

The buttons should be closer to the text.

Priority: -- → P1
Pushed by ntim.bugs@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/76ed02ac9371
Implement button positioning in login-item per design spec. r=MattN,jaws
Status: NEW → RESOLVED
Closed: 29 days ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70
Regressions: 1576176

Password Copy button spacing and behavior for short and long passwords looks good.

But the Username ellipsis should align next to the edge of the field, and 20px padding is needed between the ellipsis and the copy button.

Flags: needinfo?(ntim.bugs)

(In reply to rgaddis from comment #4)

Created attachment 9087848 [details]
Screen Shot 2019-08-23 at 2.42.31 PM.png

Password Copy button spacing and behavior for short and long passwords looks good.

But the Username ellipsis should align next to the edge of the field, and 20px padding is needed between the ellipsis and the copy button.

This is probably because the last letter in your screenshot is a shorter one horizontally (l as opposed to w for example), I don't think there's much we can do about it unfortunately.

The padding is fixable though, I filed bug 1577022.

Flags: needinfo?(ntim.bugs)
Flags: qe-verify+

I have verified this issue on the latest Beta 70.0b4 and the Nightly 71.0a1 (2019-09-09) build on Windows 7 x64, Mac 10.14 and Ubuntu 16.04 x64.

  • The "Copy" buttons are closer to the text as are displayed in the specs.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.