SELECTED on Multiple <SELECT> box not working properly.

RESOLVED WORKSFORME

Status

()

Core
Layout: Form Controls
--
major
RESOLVED WORKSFORME
16 years ago
16 years ago

People

(Reporter: Nick Tomkin, Assigned: rods (gone))

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)
BuildID:    2002062604

Using CFML, I made it so that a select box would render multiple SELECTED 
attributes. In Mozilla, it will only HIGHLIGHT the first option rather than all 
with the attribute "SELECTED" This fails for XHTML compliant SELECTED="yes" as 
well.



Reproducible: Always
Steps to Reproduce:
1. Code a simple <SELECT MULTIPLE> form element with multiple <OPTION SELECTED> 
fields.
2. Load page to view only first <OPTION> element highlighted.


Actual Results:  The form element chooses to only select the first <OPTION>, or 
at least only highlight the first <OPTION>.

<SELECT NAME="Welcoming" MULTIPLE>
    <OPTION VALUE="0" SELECTED>Hello</OPTION>
    <OPTION VALUE="1" SELECTED>Goodbye</OPTION>
</SELECT>



Expected Results:  Both <OPTION> elements should be highlighted to denote 
selection.
they are for me. Testcase? Maybe misspelled "MULTIPLE"?

Comment 2

16 years ago
WFM too.  Try updating your build.

Comment 3

16 years ago
Created attachment 97303 [details]
testcase

WORKSFORME moz 2002082208 / win98

Comment 4

16 years ago
reporter, do you have a minimal testcase that demonstrates the problem?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.