Closed Bug 1575968 Opened 2 months ago Closed 2 months ago

Add strsclnt option to enforce the use of either IPv4 or IPv6

Categories

(NSS :: Tools, defect, P1)

defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: kjacobs, Assigned: kjacobs)

References

Details

Attachments

(1 file)

While testing a patch for bug 1485533, I hit some strsclnt timeouts on taskcluster Mac. The cause is strsclnt attempting to open an IPv6 socket to connect to seflserv, which binds as IPv4.

There seems to be a lot of history and some abandoned patches on this issue, but the simplest solution is to apply the patch from bug 908617 to strsclnt. That is, to add "-4" and "-6" switches, allowing the user to specify the appropriate version. The default behavior will remain unchanged.

Blocks: 1485533
Keywords: checkin-needed
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → 3.46
You need to log in before you can comment on or make changes to this bug.