Closed Bug 1576029 Opened 7 months ago Closed 7 months ago

List Updates - Logins & Passwords

Categories

(Firefox :: about:logins, task, P2)

task

Tracking

()

RESOLVED FIXED
Firefox 70
Tracking Status
firefox70 --- fixed

People

(Reporter: ddurst, Assigned: ntim)

References

Details

(Whiteboard: [passwords:management] [skyline])

Attachments

(3 files)

Including a few things to change to match the spec:

Spec reference: https://mozilla.invisionapp.com/share/EJRHBMEDKF8#/screens/380121227

  • Remove shadow from “Create New Login” box at base of login list
  • Too much spacing for active sort state (around the selected sort, including the dropdown arrow)
  • Mouse cursor should not change to text cursor when hovering over login list items

One note for Ryan: the placement of the dropdown arrow, as currently coded, is going to vary because the length of the sort strings varies -- removing the padding-inline-end, for example, may make the padding look good for "Name (A-Z)", but it will look too big for the next option, and too small for the last option. It may be possible to recalculate that per selected item, but since that'd be JavaScript, I'm not clear how badly we want it, hence the NI. Tightening the space between "Sort by:" and that is not affected by this (I assume).

Flags: needinfo?(rgaddis)

I'm curious, how is this (sort arrows) currently handled on our Lockwise web extension? It looks and behaves as I'm hoping to intend here... attachments provided.

Flags: needinfo?(rgaddis)

(In reply to rgaddis from comment #1)

I'm curious, how is this (sort arrows) currently handled on our Lockwise web extension? It looks and behaves as I'm hoping to intend here... attachments provided.

The Lockwise extension recalculates and sets the select width via JavaScript everytime you change option. Personally, I'm not a big fan of doing this as we might end up regressing uncommon situations like different locales/fonts, whereas leaving the current behaviour handles this for us for free.

Assignee: nobody → ntim.bugs
Status: NEW → ASSIGNED
Pushed by ntim.bugs@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/fbbf527bd3a8
Updates to login-list CSS. r=jaws
Status: ASSIGNED → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70
Component: Password Manager → about:logins
Product: Toolkit → Firefox
Target Milestone: mozilla70 → Firefox 70
Regressions: 1620531
You need to log in before you can comment on or make changes to this bug.