Closed Bug 1576034 Opened 4 months ago Closed 3 months ago

Permanent [taskcluster:error] exit status 101 caused by rust warnings

Categories

(Core :: Graphics: WebRender, defect, P5)

defect

Tracking

()

RESOLVED FIXED
mozilla70
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox68 --- unaffected
firefox69 --- unaffected
firefox70 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: glandium)

Details

(Keywords: regression)

Attachments

(1 file)

Filed by: nbeleuzu [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=263047866&repo=autoland
Full log: https://queue.taskcluster.net/v1/task/G6yJkkYJT_eEQxXJAcAyHw/runs/0/artifacts/public/logs/live_backing.log
Reftest URL: https://hg.mozilla.org/mozilla-central/raw-file/tip/layout/tools/reftest/reftest-analyzer.xhtml#logurl=https://queue.taskcluster.net/v1/task/G6yJkkYJT_eEQxXJAcAyHw/runs/0/artifacts/public/logs/live_backing.log&only_show_unexpected=1


[task 2019-08-23T00:49:17.928Z] error: trait objects without an explicit dyn are deprecated
[task 2019-08-23T00:49:17.928Z] --> direct-composition\src\lib.rs:31:19
[task 2019-08-23T00:49:17.928Z] |
[task 2019-08-23T00:49:17.928Z] 31 | pub gleam: Rc<gleam::gl::Gl>,
[task 2019-08-23T00:49:17.928Z] | ^^^^^^^^^^^^^ help: use dyn: dyn gleam::gl::Gl
[task 2019-08-23T00:49:17.928Z] |
[task 2019-08-23T00:49:17.928Z] = note: -D bare-trait-objects implied by -D warnings
[task 2019-08-23T00:49:17.928Z]
[task 2019-08-23T00:49:17.928Z] error: trait objects without an explicit dyn are deprecated
[task 2019-08-23T00:49:17.928Z] --> direct-composition\src\lib.rs:153:19
[task 2019-08-23T00:49:17.928Z] |
[task 2019-08-23T00:49:17.928Z] 153 | pub gleam: Rc<gleam::gl::Gl>,
[task 2019-08-23T00:49:17.928Z] | ^^^^^^^^^^^^^ help: use dyn: dyn gleam::gl::Gl
[task 2019-08-23T00:49:17.928Z]
[task 2019-08-23T00:49:18.045Z] error: aborting due to 2 previous errors
[task 2019-08-23T00:49:18.045Z]
[task 2019-08-23T00:49:18.090Z] error: Could not compile direct-composition.
[task 2019-08-23T00:49:18.090Z]
[task 2019-08-23T00:49:18.090Z] Caused by:
[task 2019-08-23T00:49:18.090Z] process didn't exit successfully: rustc --edition=2018 --crate-name direct_composition direct-composition\src\lib.rs --color never --crate-type lib --emit=dep-info,metadata -C panic=abort -C debuginfo=2 -C metadata=cec3d3c3c6357c49 -C extra-filename=-cec3d3c3c6357c49 --out-dir z:\task_1566517771\build\src\gfx\wr\target\debug\deps -C incremental=z:\task_1566517771\build\src\gfx\wr\target\debug\incremental -L dependency=z:\task_1566517771\build\src\gfx\wr\target\debug\deps --extern euclid=z:\task_1566517771\build\src\gfx\wr\target\debug\deps\libeuclid-38d799aef02d5952.rmeta --extern gleam=z:\task_1566517771\build\src\gfx\wr\target\debug\deps\libgleam-b34ad5556b55c863.rmeta --extern mozangle=z:\task_1566517771\build\src\gfx\wr\target\debug\deps\libmozangle-80c173f93edf380b.rmeta --extern webrender=z:\task_1566517771\build\src\gfx\wr\target\debug\deps\libwebrender-5661d8d5ec176474.rmeta --extern winapi=z:\task_1566517771\build\src\gfx\wr\target\debug\deps\libwinapi-a33fae6fd7fd6fee.rmeta --extern winit=z:\task_1566517771\build\src\gfx\wr\target\debug\deps\libwinit-db75946f622794a7.rmeta --deny warnings -L native=z:\task_1566517771\build\src\gfx\wr\target\debug\build\mozangle-66360d86159a2abc\out (exit code: 1)
[task 2019-08-23T00:49:18.095Z]
[task 2019-08-23T00:49:18.095Z] z:\task_1566517771\build\src\gfx\wr\direct-composition>if 101 NEQ 0 EXIT /b 101
[fetches 2019-08-23T00:49:18.106Z] removing Z:/task_1566517771/fetches
[fetches 2019-08-23T00:49:19.280Z] finished
[taskcluster 2019-08-23T00:49:19.304Z] Exit Code: 101
[taskcluster 2019-08-23T00:49:19.304Z] User Time: 0s
[taskcluster 2019-08-23T00:49:19.304Z] Kernel Time: 15.625ms
[taskcluster 2019-08-23T00:49:19.304Z] Wall Time: 35m52.8791184s
[taskcluster 2019-08-23T00:49:19.304Z] Result: FAILED
[taskcluster 2019-08-23T00:49:19.305Z] === Task Finished ===
[taskcluster 2019-08-23T00:49:19.305Z] Task Duration: 35m52.8810818s
[taskcluster 2019-08-23T00:49:19.831Z] Uploading redirect artifact public/logs/live.log to URL https://queue.taskcluster.net/v1/task/G6yJkkYJT_eEQxXJAcAyHw/runs/0/artifacts/public/logs/live_backing.log with mime type "text/plain; charset=utf-8" and expiry 2020-08-22T00:12:45.238Z
[taskcluster:error] exit status 101

(In reply to Narcis Beleuzu [:NarcisB] from comment #1)

The bustage strated with the update builds to use Rust 1.37 (Bug 1574275 ).
https://treeherder.mozilla.org/#/jobs?repo=autoland&tochange=01f5bb7c5337534c446d7f1c39d23b5e976878ec&searchStr=wrench&fromchange=4a20a1d7f1f3ab0e7667808982ec520b3267b31b&selectedJob=263065566

It's not clear to me why this is intermittent, I guess this is an odd periodic build that's the only one to use this file. Jeff, this is a new rust Werror, are you the right person to fix this?

Flags: needinfo?(erahm) → needinfo?(jmuizelaar)

I tried the obvious thing, which led me to another error:

[task 2019-08-23T03:47:00.214Z] error: trait objects without an explicit `dyn` are deprecated
[task 2019-08-23T03:47:00.214Z]    --> direct-composition\src\main_windows.rs:197:28
[task 2019-08-23T03:47:00.214Z]     |
[task 2019-08-23T03:47:00.214Z] 197 |     fn clone(&self) -> Box<api::RenderNotifier> {
[task 2019-08-23T03:47:00.214Z]     |                            ^^^^^^^^^^^^^^^^^^^ help: use `dyn`: `dyn api::RenderNotifier`
[task 2019-08-23T03:47:00.214Z]     |
[task 2019-08-23T03:47:00.214Z]     = note: `-D bare-trait-objects` implied by `-D warnings`
[task 2019-08-23T03:47:00.214Z] 
Summary: Intermittent [taskcluster:error] exit status 101 → Permanent [taskcluster:error] exit status 101
Flags: needinfo?(jmuizelaar)
Summary: Permanent [taskcluster:error] exit status 101 → Permanent [taskcluster:error] exit status 101 caused by rust warnings
Assignee: nobody → mh+mozilla
Pushed by mh@glandium.org:
https://hg.mozilla.org/integration/autoland/rev/6ebe9191d22f
Fix bare-trait-objects warnings in direct-composition. r=jrmuizel
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70
You need to log in before you can comment on or make changes to this bug.