Closed Bug 1576153 Opened 8 months ago Closed 5 months ago

Intermittent /html/cross-origin-embedder-policy/require-corp.https.html | "require-corp" top-level: creating a "none" popup should succeed. - assert_equals: expected true but got false

Categories

(Core :: DOM: Networking, defect, P2)

defect

Tracking

()

RESOLVED FIXED
mozilla72
Tracking Status
firefox-esr68 --- unaffected
firefox70 --- unaffected
firefox71 --- fixed
firefox72 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: juhsu)

References

(Blocks 1 open bug)

Details

(Keywords: intermittent-failure, regression, Whiteboard: [necko-triaged], [wptsync upstream][stockwell unknown])

Attachments

(1 file)

Filed by: btara [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=263113264&repo=try
Full log: https://queue.taskcluster.net/v1/task/N7fRXrHrTSmX8AtQmO_twg/runs/0/artifacts/public/logs/live_backing.log


[task 2019-08-23T11:47:26.749Z] 11:47:26 INFO - TEST-START | /html/cross-origin-embedder-policy/require-corp.https.html
[task 2019-08-23T11:47:26.750Z] 11:47:26 INFO - Closing window 33
[task 2019-08-23T11:47:26.808Z] 11:47:26 INFO - Closing window 35
[task 2019-08-23T11:47:28.905Z] 11:47:28 INFO -
[task 2019-08-23T11:47:28.905Z] 11:47:28 INFO - TEST-FAIL | /html/cross-origin-embedder-policy/require-corp.https.html | "require-corp" top-level: navigating a frame to "none" should fail - assert_equals: expected null but got Document node with 1 child
[task 2019-08-23T11:47:28.906Z] 11:47:28 INFO - @https://web-platform.test:8443/html/cross-origin-embedder-policy/require-corp.https.html:17:18
[task 2019-08-23T11:47:28.907Z] 11:47:28 INFO - Test.prototype.step_timeout/<@https://web-platform.test:8443/resources/testharness.js:1669:22
[task 2019-08-23T11:47:28.907Z] 11:47:28 INFO - Test.prototype.step@https://web-platform.test:8443/resources/testharness.js:1611:25
[task 2019-08-23T11:47:28.907Z] 11:47:28 INFO - Test.prototype.step_func/<@https://web-platform.test:8443/resources/testharness.js:1635:35
[task 2019-08-23T11:47:28.907Z] 11:47:28 INFO - TEST-FAIL | /html/cross-origin-embedder-policy/require-corp.https.html | "require-corp" top-level: navigating a frame from "require-corp" to "none" should fail - assert_equals: expected null but got Document node with 1 child
[task 2019-08-23T11:47:28.908Z] 11:47:28 INFO - bc.onmessage</<@https://web-platform.test:8443/html/cross-origin-embedder-policy/require-corp.https.html:34:20
[task 2019-08-23T11:47:28.908Z] 11:47:28 INFO - Test.prototype.step_timeout/<@https://web-platform.test:8443/resources/testharness.js:1669:22
[task 2019-08-23T11:47:28.908Z] 11:47:28 INFO - Test.prototype.step@https://web-platform.test:8443/resources/testharness.js:1611:25
[task 2019-08-23T11:47:28.908Z] 11:47:28 INFO - Test.prototype.step_func/<@https://web-platform.test:8443/resources/testharness.js:1635:35
[task 2019-08-23T11:47:28.909Z] 11:47:28 INFO - TEST-PASS | /html/cross-origin-embedder-policy/require-corp.https.html | "require-corp" top-level: creating a noopener "none" popup should succeed
[task 2019-08-23T11:47:28.909Z] 11:47:28 INFO - TEST-UNEXPECTED-FAIL | /html/cross-origin-embedder-policy/require-corp.https.html | "require-corp" top-level: creating a "none" popup should succeed. - assert_equals: expected true but got false
[task 2019-08-23T11:47:28.909Z] 11:47:28 INFO - @https://web-platform.test:8443/html/cross-origin-embedder-policy/require-corp.https.html:76:18
[task 2019-08-23T11:47:28.909Z] 11:47:28 INFO - Test.prototype.step_timeout/<@https://web-platform.test:8443/resources/testharness.js:1669:22
[task 2019-08-23T11:47:28.910Z] 11:47:28 INFO - Test.prototype.step@https://web-platform.test:8443/resources/testharness.js:1611:25
[task 2019-08-23T11:47:28.910Z] 11:47:28 INFO - Test.prototype.step_func/<@https://web-platform.test:8443/resources/testharness.js:1635:35
[task 2019-08-23T11:47:28.914Z] 11:47:28 INFO - .....
[task 2019-08-23T11:47:28.914Z] 11:47:28 INFO - TEST-OK | /html/cross-origin-embedder-policy/require-corp.https.html | took 2158ms

Junior, is this on your radar? You mentioned intermittents before I think.

Blocks: resab
Flags: needinfo?(juhsu)

The intermittent rate curve perfectly match the time we land/backout/reland H3 which leads some performance regression.
Let's try to see if it's something we can fix by longer timeout. The rate is > 5% recently, which should be easy to verify.

If the constant timeout issues happen here and there, we might want a deterministic way.
https://treeherder.mozilla.org/#/jobs?repo=try&revision=16fab60d2586710068090312d3cf7fd7f7021fcb

Flags: needinfo?(juhsu)

Junior: can you please adapt the component of this issue? I'm not sure to which Networking (?) component to move it to.

Edit: moved to DOM:Navigation.

Flags: needinfo?(juhsu)
Component: DOM: Core & HTML → DOM: Navigation
Priority: -- → P3
Component: DOM: Navigation → DOM: Networking
Flags: needinfo?(juhsu)
Priority: P3 → P2
Whiteboard: [stockwell needswork:owner] → [stockwell needswork:owner][necko-triaged]
Depends on: 1595848
Pushed by juhsu@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f51eb6400003
extend timeout to tolerate longer latency from socket layer, r=annevk
Created web-platform-tests PR https://github.com/web-platform-tests/wpt/pull/20238 for changes under testing/web-platform/tests
Whiteboard: [stockwell needswork:owner][necko-triaged] → [stockwell needswork:owner][necko-triaged], [wptsync upstream]
Whiteboard: [stockwell needswork:owner][necko-triaged], [wptsync upstream] → [stockwell needswork:owner][necko-triaged], [wptsync upstream error]

(In reply to Web Platform Test Sync Bot (IRC #interop) from comment #15)

Can't merge web-platform-tests PR due to failing upstream checks:
Github PR https://github.com/web-platform-tests/wpt/pull/20238

The error is not related to this change. I suspect wpt tests with pref change .ini will encounter this error at this moment.

Flags: needinfo?(juhsu)
Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla72
Whiteboard: [necko-triaged], [wptsync upstream error][stockwell unknown] → [necko-triaged], [wptsync upstream][stockwell unknown]
See Also: → 1601168
Upstream PR merged by jgraham
See Also: 1601168
Blocks: 1595848
No longer blocks: resab
No longer depends on: 1595848
You need to log in before you can comment on or make changes to this bug.