Closed Bug 1576223 Opened 4 months ago Closed 3 months ago

Handle the way we optimistically load cards and card images

Categories

(Firefox :: New Tab Page, enhancement, P1)

enhancement

Tracking

()

VERIFIED FIXED
Firefox 70
Iteration:
70.4 - Aug 19 - Sep 1
Tracking Status
firefox70 --- verified

People

(Reporter: thecount, Assigned: thecount)

References

(Blocks 1 open bug)

Details

(Keywords: github-merged)

Attachments

(1 file)

Right now we use intersection observer to handle loading below the fold stuff so above the fold stuff can be prioritized.

This means when you start scrolling you can see stuff loading.

I'm thinking we can combine that with some of the optimistic loading we did previously, some idle events, and some transitions to make this smoother.

Assignee: nobody → sdowne
Priority: -- → P1
Blocks: 1577888
Status: NEW → RESOLVED
Iteration: --- → 70.4 - Aug 19 - Sep 1
Closed: 3 months ago
Keywords: github-merged
Resolution: --- → FIXED
Target Milestone: --- → Firefox 70

I have verified this issue on Latest Firefox Nightly 71.0a1 (Build ID: 20190903215623) on Windows 10 x64, Mac 10.14.5 and Ubuntu 16.04.
The cards images have a smoother transition when they load.

Status: RESOLVED → VERIFIED
Duplicate of this bug: 1550138
You need to log in before you can comment on or make changes to this bug.