newly released QuickTime 6 plugin crashes when leaving a page with QT content

RESOLVED WONTFIX

Status

Plugins Graveyard
QuickTime (Apple)
P2
critical
RESOLVED WONTFIX
16 years ago
2 years ago

People

(Reporter: Jo Hermans, Assigned: Peter Lubczynski)

Tracking

({crash, top100})

Future
PowerPC
Mac System 9.x
crash, top100

Details

(Whiteboard: [PL2:NA][QuickTime][Mac Classic only], URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
QuickTime 6 got relased a few hours ago (although Apple's homepage will not be
updated until tomorrow). It can be downloaded at
http://www.apple.com/quicktime/download/. Don't use the link at the
www.apple.com homepage, that still points to the preview.

I noticed a bug in the preview a few weeks ago : whenever I'm on a page with QT
content, and I'm leaving the page by cling on a link, or by clicking on the
backwards/forwards button. I don't see it when there was a static picture (like
onthe URL above, before you click on the image), or when there was only music
playing. I was hoping that I saw bug 151923 (it tells me that the final version
would solve certain problems), but that wasn't the case.

Talkback ID : TB8345453Y

Build 2002071008, on Mac OS 9, with QuickTime 6 plugin (real one, not the preview).

Comment 1

16 years ago
i just tried this with today's branch 0715 on os 9.1(with the qktime in this 
url)  and could not reproduce the crash. Jo, is it crashing for u on any page? 
or sy specific url ?

Comment 2

16 years ago
Jo, could you please go to your Netscape plug-ins directory and give us the
following information?

What is the latest file number displayed in your directory? Mine is
(npqtplugin7.dll)

Can you look at the properties of npqtplugin.dll and select the Version tab, on
the version tab can you please select 'File Version' and tell us the value
there? I want to assess that we are using the same plug-in. Mine states 6.0b18c3

There is also a File Version displayed on the top portion of the Version tab.
Mine states 6.0.0.56

Comment 3

16 years ago
well, if I had read the data ... I would have seen you're on the mac! FWIW: it
works great on windows!

Comment 4

16 years ago
I can reproduce under 8.6 (QT6 preview) / 9.1 (QT6 release).

TB8348678X
TB8348463M

I can reproduce all the time. 

To reproduce:
Start playing any QT movie then click back WHILE the movie is playing. -> Should
crash.


Otherwise (Audio/Animation/Preview) seems stable as Johan reports.

Comment 5

16 years ago
Hm....this looks familar (from talkback):

XPCWrappedNativeProto::~XPCWrappedNativeProto() [xpcwrappednativeproto.cpp, line 82]
DyingProtoKiller() [xpcjsruntime.cpp, line 200]
JS_DHashTableEnumerate() [jsdhash.c, line 600]
XPCJSRuntime::GCCallback() [xpcjsruntime.cpp, line 478]
DOMGCCallback() [nsJSEnvironment.cpp, line 1640]
js_GC() [jsgc.c, line 1346]
js_ForceGC() [jsgc.c, line 980]
JS_GC() [jsapi.c, line 1656]
nsJSContext::Notify() [nsJSEnvironment.cpp, line 1595]
nsTimerImpl::Fire() [nsTimerImpl.cpp, line 347]

I think Andrei fixed this in bug 148889. When my Classic branch build finishes,
I'll check this out. Are you able to reproduce on a Carbon build? How about a
Classic build from a few weeks ago?
Assignee: beppe → peterl
Severity: blocker → major
Keywords: crash
Priority: -- → P3
Target Milestone: --- → mozilla1.2alpha
(Reporter)

Comment 6

16 years ago
I was able to reproduce with an original 1.1.a build, 2002061103 (TB8355170Q)

My plug-ins folder looks like this :
Default Plug-in
MRJPlugin
MRJPlugin.jar
QuickTimePlugin.class
QuickTime Plugin

QuickTime is version 6.0 from July 16th (no further information displayed in a
show window). 

But there's also a 'global' folder (System Folder:Internet Plug-ins) :
nsIQTScriptablePlugin.xpt
QuickTimePlugin.class
Shockwave Flash NP-PPC
QuickTime Plugin

So, Mozilla will find the same plug-in twice (they're identical copies). I'll
try to remove the extra copy and see what happens. I found out that the plug-in
was installed in every plug-in directory on every browser that I have (3
Mozilla's, Internet Exploder and iCab). Nice!

Mac IE5 and iCab didn't have a bug. The easiest way to reproduce for me, is to
go to htt://www.apple.com/quicktime/, click on the 'swtich to Mac' ad at the top
right. On the new page, click on the preview for the 'testimonial' movie. When
that starts playing, go back to the previous page. Crash.
(Reporter)

Comment 7

16 years ago
Nope - didn't work. The 2 plug-in directories seem to be merged into 1, as expected.
(Reporter)

Comment 8

16 years ago
I just tried it with the latest version of Mozilla 1.1a+ (2002071508), and I
reinstalled QuickTime. Same result.

Comment 9

16 years ago
I could totally reproduce this in my debug branch Classic build. I'm not sure
what's going on yet except I'm seeing QT being set as a scriptable plugin
without using GetURL. We crash shortly after adding it to the unused library
list in nsPluginTag::TryUnloadPlugin but we're not unloading it. 

Sometimes the crash was harder to reproduce but often times simply reloading a
page with a movie playing did it.
Keywords: nsbeta1

Comment 10

16 years ago
it looks like mac only reincarnationof of bug148889, I cannot crash on w2k.

Comment 11

16 years ago
Peter, although the patch in bug 148889 indeed prevents libs from being unloaded
but still calls shutdown on XPConnected old school plugins. Can this be a
problem on Mac?

Comment 12

16 years ago
...could be, but it's strange that in setting breakpoints, the crash would seem
to happen when we didn't unload the plugin. When mXPConnected = TRUE and we
saved the PRLibrary, we'd crash shortly after.
(Reporter)

Comment 13

16 years ago
There's no bug in build 2002071608 on Mac OS X 10.1.5 or on Windows NT 4.0 -
I've checked both of them. It seems to be only present on Mac OS 9.

Comment 14

16 years ago
hm...still not sure why it's crashing....sometimes it only crashes at
shutdown....should plugin code force a GC?
Keywords: top100
Summary: new QuickTime 6 plugin crashes when leaving a page with QT content → newly released QuickTime 6 plugin crashes when leaving a page with QT content

Comment 15

16 years ago
currently looking at this
Status: NEW → ASSIGNED
Priority: P3 → P2
Whiteboard: [PL2:NA]

Comment 16

16 years ago
Findings so far:

The crash happens after a plugin is marked scriptable and we call Shutdown. If I
comment out Shutdown, we do not crash. We are not unload the library. It almost
looks like we are feeing memory that is already free'ed however I've been told
QT only does a NS_IF_RELEASE on the scriptable peer in NPP_Destory. I still need
to do some more tests.....

One thing to note is that I hope the scriptable peer is getting its pointer to
the plugin instance updated when the instance is destroyed. We recently found
that a dangling pointer situation may occur with our scriptable plugin samples
and may cause a crash if trying to script after the instance is gone. This
problem is being tracked in bug 159646.

Comment 17

16 years ago
adding nsbeta1+
Keywords: nsbeta1+

Updated

16 years ago
Keywords: nsbeta1
(Reporter)

Comment 18

16 years ago
Another crash with QuickTime 6 was found in bug 167199 (but on windows XP -
maybe the same ?

Also, I'm still seeing the problem in build 2002090408 (just after freeze for
1.2a) - so bug 159646 didn't solve the problem. I got the impression that QT is
not a bit stabler though. If I let the movie play until the end (and it doesn't
repeat itself), there won't be any crash. The crash only occurs with video
content (MPEG 1?), not with audio (MP3, ...) or images.
(Reporter)

Comment 19

16 years ago
*** Bug 168143 has been marked as a duplicate of this bug. ***
WFM Mac OS 9.1, Build 2002091108 QuickTime 6, All french Version

About comment 6:
The Quicktime Installer installs the plugins twice. I suppose that apple don't
know the differences between NS4 and Mozilla.
The Installer installs also an xpt file in the component folder (The same as in
System Folder:Internet Plug-ins)

Know all theese file are deleted by the intall of new builds

Is this xpt file still here ?

Comment 21

16 years ago
QuickTime does know the difference between the two, otherwise why the 
.xpt file? The xpt file is installed in the "Components" folder because 
Mozilla would _only_ load it from there until very recently. The plug-in and 
xpt file are always installed in the System's "Internet Plug-ins" folder so 
versions of the browser that are able to load from from that folder will find 
them if QuickTime is installed before the brower.

Updated

16 years ago
Target Milestone: mozilla1.2alpha → mozilla1.3alpha

Comment 22

16 years ago
Created attachment 103971 [details]
MacsBug stdlog from crash with 2002102308 trunk build

Comment 23

16 years ago
Yes, this bug is here, and it's ugly when it crashes.  

Still here under Mac OS 9.2.2 with QT 6.0.2.  See the MacsBug stdlog attachment
for a stacktrace.  I caught MacsBug's console message saying something like
'Can't read back from this address because this is not a valid address.'

Dang fingers type too fast...

Updated

16 years ago
Whiteboard: [PL2:NA] → [PL2:NA][QuickTime]
Can still reproduce this consistantly on Mac OS 9.2.2, QuickTime 6.0.2, Mozilla
2002111108

Comment 25

16 years ago
this is a mac classic only issue, removing nsbeta1+ marker and setting to future
Keywords: nsbeta1+
Whiteboard: [PL2:NA][QuickTime] → [PL2:NA][QuickTime][Mac Classic only]
Target Milestone: mozilla1.3alpha → Future

Comment 26

16 years ago
*** Bug 184076 has been marked as a duplicate of this bug. ***

Comment 27

16 years ago
By the definitions on <http://bugzilla.mozilla.org/bug_status.html#severity> and
<http://bugzilla.mozilla.org/enter_bug.cgi?format=guided>, crashing and dataloss
bugs are of critical or possibly higher severity.  Only changing open bugs to
minimize unnecessary spam.  Keywords to trigger this would be crash, topcrash,
topcrash+, zt4newcrash, dataloss.
Severity: major → critical
This bug is targeted at a Mac classic platform/OS, which is no longer supported
by mozilla.org. Please re-target it to another platform/OS if this bug applies
there as well or resolve this bug.

I will resolve this bug as WONTFIX in four weeks if no action has been taken.
To filter this and similar messages out, please filter for "mac_cla_reorg".
mac classic platform is no longer supported on mozilla.
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WONTFIX
*** Bug 239816 has been marked as a duplicate of this bug. ***

Updated

8 years ago
Component: Plug-ins → QuickTime (Apple)
Product: Core → Plugins
QA Contact: shrir → apple-quicktime
Version: Trunk → 6.x
Product: Plugins → Plugins Graveyard
You need to log in before you can comment on or make changes to this bug.