window.print() not working (trunk only)

VERIFIED FIXED in mozilla1.0.3

Status

()

Core
DOM: Core & HTML
--
major
VERIFIED FIXED
16 years ago
16 years ago

People

(Reporter: Tom Everingham, Assigned: rods (gone))

Tracking

({regression, testcase})

Trunk
mozilla1.0.3
x86
All
regression, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

16 years ago
Overview Description:  Javascript url's do not appear to be working from within
href's.   

Steps to Reproduce:
1.)  Go to URL listed (internal only) 
2.)  click on the 'click here' link

Actual Results:  nothing happens 

Expected Results:  the text of the main window should be sent to your printer

Build Date & Platform Bug Found:  trunk builds - 07/12/2002  winNT4, linux rh6,
mac osX

Additional Information:  
- works on branch
- using the javascript alert function doesn't work from within href
- examples of this can be found at http://www.mapquest.com and http://www.401k.com
(Reporter)

Comment 1

16 years ago
Created attachment 91421 [details]
testcase
(Reporter)

Updated

16 years ago
Keywords: testcase
This has nothing to do with javascript: URL's, window.print() seems broken. If I
replace the javascript: URL with javascript:alert("foo"); it works. Over to rods
who's the owner of window.print() and everything it does...
Assignee: jst → rods
Summary: javascript url's are not working from withing href (trunk only) → window.print() not working (trunk only)
(Assignee)

Comment 3

16 years ago
Created attachment 91502 [details] [diff] [review]
patch

My fault.. how I forgot to test this testcase is a mystery.
As it turns out clicking on a link makes the document "busy" with a "before
page load" flag. (who would have thought)

This check to make sure the document is busy with an actual page load.
(Assignee)

Comment 4

16 years ago
Created attachment 91503 [details]
testcase (both onload and with a link and a button)

I mis that test because I als check with an input button and forget about the
link case.

Comment 5

16 years ago
Comment on attachment 91502 [details] [diff] [review]
patch

r=dcone
Attachment #91502 - Flags: review+
Comment on attachment 91502 [details] [diff] [review]
patch

sr=jst
Attachment #91502 - Flags: superreview+
(Assignee)

Updated

16 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.0.3

Comment 7

16 years ago
Comment on attachment 91502 [details] [diff] [review]
patch

a=scc for checkin to the mozilla trunk
Attachment #91502 - Flags: approval+
(Assignee)

Comment 8

16 years ago
fixed
(Assignee)

Comment 9

16 years ago
fixed again
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
(Reporter)

Comment 10

16 years ago
this is working for me now on 07/26/02 trunk builds

verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.