Closed Bug 1576334 Opened 3 years ago Closed 3 years ago

Dragging the URL from URL bar to anywhere outside Firefox does not work without no-deelevate / with the launcher process enabled

Categories

(Firefox :: General, defect, P3)

68 Branch
defect

Tracking

()

RESOLVED WONTFIX

People

(Reporter: daniel, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0

Steps to reproduce:

Win10Pro: Dragging a URL from URL bar to anywhere outside Firefox does not work (terribly inconvenient!). I remedy by using the start option "-no-deelevate". But this only works when I use the shortcut. There are tons of other ways FF may be launched where this parameter will not come into effect - like using a link in an email (with FF closed).

Actual results:

I see a stop sign and cannot drop the Shortcut anywhere.

Expected results:

I want to be able to drop my shortcuts everywhere. Just like with "-no-deelevate". IMO this parameter needs to be added to the about:config page. Alternatively, please find a way not to deelevate but still keeping drag'n'drop for shortcuts in tact.

Assigning "Toolkit: Preferences" component for this issue.

Component: Untriaged → Preferences
Product: Firefox → Toolkit

My further research has brought up an about:config parameter that supposedly controls the same as -no-deelveate. Namely "browser.launcherProcess.enabled" .. though I cannot tell if there is a fundamental difference. If it leads to the same the ticket can be closed.

Aaron/Matt, this looks related to the launcher process, can you take a look?

(In reply to daniello from comment #0)

Win10Pro: Dragging a URL from URL bar to anywhere outside Firefox does not work (terribly inconvenient!).

We should fix this rather than making it easier to use no-deelevate. Is there anything specific about user permissions on your machine that might influence this?

Component: Preferences → General
Flags: needinfo?(mhowell)
Flags: needinfo?(daniel)
Product: Toolkit → Firefox
Summary: deelevate not in about:config → Firefox "does not work" without no-deelevate / with the launcher process enabled
Summary: Firefox "does not work" without no-deelevate / with the launcher process enabled → Dragging the URL from URL bar to anywhere outside Firefox does not work without no-deelevate / with the launcher process enabled
Flags: needinfo?(aklotz)
Keywords: regression
Priority: -- → P3
Regressed by: 1477790

A relevant parameter is whether UAC on Windows is turned on or off. In my situation UAC is off. I found threads which state that the problem is gone when UAC is activated. Many have it turned off.

Flags: needinfo?(daniel)

This is by design. You must either run with UAC, or use -no-deelevate.

Flags: needinfo?(mhowell)
Flags: needinfo?(aklotz)
Keywords: regression
No longer regressed by: 1477790
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → WONTFIX

Which again makes it inconvenient for those who decide to turn off UAC for whatever reason. -no-deelevate can only be used with a shortcut .. which does not suffice. As mentioned above turning off browser.launcherProcess.enabled .. helps in this case.

That pref is not supported and will eventually be going away.

:-(

You need to log in before you can comment on or make changes to this bug.