Closed Bug 1576388 Opened 3 years ago Closed 3 years ago

The window buttons are slightly clipped at the bottom in "floating titlebar" windows

Categories

(Core :: Widget: Cocoa, task, P3)

All
macOS
task

Tracking

()

RESOLVED DUPLICATE of bug 1576391

People

(Reporter: mstange, Unassigned)

Details

Attachments

(1 file)

Attached image Screenshot

In windows where -[NSThemeFrame _wantsFloatingTitlebar] returns YES, our override of -[NSThemeFrame _closeButtonOrigin] to move the window buttons causes trouble: The bottom pixels of the window buttons get cut off slightly.

We probably need to find a solution to this before we can remove our override to _wantsFloatingTitlebar which returns NO.

Blocks: 1576391

This is more severe when the "Drag Space" option is checked. See bug 1576399 for more screenshots.

No longer blocks: 1576391

Folded into bug 1576391.

Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1576391
You need to log in before you can comment on or make changes to this bug.