Closed Bug 1576397 Opened 2 years ago Closed 2 years ago

Enabling message pane via hamburger button creates invalid message pane

Categories

(Thunderbird :: Message Reader UI, defect)

defect
Not set
normal

Tracking

(thunderbird_esr6868+ fixed, thunderbird69 fixed, thunderbird70 fixed)

RESOLVED FIXED
Thunderbird 70.0
Tracking Status
thunderbird_esr68 68+ fixed
thunderbird69 --- fixed
thunderbird70 --- fixed

People

(Reporter: emoore, Assigned: pmorris)

References

(Regression)

Details

(Keywords: regression, Whiteboard: smoketest68.0)

Attachments

(1 file)

I'm using Thunderbird 68.0 (build id 20190816191614), with its own profile, under Windows 10. It initially had no message pane, displaying the welcome pane instead. I enabled the menu toolbar.

I enabled the message pane in Options -> Layout -> Message Pane using the hamburger button. That appears to create a message pane with no lines (zero height). It should have created a message pane with the same height as the welcome pane.

I looked at View -> Layout and it believes there is no message pane. If I drag and drop the bottom edge of the folder listing window upwards that creates a working message pane and updates View -> Layout in the toolbar to indicate there is one.

If I then drag and drop the top of the message pane to the bottom of the folder listing (zero line height) both View -> Layout and Options -> Layout in the hamburger button believes there is no message pane. If I drag and drop the bottom edge of the folder listing window upward to create a working message pane View -> Layout believes it exists but Options -> Layout in the hamburger button doesn't.

View -> Layout in the toolbar and Options -> Layout in the hamburger button are not working together correctly.

I did not have this problem using version 60.8 (with its own profile)

Yes, there's something funny in the app menu related to the message pane. Even if there's no message pane, the item has a tick.

Paul, can you please take a look.

Flags: needinfo?(paul)

Luckily it just took adding a single "!" character. Fixes updating the checked state of the appmenu > Preferences > Layout > Message Pane item. Flagging either jorgk or mkmelin for review.

Assignee: nobody → paul
Status: NEW → ASSIGNED
Flags: needinfo?(paul)
Attachment #9088250 - Flags: review?(mkmelin+mozilla)
Attachment #9088250 - Flags: review?(jorgk)
Regressed by: 1371911
Comment on attachment 9088250 [details] [diff] [review]
show-message-pane-0.patch

Now that it turns out that this is already broken in TB 60, I'm not interested any more, haha.

But honestly, thanks for fixing it!!
Attachment #9088250 - Flags: review?(mkmelin+mozilla)
Attachment #9088250 - Flags: review?(jorgk)
Attachment #9088250 - Flags: review+
Attachment #9088250 - Flags: approval-comm-esr68+
Attachment #9088250 - Flags: approval-comm-beta+

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/5e98fe41e475
Fix updating the checked state of "Message Pane" in appmenu. r=jorgk

Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 70.0
You need to log in before you can comment on or make changes to this bug.