Closed Bug 1576447 Opened 3 months ago Closed 3 months ago

"This time, search with:" string and cog icon duplicate after customization

Categories

(Firefox :: Address Bar, defect, P1)

defect
Points:
2

Tracking

()

VERIFIED FIXED
Firefox 70
Iteration:
70.4 - Aug 19 - Sep 1
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox69 --- unaffected
firefox70 --- verified

People

(Reporter: itiel_yn8, Assigned: harry)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression)

Attachments

(2 files)

Attached image Screenshot

Using Windows 10, latest Nightly.

STR:

  1. Toggle browser.urlbar.megabar to true and change intl.uidirection to 1
  2. Restart Nightly
  3. Type anything in the megabar

AR:
The "This time, search with:" string and cog icon appear twice.
See attached.

ER:
Both should appear once.

Priority: -- → P1

Itiel, I encountered an issue like this on Mac in a LTR locale but it was fixed in the batch of Megabar layout fixes that landed in the past few days. I followed your STR and wasn't able to replicate this bug (albeit on Mac).

Using a Nightly from August 27 or later, are you still able to reproduce this issue?

Flags: needinfo?(itiel_yn8)

(In reply to Harry Twyford [:harry] from comment #1)

Itiel, I encountered an issue like this on Mac in a LTR locale but it was fixed in the batch of Megabar layout fixes that landed in the past few days. I followed your STR and wasn't able to replicate this bug (albeit on Mac).

Using a Nightly from August 27 or later, are you still able to reproduce this issue?

I think this is not reproducible anymore, will check tomorrow.
Keeping ni? to remind me.

Yep, not an issue anymore.

Status: NEW → RESOLVED
Closed: 3 months ago
Flags: needinfo?(itiel_yn8)
Resolution: --- → INVALID
Resolution: INVALID → WORKSFORME

I see this in today's nightly (en-US build).

Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Summary: [RTL][Megabar] "This time, search with:" string and cog icon appear twice → [Megabar] "This time, search with:" string and cog icon appear twice

It's not a rendering issue, the elements are actually duplicated in the DOM. Presumably a bug in search-one-offs.js or related urlbar code.

Keywords: rtl

To reproduce, open customize view, exit it, and then type in the Urlbar. A header string + cog icon will appear for each time you do this.

I reverted to the patch from bug 1561894 and this issue did not exist then, so it's something that's been introduced since. This also happens both with and without megabar enabled.

Summary: [Megabar] "This time, search with:" string and cog icon appear twice → This time, search with:" string and cog icon duplicate after customization
Summary: This time, search with:" string and cog icon duplicate after customization → "This time, search with:" string and cog icon duplicate after customization

I think bug 1561533 probably regressed this.

Regressed by: 1561533

Exiting customize mode calls UrlbarInput.uninit(). We used to remove the panel on uninit and then re-add it on re-initialization which would give us a fresh copy of the search one offs container. Since we no longer do this, copies of the search one offs keep piling up. Working on verifying this now.

Assignee: nobody → htwyford
Status: REOPENED → ASSIGNED
Iteration: --- → 70.4 - Aug 19 - Sep 1
Points: --- → 2
Pushed by htwyford@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3e5ac5ef3c9a
Stop duplicating one-offs container on UrlbarInput uninit. r=dao
Status: ASSIGNED → RESOLVED
Closed: 3 months ago3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 70
Flags: qe-verify+

I’ve reproduced this issue with Fx 70.0a1 (2019-08-25) on Windows 10 x64.
The issue is fixed with Fx 71.0a1 (2019-09-23) and Fx 70.0b8 on Windows 10 x64, macOS 10.13 and Ubuntu 18.04 x64.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.