Closed Bug 1576452 Opened 3 years ago Closed 2 years ago

Crash in [@ nsGlobalWindowInner::ClearDocumentDependentSlots]

Categories

(Core :: DOM: Core & HTML, defect)

69 Branch
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1573464
Tracking Status
firefox69 --- fix-optional
firefox70 --- fix-optional

People

(Reporter: philipp, Unassigned)

References

Details

(Keywords: crash, regression)

Crash Data

This bug is for crash report bp-a300b388-b25d-483a-83b9-883990190822.

Top 10 frames of crashing thread:

0 xul.dll nsGlobalWindowInner::ClearDocumentDependentSlots dom/base/nsGlobalWindowInner.cpp:6795
1 xul.dll nsGlobalWindowInner::InnerSetNewDocument dom/base/nsGlobalWindowInner.cpp:1612
2 xul.dll nsresult nsGlobalWindowOuter::SetNewDocument dom/base/nsGlobalWindowOuter.cpp:2195
3 xul.dll nsDocumentViewer::InitInternal layout/base/nsDocumentViewer.cpp:969
4 xul.dll nsDocumentViewer::Init layout/base/nsDocumentViewer.cpp:720
5 xul.dll nsresult nsDocShell::SetupNewViewer docshell/base/nsDocShell.cpp:8551
6 xul.dll nsresult nsDocShell::Embed docshell/base/nsDocShell.cpp:6387
7 xul.dll nsresult nsDocShell::CreateContentViewer docshell/base/nsDocShell.cpp:8354
8 xul.dll nsresult nsDSURIContentListener::DoContent docshell/base/nsDSURIContentListener.cpp:182
9 xul.dll bool nsDocumentOpenInfo::TryContentListener uriloader/base/nsURILoader.cpp:747

this crash signature with MOZ_CRASH(Unhandlable OOM while clearing document dependent slots.) has been around for a while but is spiking up in volume during the 69 cycle.

Component: General → DOM: Core & HTML

It says the OOM is unhandlable, so I'm not sure what we can do apart from telling people to run 64-bit Firefox.

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1573464
You need to log in before you can comment on or make changes to this bug.