Closed Bug 1576455 Opened 8 months ago Closed 6 months ago

Initialize the flash plugin in Page Info like other permissions

Categories

(SeaMonkey :: Page Info, enhancement)

enhancement
Not set

Tracking

(seamonkey2.49esr wontfix, seamonkey2.53 affected, seamonkey2.57esr fixed, seamonkey2.63 wontfix)

RESOLVED FIXED
seamonkey2.68
Tracking Status
seamonkey2.49esr --- wontfix
seamonkey2.53 --- affected
seamonkey2.57esr --- fixed
seamonkey2.63 --- wontfix

People

(Reporter: iann_bugzilla, Assigned: iann_bugzilla)

References

(Blocks 1 open bug)

Details

Attachments

(1 file, 1 obsolete file)

Port the relevant parts of Bug 1192927 - Remove plugins specific code and initialize the flash plugin in Page Info like other permissions

Attached patch page info flash permission (obsolete) — Splinter Review

[Approval Request Comment]
Regression caused by (bug #): n/a
User impact if declined: None
Testing completed (on m-c, etc.): 2.53
Risk to taking this patch (and alternatives if risky): None
String changes made by this patch: A couple of extra entities

Other work is required to fix click to play but this should still be safe.

Attachment #9088005 - Flags: review?(frgrahl)
Attachment #9088005 - Flags: approval-comm-release?
Attachment #9088005 - Flags: approval-comm-esr60?

Unbitrot following update to Bug 1574689

Attachment #9088005 - Attachment is obsolete: true
Attachment #9088005 - Flags: review?(frgrahl)
Attachment #9088005 - Flags: approval-comm-release?
Attachment #9088005 - Flags: approval-comm-esr60?
Attachment #9088323 - Flags: review?(frgrahl)
Attachment #9088323 - Flags: approval-comm-release?
Attachment #9088323 - Flags: approval-comm-esr60?
Blocks: 1576618
Comment on attachment 9088323 [details] [diff] [review]
page info flash permission v1.1

lgtm
Attachment #9088323 - Flags: review?(frgrahl)
Attachment #9088323 - Flags: review+
Attachment #9088323 - Flags: approval-comm-release?
Attachment #9088323 - Flags: approval-comm-release+
Attachment #9088323 - Flags: approval-comm-esr60?
Attachment #9088323 - Flags: approval-comm-esr60+

Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/ba2b990c337c
Initialize the flash plugin row in Page Info. r=frg

Status: ASSIGNED → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.