Closed Bug 1576553 Opened 2 months ago Closed 2 months ago

stroked text with ligature painted incorrectly when selection intersects ligature

Categories

(Core :: Layout: Text and Fonts, defect, P3)

defect

Tracking

()

RESOLVED FIXED
mozilla70
Tracking Status
firefox70 --- fixed

People

(Reporter: heycam, Assigned: jfkthame)

Details

Attachments

(3 files)

Attached file test

See the attached test case, which hopefully renders with a font that has an ff or fi or ffi ligature. Selecting part of that ligature causes some parts of the text to be painted in the wrong position.

I could only reproduce this with -webkit-text-fill-color: transparent.

Cute! I think there's a simple patch that will fix this; we should also add a reftest to cover it.

This fixes the behavior in my local testing; I'll put up a reftest patch in a while.

The reftest is likely to have a little bit of "fuzz" in the antialiasing at the edges of the selected range, because of drawing adjacent (touching) parts of the text in separate operations, but it should be unimportant; I'll get tryserver to confirm how much fuzz is needed.

Pushed by jkew@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d653382c7997
Partial ligatures need to be drawn if either GLYPH_FILL or GLYPH_STROKE is in effect. r=heycam
https://hg.mozilla.org/integration/autoland/rev/bc36c4359eef
Add reftest. r=heycam
Pushed by jkew@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ae2021d2c744
Partial ligatures need to be drawn if either GLYPH_FILL or GLYPH_STROKE is in effect. r=heycam
https://hg.mozilla.org/integration/autoland/rev/713c95e01d1e
Add reftest. r=heycam
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70
Assignee: nobody → jfkthame
Flags: needinfo?(jfkthame)
QA Whiteboard: [qa-70b-p2]
You need to log in before you can comment on or make changes to this bug.