Closed Bug 1576599 Opened 3 months ago Closed 2 months ago

The "Copy" buttons of the username and password fields are not aligned on small-width screens

Categories

(Firefox :: about:logins, defect, P3)

Desktop
Linux
defect

Tracking

()

VERIFIED FIXED
Firefox 70
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox68 --- unaffected
firefox69 --- disabled
firefox70 --- verified
firefox71 --- verified

People

(Reporter: cosmin.muntean, Assigned: jaws)

References

Details

(Whiteboard: [passwords:management] [skyline])

Attachments

(3 files)

Attached image Copy buttons.png

[Notes]:

  • The issue is not reproducible on Windows and Mac OS.

[Affected Platforms]

  • All Linux

[Steps to reproduce]:

  1. Open the latest Nightly browser with the profile from prerqusites.
  2. Navigate to "about:logins" page.
  3. Click the "Create New Login" button.
  4. Enter a valid Website Address.
  5. Enter a short username and password and click the "Save" button.
  6. Observe the "Copy" buttons of the username and password fields.

[Expected results]:

  • The buttons are aligned.

[Actual results]:

  • The buttons are not aligned.

[Additional Notes]:

  • Attached a screenshot with the issue.
Summary: [Linux] The "Copy" buttons of the username and password fields are not aligned → The "Copy" buttons of the username and password fields are not aligned on small-width screens
Assignee: nobody → jaws
Status: NEW → ASSIGNED
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/449729bd4714
Calculate the flex-basis of the login-item detail rows from the left (start) side to keep the copy buttons aligned in small windows. r=ntim
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70
Attached image Ubuntu buttons.png

I have verified this issue on the latest Nightly 70.0a1 (2019-08-30) (64-bit) on Ubuntu 18.04, Ubuntu 16.04 and Arch Linux 4.14. Here are the results:

  • The issue is no longer reproducible on Arch Linux 4.14.
  • The issue is still reproducible on Ubuntu versions. Attached a screenshot with the issue.

Considering this I will reopen the issue.

Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Hi Cosmin, once patches land we only reopen the bug if the patches were backed out. Can you please file a new bug for comment 4?

Status: REOPENED → RESOLVED
Closed: 3 months ago2 months ago
Flags: needinfo?(cosmin.muntean)
Resolution: --- → FIXED

Ah, make sense. Sorry for reopening the issue.

However, I have verified this issue and is no longer reproducible on Arch Linux 4.14 using the latest Beta 70.0b3 and the latest Nightly 71.0a1 (2019-09-05) build. I have opened a new issue for Ubuntu versions in bug 1579108.

Considering this I will mark this issue as Verified-Fixed.

Status: RESOLVED → VERIFIED
Flags: needinfo?(cosmin.muntean)
Component: Password Manager → about:logins
Product: Toolkit → Firefox
Target Milestone: mozilla70 → Firefox 70
Version: 70 Branch → unspecified
You need to log in before you can comment on or make changes to this bug.