Closed Bug 1576797 Opened 1 year ago Closed 1 year ago

Remove threadFront/target references from tests

Categories

(Core :: Web Replay, enhancement)

enhancement
Not set

Tracking

()

RESOLVED FIXED
mozilla70
Tracking Status
firefox70 --- fixed

People

(Reporter: bhackett1024, Assigned: bhackett1024)

References

Details

Attachments

(1 file)

The web replay tests are rather messy, in that they combine operations on the debugger frontend, the thread front, and the toolbox target. Particularly problematic is using the thread front directly, as the debugger also operates on this and we can easily get into states that would not be possible for users. I noticed this in one of the logpoint tests, as directly supplying invalid breakpoint options to the thread ended up producing weird output in the console. It would be better if the tests only operated on the debugger frontend to as great a degree as possible, so that the tests correspond better with user behavior and are easier to maintain.

Pushed by bhackett@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2708346920d8
Remove threadFront/target references from web replay tests, r=jlast.
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70
Duplicate of this bug: 1572850
You need to log in before you can comment on or make changes to this bug.