Closed Bug 1576805 Opened 3 years ago Closed 3 years ago

Can not see [Gmail]/Trash or get it recognized as a real Trash folder in 68.0

Categories

(Thunderbird :: Folder and Message Lists, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: emoore, Unassigned)

References

Details

(Keywords: regression, regressionwindow-wanted, Whiteboard: smoketest68.0)

Attachments

(1 file)

My Gmail IMAP account has two trash folders. One is under the inbox, the other is a peer of the inbox just above [Gmail]. Neither has a trash icon (they're ordinary folders). No idea how I got in this configuration. The Gmail IMAP account in 68 is using maildir. The Gmail account in 60.8 is using mbox. 60.8 and 68 each have their own profile. I'm using view -> folders -> all.

Thunderbird 68.0 enables delete in the context menu for both those folders. However, when I try to delete them nothing happens. Thunderbird 60.8 will display a "Delete Folder" message box warning me that deleting this folder is not undoable ....." if I try to delete either Trash folder.

I expected 68.0 to act like 60.8 when I try to delete one of those Trash folders.

The FolderFlags add-on doesn't support version 68. Each version is using its own profile. I installed FolderFlags under 60.8 and used it to make the second Trash folder a Trash folder. The icon changed to become a trash folder. I then deleted the first trash folder, exited Thunderbird and start 68.0. No change - both Trash folders exist and neither has a Trash icon. File -> Compact Folders has no effect.

60.8 is using "just mark it as deleted. I thought I had made the same change for 68 but I was wrong. I changed it from when I delete a message: move it to trash to just mark it as deleted. I then tried deleting the first trash folder again. I got the delete folder message box. I exited and restarted and now there is just one trash folder. Its still a ordinary folder, but its position has moved from above [Gmail] to down under "sync issues".

I exited 68 and started 60.8. It has only one Trash folder, but its on the old position as a peer of the Inbox, just above [Gmail].

I deleted the second/last trash folder in my Gmail account using 68. I used file-> compact folders and file -> empty trash. Looking at the subscription window for that account it still lists a Trash folder under [Gmail]. Its marked as subscribed. I refreshed the subscription window - it's still there. But its not visible in the folder pane.

If I log into gmail webmail I see a Trash folder listed right after All Mail and the Spam folder and [Gmail/Trash] right after "categories". The subscription window apparently recognizes the latter as a folder but its not listed in the folder pane despite being subscribed.

There seem to be several problems.

  1. I can't delete a folder in my Gmail IMAP account in 68.0 using "move it to this folder: Trash" because I can't get it to recognize a trash folder as a real trash folder. If the Folder Flags add-on supported 68 I might be able to workaround that. I can't fix the situation by temporarily using just mark it as deleted as several older bugs reports about not-visible Gmail trash folders suggested.

  2. The Gmail IMAP account folders act differently under 60.8 and 68.0. The subscription window in 68 also claims there is a Trash folder that the folder pane refuses to display (despite it being subscribed)

Something for Gene to look at. I'll fix the "Folder Flags" add-on.

Flags: needinfo?(gds)
Attached file folderflags.1.2.7.xpi

This works for me in TB 68.

Thanks for the fixed add-on.

After installing the folder flags add-on from the attachment and restarting 68.0 I could see the trash folder under [Gmail]. I then set it to be a real junk folder, changed when I delete a message to "move it to this folder: trash on gmail", and verified I could delete messages by deleting a security alert message from google.

I then exited 68 and started 60.8. It shows just one trash folder, a ordinary folder, under [Gmail]. I installed the thunderbird.net version of folder flags and set it to Trash. I exited 60.8 and restarted 68.0. It still has a trash folder (with the trash icon) under [Gmail].

I logged into Gmail webmail. It shows a Trash folder (has the message I just deleted) after the AllMail and Spam folders and a [Gmail]/Trash folder (empty). I emptied the Trash folder in webmail and verified the message disappeared in 68.0's Trash folder (under [Gmail]).

Reporter Eric: Not sure I completely understand the problem. But are you saying it is OK now?

I then set it to be a real junk folder,...

Also here, I assume you mean "real trash folder" and not "real junk folder" since Junk or Spam folder is typically a separate folder from Trash folder.

Flags: needinfo?(gds)

Gene:

Yes, I meant trash folder. This problem didn't involve a junk or spam folder at all. Sorry about that. By "real" trash folder I meant that it used the trash icon rather than a ordinary folder icon.

Everything seems to be working okay now. In hindsight I should have enabled IMAP logging and perhaps saved several snapshots of panacea.dat while this problem still occurred because I have no idea how somebody can duplicate the confused state it got into. I'm most worried about the folder pane not showing subscribed folders that are visible in both webmail and Thunderbird's subscribe window. I'm out of town right now but will be back tomorrow night if you want me to do something on the PC I used.

Sometimes gmail with imap is just weird. So I don't know of anything more you can do. There has been a recent issue looked at where users want to assign a different folder for trash other than [Gmail]/Trash since its content gets auto-deleted after 30 days with no option to disable it. Maybe at some point you were trying to create an "alternate" trash folder and possibly forgot that you created them. But that's just a theory.

You might be interested in related bug 1175446 that attempts to fix the alternate Trash folder issue. There is a patch but it is not incorporated into the daily build, AFAIK.

Anyhow, I guess this can be closed but not sure if it is INVALID or FIXED by the add-on that Jorg provided.

Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.