Closed Bug 1576884 Opened 4 months ago Closed 4 months ago

TypeError: this.intersectionObserver is null

Categories

(DevTools :: Netmonitor, defect, P2)

defect

Tracking

(firefox70 fixed)

RESOLVED FIXED
Firefox 70
Tracking Status
firefox70 --- fixed

People

(Reporter: Honza, Assigned: tanhengyeow)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

I am experiencing the following error in the Browser Console:

TypeError: this.intersectionObserver is null FrameListContent.js:105:5

I don't have STR though.

Honza

@Heng Yeow: can you please look at this?

Perhaps we could just add a if not null condition?

Honza

Flags: needinfo?(E0032242)

I think I found STR:

  1. Try to create WS connection to non existing server
  2. Click on the 101 request in the list
  3. Select the Messages panel (no frames, since no connection)
  4. Close the entire side bar
  5. See the Browser Console, it shows the error and the entire Network panel is empty -> BUG

The entire Toolbox needs to be reopened to fix the Network panel.

Honza

Has STR: --- → yes

:Honza, if you think that's a regression, then could you try to find a regression range in using for example mozregression?

Sent in a patch!

Flags: needinfo?(E0032242)
Assignee: nobody → E0032242
Status: NEW → ASSIGNED
Pushed by jodvarko@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/375480007a0a
TypeError: this.intersectionObserver is null. r=Honza
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 70
QA Whiteboard: [qa-70b-p2]
You need to log in before you can comment on or make changes to this bug.