Closed Bug 1576907 Opened 3 years ago Closed 5 months ago

Don't add expressions to history in private mode

Categories

(DevTools :: Console, enhancement, P2)

70 Branch
enhancement

Tracking

(firefox102 fixed)

RESOLVED FIXED
102 Branch
Tracking Status
firefox102 --- fixed

People

(Reporter: mozilla-crowdicity.wadmol, Assigned: nchevobbe)

References

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Firefox/68.0

Steps to reproduce:

  1. Open web console (in private window)
  2. Try anything in the console and close browser window
  3. Re-open browser and web console

Actual results:

Earlier expression/string can be found in history

Expected results:

History should not be kept at least when using private window. Actually it would be nice to have a preference whether to save history or not.

Right now I have set devtools.webconsole.inputHistoryCount to 0 to entirely disable it

Hi Ashutosh Sharma,

Thanks for the filed issue, the console commands are indeed saved and shown in history from private browsing windows too.
Will mark this as an enhancement and move it over to a component so the developers can take a look at it.

Status: UNCONFIRMED → NEW
Component: Untriaged → Console
Ever confirmed: true
OS: Unspecified → All
Product: Firefox → DevTools
Hardware: Unspecified → All
Priority: -- → P3

Given how some development happens in private browsing, for private or other reasons, retaining any of this information is not good.

Priority: P3 → P2

This is where we store the expressions /devtools/client/webconsole/middleware/history-persistence.js#45-57
Before setting them, we should check if we're in private mode .

Summary: Web Console history should be cleared on close (at least when private window is used) → Don't add expressions to history in private mode
Duplicate of this bug: 1350742
See Also: → 1656312
Duplicate of this bug: 1656312
Duplicate of this bug: 1767152
Assignee: nobody → nchevobbe
Status: NEW → ASSIGNED
Pushed by nchevobbe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/39d5dc270aa9
[devtools] Don't add expressions from private window console in history. r=bomsy.
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → 102 Branch
You need to log in before you can comment on or make changes to this bug.