Closed Bug 1577000 Opened 5 months ago Closed 5 months ago

Fix Megabar breakout width on window resize

Categories

(Firefox :: Address Bar, defect, P1)

defect
Points:
2

Tracking

()

RESOLVED FIXED
Firefox 71
Iteration:
70.4 - Aug 19 - Sep 1
Tracking Status
firefox71 --- fixed

People

(Reporter: harry, Assigned: harry)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

When the Megabar is broken-out and the window is resized, the breakout stays open and does not resize. This leads to unwanted visual behaviour.

The existing Urlbar closes the autocomplete panel on window resize. The Megabar should close both the panel and the breakout.

Assignee: nobody → htwyford
Status: NEW → ASSIGNED
Blocks: 1577472
Summary: End Megabar breakout on window resize → Fix Megabar breakout width on window resize
Attachment #9088544 - Attachment description: Bug 1577000 - End Megabar breakout on window resize. r?dao → Bug 1577000 - Fix Megabar breakout width on window resize. r?dao
Priority: -- → P1
Iteration: --- → 70.4 - Aug 19 - Sep 1
Attachment #9088544 - Attachment description: Bug 1577000 - Fix Megabar breakout width on window resize. r?dao → Bug 1577000 - End Megabar breakout on window resize. r?dao
Attachment #9088544 - Attachment description: Bug 1577000 - End Megabar breakout on window resize. r?dao → Bug 1577000 - Fix Megabar breakout width on window resize. r?dao
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1d1b7070291c
Fix Megabar breakout width on window resize. r=dao

Backed out changeset 1d1b7070291c (Bug 1577000) for browser_918049_skipintoolbarset_dnd.js failures

Push with failures: https://treeherder.mozilla.org/#/jobs?repo=autoland&fromchange=2cbc4579e85afc67a37e3273ef723bd88189a683&tochange=4a4f6df85daaafbf4b656e90910b65af59821361&selectedJob=264165254

Backout link: https://hg.mozilla.org/integration/autoland/rev/4a4f6df85daaafbf4b656e90910b65af59821361

Failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=264165254&repo=autoland&lineNumber=8603

[task 2019-08-30T01:28:43.575Z] 01:28:43 INFO - TEST-START | browser/components/customizableui/test/browser_918049_skipintoolbarset_dnd.js
[task 2019-08-30T01:28:43.923Z] 01:28:43 INFO - TEST-INFO | started process screencapture
[task 2019-08-30T01:28:44.075Z] 01:28:44 INFO - TEST-INFO | screencapture: exit 0
[task 2019-08-30T01:28:44.075Z] 01:28:44 INFO - Buffered messages logged at 01:28:43
[task 2019-08-30T01:28:44.075Z] 01:28:44 INFO - Entering test bound
[task 2019-08-30T01:28:44.076Z] 01:28:44 INFO - Waiting for overflow button to have non-0 size
[task 2019-08-30T01:28:44.076Z] 01:28:44 INFO - TEST-PASS | browser/components/customizableui/test/browser_918049_skipintoolbarset_dnd.js | Should still be in default state -
[task 2019-08-30T01:28:44.076Z] 01:28:44 INFO - TEST-PASS | browser/components/customizableui/test/browser_918049_skipintoolbarset_dnd.js | Should still be in default state -
[task 2019-08-30T01:28:44.076Z] 01:28:44 INFO - TEST-PASS | browser/components/customizableui/test/browser_918049_skipintoolbarset_dnd.js | Should be next to library button -
[task 2019-08-30T01:28:44.076Z] 01:28:44 INFO - Buffered messages finished
[task 2019-08-30T01:28:44.076Z] 01:28:44 INFO - TEST-UNEXPECTED-FAIL | browser/components/customizableui/test/browser_918049_skipintoolbarset_dnd.js | Should be next to skipintoolbarset item - Got wrapper-sidebar-button, expected wrapper-test-skipintoolbarset-item
[task 2019-08-30T01:28:44.077Z] 01:28:44 INFO - Stack trace:
[task 2019-08-30T01:28:44.077Z] 01:28:44 INFO - chrome://mochikit/content/browser-test.js:test_is:1595
[task 2019-08-30T01:28:44.077Z] 01:28:44 INFO - chrome://mochitests/content/browser/browser/components/customizableui/test/browser_918049_skipintoolbarset_dnd.js:null:34
[task 2019-08-30T01:28:44.077Z] 01:28:44 INFO - chrome://mochikit/content/browser-test.js:Tester_execTest/<:1350
[task 2019-08-30T01:28:44.077Z] 01:28:44 INFO - chrome://mochikit/content/browser-test.js:Tester_execTest:1385
[task 2019-08-30T01:28:44.077Z] 01:28:44 INFO - chrome://mochikit/content/browser-test.js:nextTest/<:1213
[task 2019-08-30T01:28:44.077Z] 01:28:44 INFO - chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<:805
[task 2019-08-30T01:28:44.078Z] 01:28:44 INFO - TEST-PASS | browser/components/customizableui/test/browser_918049_skipintoolbarset_dnd.js | Should still be in default state -
[task 2019-08-30T01:28:44.078Z] 01:28:44 INFO - Leaving test bound
[task 2019-08-30T01:28:44.078Z] 01:28:44 INFO - Entering test bound asyncCleanup
[task 2019-08-30T01:28:44.078Z] 01:28:44 INFO - Leaving test bound asyncCleanup
[task 2019-08-30T01:28:44.078Z] 01:28:44 INFO - GECKO(1829) | JavaScript error: resource://testing-common/PromiseTestUtils.jsm, line 112: uncaught exception: Object
[task 2019-08-30T01:28:44.078Z] 01:28:44 INFO - Console message: [JavaScript Error: "uncaught exception: Object" {file: "resource://testing-common/PromiseTestUtils.jsm" line: 112}]
[task 2019-08-30T01:28:44.078Z] 01:28:44 INFO - GECKO(1829) | MEMORY STAT | vsize 7745MB | residentFast 461MB | heapAllocated 206MB
[task 2019-08-30T01:28:44.079Z] 01:28:44 INFO - TEST-OK | browser/components/customizableui/test/browser_918049_skipintoolbarset_dnd.js | took 488ms

Flags: needinfo?(htwyford)

Clearing ni since I posted a new revision to Phabricator for review.

Flags: needinfo?(htwyford)
Pushed by htwyford@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/18705df33e23
Fix Megabar breakout width on window resize. r=dao

Backed out changeset 18705df33e23 (bug 1577000) for browser-chrome failures at browser/components/customizableui/test/browser_918049_skipintoolbarset_dnd.js

Backout: https://hg.mozilla.org/integration/autoland/rev/7e874f347a33

Failure push: https://treeherder.mozilla.org/#/jobs?repo=autoland&revision=18705df33e235acb6f9031dea73b9fa89712af30

Failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=264651994&repo=autoland&lineNumber=7905

task 2019-09-03T00:18:48.403Z] 00:18:48 INFO - TEST-PASS | browser/components/customizableui/test/browser_918049_skipintoolbarset_dnd.js | Should be next to library button -
[task 2019-09-03T00:18:48.403Z] 00:18:48 INFO - Buffered messages logged at 00:18:48
[task 2019-09-03T00:18:48.403Z] 00:18:48 INFO - Waiting for overflow button to have non-0 size
[task 2019-09-03T00:18:48.403Z] 00:18:48 INFO - Buffered messages finished
[task 2019-09-03T00:18:48.403Z] 00:18:48 INFO - TEST-UNEXPECTED-FAIL | browser/components/customizableui/test/browser_918049_skipintoolbarset_dnd.js | Should be next to skipintoolbarset item - Got wrapper-sidebar-button, expected wrapper-test-skipintoolbarset-item
[task 2019-09-03T00:18:48.403Z] 00:18:48 INFO - Stack trace:
[task 2019-09-03T00:18:48.403Z] 00:18:48 INFO - chrome://mochikit/content/browser-test.js:test_is:1595
[task 2019-09-03T00:18:48.403Z] 00:18:48 INFO - chrome://mochitests/content/browser/browser/components/customizableui/test/browser_918049_skipintoolbarset_dnd.js:null:36
[task 2019-09-03T00:18:48.403Z] 00:18:48 INFO - chrome://mochikit/content/browser-test.js:Tester_execTest/<:1350
[task 2019-09-03T00:18:48.403Z] 00:18:48 INFO - chrome://mochikit/content/browser-test.js:Tester_execTest:1385
[task 2019-09-03T00:18:48.403Z] 00:18:48 INFO - chrome://mochikit/content/browser-test.js:nextTest/<:1213
[task 2019-09-03T00:18:48.403Z] 00:18:48 INFO - chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<:805

Flags: needinfo?(htwyford)

New revision on Phabricator that disables this test on Mac. It looks good on try: https://treeherder.mozilla.org/#/jobs?repo=try&revision=3eb1708a4069d8025b519a6bf9a47920dae3386f

Flags: needinfo?(htwyford)
Pushed by htwyford@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/40665756406c
Fix Megabar breakout width on window resize. r=dao
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 71
Regressions: 1536312
Regressions: 1581763
Flags: qe-verify+
QA Contact: cristian.comorasu
Flags: qe-verify+ → qe-verify-
You need to log in before you can comment on or make changes to this bug.