strange large vertical gaps

RESOLVED DUPLICATE of bug 113779

Status

()

Core
Layout
P3
major
RESOLVED DUPLICATE of bug 113779
16 years ago
15 years ago

People

(Reporter: Thomas Speck, Unassigned)

Tracking

({qawanted})

Trunk
Future
x86
Windows XP
qawanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(8 attachments)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-AT; rv:1.0.0) Gecko/20020530
BuildID:    2002053012

In the mentioned Page there appears a gigantic (several screens) vertical gap
under the first URL. Similar things also happen on other pages (e.g.
dict.leo.org). I had the same problem on my PC at home for a time. I had tested
it then with all RC Versions (this was before the release of 1.0 final), and it
wouldn't go away, until i did a System Recovery to a date before this problem
appeared. Now the Bug resurfaced yesterday on my PC at work. 

Reproducible: Always
Steps to Reproduce:
1. Just open the given page.


Actual Results:  Page will be displayed with the mentionend gap.
A screenshoot can be found at:
http://www.thspeck.de/pics/capture.jpg

Expected Results:  No gap, probably what you may see, or every other browser
(even this one before yesterday).

Comment 1

16 years ago
WFM on BuildID 2002071208 on WinXP, Reporter can you try with a more recent build?

Comment 2

16 years ago
WFM - 2002071204 under XP.

Thomas, your build is a month and a half old.  Please download a recent build
and try again.  If that solves it, resolve this bug as WORKSFORME.

Also note that the URL you gave points to the frame only, not the actual page
(so your screenshot differs from what you see when you go to the post URL). 
Changing URL so it points to the page rather than just the frame.
(Reporter)

Comment 3

16 years ago
The bug happens with or without the Frameset. I have added a new Screenshot under
http://www.thspeck.de/pics/capture2.jpg

Also, the first screenshot was taken when the problem was on my PC at home with
an older version.

I will install a newer version and report again.
(Reporter)

Comment 4

16 years ago
So, just installed the latest nightly build, and the problem remains :-(

I have done new screenshots (one of my homepage, the other of dict.leo.org,
where the same happens).

http://www.thspeck.de/pics/capture3.jpg
and
http://www.thspeck.de/pics/capture4.jpg

Other computers i can access using Mozilla 1.0 don't show this behavior.

Comment 5

16 years ago
WFM BuildID 2002071504/Win2000.

Suggestions: 
 * Try clean installation (uninstall, erase c:\program files\mozilla
   completely and install again)
 * Something German-specific, presumably some character with code 255
   causes such a behavior??
(Reporter)

Comment 6

16 years ago
Each time i update Mozilla, i uninstall the old version, remove everything from
its directory (leaving the plugins-folder :-) and then install the new version
into that folder.

In the new version, i haven't installed any add-ons (no optimoz, no german
language), mozilla as (completely) installed.

And the bug remains :-(

I guess, i will have to try going back some days with XP tomorrow (this was the
solution last time), but i thought it might be helpful to see what causes this
behavior.

BTW, is there a way to compare the current state of XP with an earlier (saved) one?

Comment 7

16 years ago
I have seen this effect before on other pages, for months.   I'm currently using
2002071508 on Win2k. 

An example URL: http://www.ubbdev.com/ubb/ultimatebb.php?ubb=get_topic;f=1;t=000148

The raquo character in the header between the "Announcements" text ("UBBDev.com
>> Announcements >> Announcements >> ...") is the one that get super-heightened.
 The other raquos in that snippet do NOT suffer from this effect.

Oddly enough, this occurs only on two of my four machines (a P3 450, a P3 700).
 The same exact build does not do this on two other machines.  All machines are
running Win2k.
WFM on WinXP trunk build 2002070108.

Reporter: have you tried with a new profile ?
Have you used NS6/7 on the same machine as Mozilla ?

Comment 9

16 years ago
WFM Win98SE 2002071608
(Reporter)

Comment 10

16 years ago
Just tested with an existing (other profile) and a new created one, the bug
remains in each case.

And yes, on http://www.ubbdev.com/ubb/ultimatebb.php?ubb=get_topic;f=1;t=000148
it raises its ugly head, too.

Added a screenshot under
http://www.thspeck.de/pics/capture4.jpg

I'm kind of reliefed, that i'm not the only one experiencing this problem.
(Reporter)

Comment 11

16 years ago
Upps, here is the correct link to the fifth screenshot:
http://www.thspeck.de/pics/capture5.jpg
(Reporter)

Comment 12

16 years ago
Just came back to report that the problem returned at home, too. Earlier this
evening everything was as should be, when i restarted Mozilla right now, my
Homepage was as reported, only this time the additional space seems to be above
and below the link. I haven't been able to locate the line in the hundreds (at
least) of screenpages which are added :-(

I haven't changed anything in my system since earlier, no programm installed or
anything else.
(Reporter)

Comment 13

16 years ago
Additionally, i just saw that when i resize the window so that the faulty link
is broken into the next line, the problem disappears.
(Reporter)

Comment 14

16 years ago
Created attachment 91709 [details]
Series of screenshots #1

Here the Link is broken over two lines. Everything is displayed as should be.
BTW, a narrower window eill see the problem return again.
(Reporter)

Comment 15

16 years ago
Created attachment 91710 [details]
Series of screenshots #2

Here the link is on one line and its not broken, but...
(Reporter)

Comment 16

16 years ago
Created attachment 91712 [details]
Series of screenshots #3

... making the window another bit wider, the problem returns.
(Reporter)

Comment 17

16 years ago
Something strange has happened: WFM on both faulty system without any actions on
my side. I am completely dazzled, how such thing could happen. My first guess
was that it may have had something to do with some setting or other my provider
has change on his system, but the other pages are ok as well.

Well, just put it away as another strange thing which can happen on a computer :)

I hope i haven't made too much of noise with this bug.
(Reporter)

Comment 18

16 years ago
It seems that i may have unearthed the source for this bug. After installing the
newest nightly here, everythimg worked fine. Then i installed Optimoz (the mouse
gestures add-on), made the necessary restart and everything still worked. But,
after the next restart, the bug was back again.

Having an flash of genius, i uninstalled optimoz, then restarted Mozilla. The
big remained. But after restarting the system, it was gone. So it seems that
optimoz may be the culprit.

Comment 19

16 years ago
That is not the case for me - I have no extensions or add-ons installed, never
installed NS6/7, tried clean profiles, etc.  This issue persists on two of four
systems.  Quite annoying and odd.
(Reporter)

Comment 20

16 years ago
Right now it is getting old, the Problem is back again :-( (and no optimoz
installed here this time). The only change i made was installing grayrest's
mozilla icons this morning.
(Reporter)

Comment 21

16 years ago
As a workaround for this bug i have found that uninstalling Mozilla, then
rebooting the system before reinstalling it works everytime. After some days the
bug is usually back again, but thats just a way to assure a relatively up to
date build of mozilla on my system (i am just now using 1.1 beta, will go back
to the latest nightly next time it happens).

Should i do some further reporting on this bug (something like on build
200xxxxxxx it is still there?)
Thomas: yes, please do. And close it if it goes away. Please also try to get
someone on irc.mozilla.org to check it out.

I don't want this on my UNCONFIRMED radar, and it WFM. But I'm confirming due to
the screenshots.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 23

16 years ago
I had this bug with every mozilla version I was using. But with the 1.1 release
(Windows 2000, 20020826) I think I have seen it more often than with 1.0. It's
fine with the Linux version. With win2k I can reproduce it with the given URL
(http://www.thspeck.de/)

Comment 24

16 years ago
Created attachment 98415 [details]
Screenshot of font preferences

The bug happens with these font settings. If I change the font size using ctrl
+ or ctrl - the bug disappears for the given url. There are other urls
(http://www.rwth-aachen.de - I fear the page changes quite often) where the bug
appears with some font sizes and disappears with others.

Updated

16 years ago
Priority: -- → P3
(Reporter)

Comment 25

16 years ago
Hmm, WFM since Mozilla 1.1, but I still haven't found out, what caused this
behavior on the other versions. Sometimes I guessed, that addons like Optimoz or
the Mozilla Icons (which now are intergrated into Mozilla 1.1) caused the whole
ruckus, but couldn't nail it onto anything. Only solution for me was
reinstalling Mozilla and rebooting in the process, which got rid of the problem
(mostly at least for a time), but I'm waiting for the "Retourn of the Bug (TM)"
;-) (knocks on wood).
(Reporter)

Comment 26

16 years ago
The whole "knocking on wood"-thing didn't work, the bug is back again (Build
20020826, also using Multizilla 1.1.21).
(Reporter)

Comment 27

16 years ago
Addition to comment #26: Unistallinf, rebooting then reinstalling Mozilla seems
to remove the problem (for a while, at least). Still haven't found out, what
causes it in the first place, though. I.e. was browsing a few hours ago without
Problems, left the computer for a while, leaving it running, and when I returned
and started Mozilla, there was this Bug again.

Updated

16 years ago
Target Milestone: --- → Future

Comment 28

16 years ago
Created attachment 103036 [details]
Vertical space in a text file

I just had this bug with a text file. Take a look at the scrollbar - the
vertical space is huge. The text continues far below.

Comment 29

16 years ago
Bug 178106 also shows an example of this bug in the "before" Japanese text the
user provided.  

2002101612 on Win2k SP2.
(Reporter)

Comment 30

16 years ago
The Attachment of Bug 178106 WFM with Moz 1.1, but I seem to be free of this bug
since my last statement (knocks on wood).

Comment 31

16 years ago
I get this too, with standard 1.0 install on Win2k (2002053012)(+ a few modules
including bannerblind). It's reliably reproduced with certain URLs. Including
http://www.economics.ltsn.ac.uk/events/courses.htm
There is a huge gap of many many screenfuls within the "What's related" box at
the bottom of the page. The problem for this page disappears when I close the
sidebar.

Comment 32

16 years ago
Created attachment 108207 [details]
vertical and horizontal gap

I was free of this bug for some time using uninstall, delete everything,
reinstall method. Not it is back (build 2002101612, Windows 2000 - never had it
with any Linux version btw.). In addition I now have a horizontal gap at
http://slashdot.org/articles/02/11/20/1753238.shtml?tid=98
Take a look at the horizontal scroll bar in picture!

Comment 33

16 years ago
Just as a note: I installed phoenix 0.5 to the same machine I have the problems
with. The same bug appears at the same page with both phoenix 0.5 and mozilla
build 2002101612. All still under windows 2000. 

Comment 34

16 years ago
I posted the same Bug (#176786), a while ago. I still suffer from it... (v1.2.1,
W2000, no foreign language, no extra add inn's)

Comment 35

16 years ago
Ok, something might help in solving this problem> If you change the zoom on a
bad page, the page shows correctly; if you then go back to 100% it remains in
the correct layout.

Also, if you select the "breakpoint" in your text you can see that there is one
"block" that streches over the n-pages until the text starts again. 

I don't know if this all helps, I do not know too much about html, I can just
describe what I see.

Comment 36

16 years ago
*** Bug 176786 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 37

16 years ago
Its back again, this time in (Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US;
rv:1.3a) Gecko/20021212). Hmm, time to go to 1.3b.

BTW; it appeared without any changes to my system, i just started Mozilla and
there it was.
(Reporter)

Comment 38

16 years ago
I can remove the bug with the method mentioned above (uninstall, reboot,
install), but the problem seems to be back in force (got it the second time in
1.3b now, ehich makes that 3 times the last week, while before it went for weeks
without rearing its head.

I ran 1.3a the whole time without probs until the end. The other change in my
Mozilla install is Optimoz 0.35, after this install i will go back to 0.34,
maybe thats the problem (but could it be?).

Comment 39

15 years ago
Created attachment 118890 [details]
Another occurence of the bug, notice the gap

http://forum.rue-montgallet.com exhibits this problem as well. The front page
is OK most of the time but as soon as you enter any thread, wham, here it goes.
On the attachement I've highlighted the text to put the bug occurence forward.
Nothing special here except it's an URL.

Also, it might be interesting to add that after a driver upgrade on my graphics
card (Mobility Radeon 9000, running Windows 2000), the bug disappeared for a
while (one week or so). It doesn't occur on my other systems, nor have I ever
seen it under Linux (all running the same version of Mozilla, 1.2.1).

Updated

15 years ago
Summary: strange vertical gaps appearing under URLs → strange large vertical gaps [Radeon graphic driver]
(Reporter)

Comment 40

15 years ago
Erm, the whole thing I reported only happened on systems using Nvidia Cards (GF
2MX, 2MX400 and ti4200)), so tying it to radeon drivers seems kind of false.
BTW, no errors for the moment.

Comment 41

15 years ago
Yes, why was this changed to mention the Radeon?  I've experienced it on a
Matrox card and an ATI Rage card.

Comment 42

15 years ago
I am getting this (nearly) all the time with ebay.de.

I am using 2003040604 (WinXP) but had it for quite a few builds now. There was
one build (sorry, don't know the build anymore) approx last week where it did
not occur as often.

I am using a 64MB Radeon Mobility 9000 by the way, but do not really think that
this is Graphic adapter related.

Updated

15 years ago
Summary: strange large vertical gaps [Radeon graphic driver] → strange large vertical gaps
This needs a way to reproduce.... if we can't reproduce it, we usually can't fix it.
Assignee: attinasi → other
Keywords: qawanted
QA Contact: cpetersen0953 → ian
(Reporter)

Comment 44

15 years ago
Finding a way to reproduce is is kind of difficult, since it happens only very
sporadic (last time was when i was using 1.3b, as mentioned). With 1.3 now,
there where no occurences till now (knock on wood, the last time i mentioned
something like that, it was back very fast). Although the bug leaves many pages
almost unreadable, it is usually removed with uninstallation, reboot, and then a
new install.

Comment 45

15 years ago
This is probably the same thing as I described here:
http://bugzilla.mozilla.org/show_bug.cgi?id=205760

I see it with Mozilla/5.0 (Windows; U; Windows NT 5.1; de-AT; rv:1.3)
Gecko/20030312 even on a page with minimal HTML:
http://privat.svensson.de/bugzilla.htm (and on lots of other pages too!).

Comment 46

15 years ago
*** Bug 205760 has been marked as a duplicate of this bug. ***

Comment 47

15 years ago
Created attachment 123387 [details]
Screenshot of http://privat.svensson.de/bugzilla.htm under 1.3/XP

Here's another screenshot (showing my dummy page
http://privat.svensson.de/bugzilla.htm with the bug).

Comment 48

15 years ago
I can't reproduce this problem using 2003052309 nightly on Window 98.
Is this Themes related?  Is it specific to certain video drivers?  Is it related
to overriding fonts?  Is it Windows XP only?  Can someone who can reproduce
this, please post a minimal, validated, testcase HERE.
(Reporter)

Comment 49

15 years ago
As I wrote before, i haven't found a way to reproduce the bug until now, was
free of problems since the mentioned ones with 1.3b. All I have found out is how
to remove it, once it appears.

I am nat aware to have especially "done" something to get it, mostly it happens
after starting Mozilla again, that is I am browsing happily along, close Mozilla
and when I start it again, my homepage ist distorted. 

The problem is, evertytime I thought the problem may be solved at last, it
appears again :-(

BTW, at last it seems to have reduced the frequency of appearing, when I
reported the bug about a year ago, it happened every week or so, whereas now it
takes sometimes months to reappear.

Sorry that I couldn't be of more help.

Comment 50

15 years ago
I have the problem with any of the themes I use, but the appearance settings
seem to be the clue!

Here's what I came up with (using Mozilla/5.0 (Windows; U; Windows NT 5.1;
de-AT; rv:1.3) Gecko/20030312):

1. "Allow documents to use other fonts" checked
2. http://privat.svensson.de/bugzilla.htm loaded -- the problem is there
3. "Allow documents to use other fonts" UNchecked -- the problem is gone
4. http://privat.svensson.de/bugzilla.htm reloaded -- the problem is there
5. "Allow documents to use other fonts" checked -- the problem is gone
6. http://privat.svensson.de/bugzilla.htm reloaded -- the problem is there

Or another way:
1. "Display resolution" set to 96 dpi
2. http://privat.svensson.de/bugzilla.htm loaded -- the problem is there
3. "Display resolution" set to 72 dpi -- the problem is gone
4. http://privat.svensson.de/bugzilla.htm reloaded -- the problem is there
5. "Display resolution" set to 96 dpi -- the problem is gone
6. http://privat.svensson.de/bugzilla.htm reloaded -- the problem is there

In other words: Switch a setting, and it works fine until the page is reloaded.

This also works with
-- changing the fonts (e.g. switching between Arial and another sans-serif font
   or changing the font size)
-- changing the colors (e.g. changing the background color or switching the 
   custom colors setting).

Hope that helps!

Comment 51

15 years ago
Alexander, Thomas, Michael:
This seems to be bug 113779 which was fixed some days ago on the 1.5a trunk.
Can you verify this by comparing them or test the testcases in the other bug,
please?

Comment 52

15 years ago
I cannot reproduce the bug using the testcases from bug 113779 - but somehow
this is typical for the bug: sometimes it is there, and then it vanishes for month. 
From the descriptions and the screenshot I would say it is a duplicate of bug
113779. 
(Reporter)

Comment 53

15 years ago
Sorry, I am also bugfree since the last time I mentioned it. Lets hope, that it
is removed for good :-)
WFM, 2003-07-18-08 trunk Linux

Comment 55

15 years ago
the bug as originally reported certainly seems to have been a dupe of bug 113779
(there would be an umlaut on the line that would be below the gap in attachment
91712).  many of the other screensots here seem to be different bugs.

marking dupe of bug 113779
if the other problems mentioned here are still a problem, please find a more
appropriate bug, or file a new one.

*** This bug has been marked as a duplicate of 113779 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.