Closed Bug 1577104 Opened 2 months ago Closed 28 days ago

Talos performance numbers should have clear units

Categories

(Tree Management :: Perfherder, defect, P3)

defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1520739

People

(Reporter: standard8, Unassigned)

Details

I had a bug filed against a regression of tp5n nonmain_startup_fileio opt e10s stylo. The first thing I looked at was the performance comparison. This had:

tp5n nonmain_startup_fileio opt e10s stylo
windows7-32-shippable graph	2743634.29 ± 3.67	<	2883678.48 ± 2.75	5.10%	10.94 (high)

Given this was file i/o, I was initially assuming that it was bytes, however the decimal points in 2743634.29 then made me think, is it bytes or something else? Kilobytes... or some other unit system (it is apparently bytes).

I see other tests sometimes have the units system encoded in the name... but really this should be another column, part of the number field, or at worst a tooltip - at least in the comparison view. Ideally the treeherder info would have it as well.

Component: Talos → Perfherder
Product: Testing → Tree Management
Version: Version 3 → ---
Priority: -- → P3

I believe this is a duplicate of bug 1520739.

Status: NEW → RESOLVED
Closed: 28 days ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1520739
You need to log in before you can comment on or make changes to this bug.