Closed Bug 1577181 Opened 11 months ago Closed 10 months ago

Improper search engines overflow inside the address bar dropdown

Categories

(Firefox :: Address Bar, defect, P1)

70 Branch
defect
Points:
2

Tracking

()

VERIFIED FIXED
Firefox 71
Iteration:
71.1 - Sept 2 - 15
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox69 --- unaffected
firefox70 + verified
firefox71 --- verified

People

(Reporter: Anca, Assigned: dao)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression)

Attachments

(2 files)

[Affected versions]:

  • 70.0a1 (2019-08-28)

[Affected platforms]:

  • Windows 10
  • macOS 10.13

[Steps to reproduce]:

  • Access the about:preferences#search page
  • Click the “Find more search engines” link and add several search engines
  • Open a new tab and type anything inside the address bar
  • Observe the address bar dropdown bottom

[Expected result]:

  • All added search engines are visible and displayed on several rows when the case.

[Actual result]:

  • The last added search engines are not displayed.
  • The “Change search settings” button is nowhere to be found.

[Regression range]:

  • Introduced in Fx 70.0a1 (2019-08-14) with the new design changes (bug 1561894).

[Additional notes]:

  • Ubuntu 18.04 is not affected, the overflow implementation looks good.
Has Regression Range: --- → yes
Has STR: --- → yes
Component: Search → Address Bar
Component: Address Bar → Graphics
Product: Firefox → Core

Sorry, accidentally moved the wrong bug.

Component: Graphics → Address Bar
Product: Core → Firefox
Flags: needinfo?(htwyford)
Regressed by: 1561894
Priority: -- → P1
Blocks: megabar

I reverted back to the patch from bug 1561894 and this appeared to work fine (on Mac, at least), so I think it's been introduced in the time since. Could the regression range please be double checked?

Has Regression Range: yes → ---
Flags: needinfo?(htwyford) → needinfo?(anca.soncutean)
Assignee: nobody → htwyford
Iteration: --- → 71.2 - Sept 16 - 29
Points: --- → 2
Duplicate of this bug: 1577965
Status: NEW → ASSIGNED

This needs to be uplifted to 70 -- we should fix this asap (this week).

Assignee: htwyford → dao+bmo
Iteration: 71.2 - Sept 16 - 29 → 71.1 - Sept 2 - 15
Flags: needinfo?(anca.soncutean)
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/dc7ec5a19a13
Fix one off search button overflow layout in the urlbar. r=harry

Push with failures: https://treeherder.mozilla.org/#/jobs?repo=autoland&selectedJob=266573866&resultStatus=testfailed%2Cbusted%2Cexception&revision=dc7ec5a19a13da79beb049a5025e58e625342122&searchStr=browser%2Cchrome

Failure log: https://treeherder.mozilla.org/logviewer.html#?job_id=266573866&repo=autoland

Backout link: https://hg.mozilla.org/integration/autoland/rev/2b52360f30e025a46e19b5b75cef984e64eba281

[task 2019-09-13T17:18:46.053Z] 17:18:46 INFO - TEST-PASS | browser/components/search/test/browser/browser_oneOffContextMenu.js | One-off for test engine should exist - {"engine":{"_name":"Foo","_shortName":"foo","_loadPath":"[other]/testEngine.xml","description":"Foo Search","__searchForm":"http://mochi.test:8888/browser/browser/components/search/test/browser/","_iconURL":"data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABAAAAAQCAIAAACQkWg2AAABGklEQVQoz2NgGB6AnZ1dUlJSXl4eSDIyMhLW4Ovr%2B%2Fr168uXL69Zs4YoG%2BLi4i5dusTExMTGxsbNzd3f37937976%2BnpmZmagbHR09J49e5YvX66kpATVEBYW9ubNm2nTphkbG7e2tp44cQLIuHfvXm5urpaWFlDKysqqu7v73LlzECMYIiIiHj58mJCQoKKicvXq1bS0NKBgW1vbjh074uPjgeqAXE1NzSdPnvDz84M0AEUvXLgAsW379u1z5swBen3jxo2zZ892cHB4%2BvQp0KlAfwI1cHJyghQFBwfv2rULokFXV%2FfixYu7d%2B8GGqGgoMDKyrpu3br9%2B%2FcDuXl5eVA%2FAEWBfoWHAdAYoNuAYQ0XAeoUERFhGDYAAPoUaT2dfWJuAAAAAElFTkSuQmCC","_iconMapObj":"undefined","_metaData":{"loadPathHash":"ywAfsgCt8O+x6bmN5JPmkoCCc5mFksn7bKSQSNRzcUc=","order":10},"_urls":[{"template":"http://mochi.test:8888/browser/browser/components/search/test/browser/?search","rels":[],"resultDomain":"mochi.test","params":[{"name":"test","value":"{searchTerms}","purpose":"undefined"}]}],"_isBuiltin":false,"queryCharset":"UTF-8","_readOnly":false},"_inheritedElements":{".button-icon":{}},"initializedAttributeInheritance":true} != "undefined" -
[task 2019-09-13T17:18:46.053Z] 17:18:46 INFO - Buffered messages finished
[task 2019-09-13T17:18:46.053Z] 17:18:46 INFO - TEST-UNEXPECTED-FAIL | browser/components/search/test/browser/browser_oneOffContextMenu.js | Uncaught exception - at resource://testing-common/BrowserTestUtils.jsm:1036 - TypeError: subject is null
[task 2019-09-13T17:18:46.054Z] 17:18:46 INFO - Stack trace:
[task 2019-09-13T17:18:46.054Z] 17:18:46 INFO - waitForEvent/<@resource://testing-common/BrowserTestUtils.jsm:1036:7
[task 2019-09-13T17:18:46.054Z] 17:18:46 INFO - waitForEvent@resource://testing-common/BrowserTestUtils.jsm:1035:12
[task 2019-09-13T17:18:46.054Z] 17:18:46 INFO - telemetry@chrome://mochitests/content/browser/browser/components/search/test/browser/browser_oneOffContextMenu.js:53:30
[task 2019-09-13T17:18:46.054Z] 17:18:46 INFO - AsyncTester_execTest/<@chrome://mochikit/content/browser-test.js:1350:34
[task 2019-09-13T17:18:46.054Z] 17:18:46 INFO - async
Tester_execTest@chrome://mochikit/content/browser-test.js:1385:11
[task 2019-09-13T17:18:46.054Z] 17:18:46 INFO - nextTest/<@chrome://mochikit/content/browser-test.js:1213:14
[task 2019-09-13T17:18:46.054Z] 17:18:46 INFO - SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<@chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:805:67
[task 2019-09-13T17:18:46.054Z] 17:18:46 INFO - Leaving test bound telemetry
[task 2019-09-13T17:18:46.054Z] 17:18:46 INFO - Search engine removed: testEngine.xml
[task 2019-09-13T17:18:46.054Z] 17:18:46 INFO - GECKO(1861) | JavaScript error: resource://testing-common/PromiseTestUtils.jsm, line 112: uncaught exception: Object
[task 2019-09-13T17:18:46.055Z] 17:18:46 INFO - Console message: [JavaScript Error: "uncaught exception: Object" {file: "resource://testing-common/PromiseTestUtils.jsm" line: 112}]
[task 2019-09-13T17:18:46.055Z] 17:18:46 INFO - GECKO(1861) | MEMORY STAT | vsize 7697MB | residentFast 331MB | heapAllocated 138MB
[task 2019-09-13T17:18:46.055Z] 17:18:46 INFO - TEST-OK | browser/components/search/test/browser/browser_oneOffContextMenu.js | took 378ms
[task 2019-09-13T17:18:46.055Z] 17:18:46 INFO - checking window state
[task 2019-09-13T17:18:46.055Z] 17:18:46 INFO - TEST-START | browser/components/search/test/browser/browser_oneOffContextMenu_setDefault.js
[task 2019-09-13T17:18:56.386Z] 17:18:56 INFO - GECKO(1861) | 2019-09-13 17:18:56.368 firefox[1861:14017] Persistent UI failed to open file file:///Users/cltbld/Library/Saved%20Application%20State/org.mozilla.nightly.savedState/window_1.data: No such file or directory (2)
[task 2019-09-13T17:19:31.040Z] 17:19:31 INFO - Not taking screenshot here: see the one that was previously logged
[task 2019-09-13T17:19:31.040Z] 17:19:31 INFO - Buffered messages logged at 17:18:45
[task 2019-09-13T17:19:31.040Z] 17:19:31 INFO - Entering test bound init
[task 2019-09-13T17:19:31.041Z] 17:19:31 INFO - Buffered messages logged at 17:18:46
[task 2019-09-13T17:19:31.041Z] 17:19:31 INFO - Waiting for engine to be added: testEngine.xml
[task 2019-09-13T17:19:31.041Z] 17:19:31 INFO - Search engine added: testEngine.xml
[task 2019-09-13T17:19:31.041Z] 17:19:31 INFO - Leaving test bound init
[task 2019-09-13T17:19:31.041Z] 17:19:31 INFO - Entering test bound test_searchBarChangeEngine
[task 2019-09-13T17:19:31.041Z] 17:19:31 INFO - Opening panel
[task 2019-09-13T17:19:31.041Z] 17:19:31 INFO - Buffered messages finished

Flags: needinfo?(dao+bmo)
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/fe36492bc182
Fix one off search button overflow layout in the urlbar. r=harry
Flags: needinfo?(dao+bmo)
Status: ASSIGNED → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 71
Flags: qe-verify+

Comment on attachment 9092627 [details]
Bug 1577181 - Fix one off search button overflow layout in the urlbar. r=harry

Beta/Release Uplift Approval Request

  • User impact if declined: see comment 0
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: see comment 0
  • List of other uplifts needed: None
  • Risk to taking this patch: Medium
  • Why is the change risky/not risky? (and alternatives if risky): Reasonably straightforward patch, switching the one off search buttons from XUL flexbox to standard flexbox layout.
  • String changes made/needed:
Attachment #9092627 - Flags: approval-mozilla-beta?

Dão, do you want to address bug 1581377 before uplift ?

Flags: needinfo?(dao+bmo)
QA Whiteboard: [qa-triaged]

Hello,
Reproduced the issue with Firefox 70.0a1 (20190828214452) on Windows 10x64.
The issue is verified fixed with Firefox 71.0a1 (20190915214245) on Windows 10x64, macOS 10.14 and Ubuntu 18.04.

(In reply to Liz Henry (:lizzard) from comment #12)

Dão, do you want to address bug 1581377 before uplift ?

It's sort of an edge case that I think we can fix and uplift separately.

Flags: needinfo?(dao+bmo)

Comment on attachment 9092627 [details]
Bug 1577181 - Fix one off search button overflow layout in the urlbar. r=harry

Visual fixup for the one off search buttons in the urlbar. Approved for 70.0b8.

Attachment #9092627 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Hello,
The issue is verified fixed with Firefox 70.0b8 (20190919093316) on Windows 10x64, Ubuntu 18.04 and macOS 10.14.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.