Closed Bug 1577183 Opened 2 months ago Closed Last month

One-click Search engines are not properly aligned inside the search Bar when resizing the browser

Categories

(Firefox :: Search, defect, P3)

70 Branch
defect

Tracking

()

RESOLVED INVALID
Tracking Status
firefox70 --- fix-optional
firefox71 --- affected

People

(Reporter: Anca, Unassigned)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

Attached image old vs new Nigthly.png

[Affected versions]:

  • 70.0a1 (2019-08-27)

[Affected platforms]:

  • Windows 10
  • Ubuntu 18.04

[Steps to reproduce]:

  1. Go to about:preferences#search page]
  2. Check the “Add search bar in toolbar” option
  3. Resize the browser to 955px
  4. Type something inside the Search bar
  5. Observe the one-click search engines

[Expected result]:

  • One-click search engines are aligned properly.

[Actual result]:

  • One-click search engines are not adjusted accordingly (see the attached screenshot for comparison with the same browser width).

[Regression range]:

  • Introduced in Fx 70.0a1 (2019-08-14) with the new design changes.

[Additional notes]:

  • On Ubuntu “This time, search with” and “Change search settings” string are cut off see screenshot
Has Regression Range: --- → yes
Has STR: --- → yes
Priority: -- → P3

It's not clear to me what the regression range is (and the specific regressing patch), Anca could you tell us which bug caused this regression? Thanks

Flags: needinfo?(anca.soncutean)

Hello Pascal! Following up on Anca's behalf, since she's on PTO.

Last good revision: b134d9db39a9da2cdb1a4b7c19e6023063fde7f4
First bad revision: 7af558091d18077a0a09d8528027c73a0b7eab9f
Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=b134d9db39a9da2cdb1a4b7c19e6023063fde7f4&tochange=7af558091d18077a0a09d8528027c73a0b7eab9f

Flags: needinfo?(anca.soncutean)
Regressed by: 1561894

The buttons have a fixed width now. I believe this is working as intended.

Status: NEW → RESOLVED
Closed: Last month
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.