Closed Bug 1577188 Opened 2 years ago Closed 2 years ago

[wpt-sync] Sync PR 18723 - Reland "[CSS] Treat viewport-relative units as computationally independent"

Categories

(Core :: CSS Parsing and Computation, task, P4)

task

Tracking

()

RESOLVED FIXED
mozilla71
Tracking Status
firefox71 --- fixed

People

(Reporter: mozilla.org, Unassigned)

References

()

Details

(Whiteboard: [wptsync downstream])

Sync web-platform-tests PR 18723 into mozilla-central (this bug is closed when the sync is complete).

PR: https://github.com/web-platform-tests/wpt/pull/18723
Details from upstream follow.

Philip Rogers <pdr@chromium.org> wrote:

Reland "[CSS] Treat viewport-relative units as computationally independent"

This reverts commit 182115f0e3d61178991b3394e0dd50489df5ea30.

Reason for revert: We are relanding this to prove whether this patch was or was not the cause of the style and layout performance regression.

Original change's description:

Revert "[CSS] Treat viewport-relative units as computationally independent"

This is a speculative revert in order to either confirm or eliminate it
as a source for a hard to track down persistent performance regression.

This reverts r679183 (commit 6b846d3689b9038c73d87ecbab61670e91c7e051).

Bug: 993476
Tbr: pdr@chromium.org
Change-Id: I37566d32fb0853590e72299fdc0f281c712bf027
Reviewed-on: https://chromium-review.googlesource.com/c/chromium/src/+/1764195
Commit-Queue: Emil A Eklund \<eae@chromium.org>
Reviewed-by: Emil A Eklund \<eae@chromium.org>
Reviewed-by: Philip Rogers \<pdr@chromium.org>
Cr-Commit-Position: refs/heads/master@{#689475}

TBR=pdr@chromium.org,eae@chromium.org,xiaochengh@chromium.org,andruud@chromium.org

Not skipping CQ checks because original CL landed > 1 day ago.

Bug: 993476
Change-Id: I0292aa653c23ae3b2a751f62ee210626aeb71bbd

Reviewed-on: https://chromium-review.googlesource.com/1774683
WPT-Export-Revision: 628191720ea23a3a95dbdc68f59a880033a58fe7

Component: web-platform-tests → CSS Parsing and Computation
Product: Testing → Core
Ran 1 tests and 169 subtests
OK     : 1
FAIL   : 169

New tests that have failures or other problems:
/css/css-properties-values-api/register-property-syntax-parsing.html
    syntax:'<length>', initialValue:'10vmin' is valid: FAIL
    syntax:'<percentage> | <length>+', initialValue:'calc(100vh - 10px) 30px' is valid: FAIL
Pushed by wptsync@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/5684776f3a13
[wpt PR 18723] - Reland "[CSS] Treat viewport-relative units as computationally independent", a=testonly
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla71
You need to log in before you can comment on or make changes to this bug.