Closed Bug 1577194 Opened 3 months ago Closed 3 months ago

Perma Tier 2 dom/tests/mochitest/whatwg/test_postMessage.html | Test timed out.

Categories

(Core :: DOM: Core & HTML, defect, P1)

defect

Tracking

()

RESOLVED FIXED
mozilla70
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox69 --- unaffected
firefox70 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: pbone)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: intermittent-failure, regression, Whiteboard: [stockwell needswork:owner])

Attachments

(1 file)

Filed by: rgurzau [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=263862516&repo=mozilla-central
Full log: https://queue.taskcluster.net/v1/task/djUsXI19TAuzCZAqJ5lBCg/runs/0/artifacts/public/logs/live_backing.log


task 2019-08-28T13:20:58.143Z] 13:20:58 INFO - TEST-START | dom/tests/mochitest/whatwg/test_postMessage.html
[task 2019-08-28T13:26:26.533Z] 13:26:26 INFO - TEST-INFO | started process screentopng
[task 2019-08-28T13:26:26.966Z] 13:26:26 INFO - TEST-INFO | screentopng: exit 0
[task 2019-08-28T13:26:26.968Z] 13:26:26 INFO - Buffered messages logged at 13:20:58
[task 2019-08-28T13:26:26.969Z] 13:26:26 INFO - TEST-PASS | dom/tests/mochitest/whatwg/test_postMessage.html | umm, how did we get this?
[task 2019-08-28T13:26:26.969Z] 13:26:26 INFO - TEST-PASS | dom/tests/mochitest/whatwg/test_postMessage.html | postMessage creates events with empty lastEventId
[task 2019-08-28T13:26:26.970Z] 13:26:26 INFO - TEST-PASS | dom/tests/mochitest/whatwg/test_postMessage.html | expected events of type 'message'
[task 2019-08-28T13:26:26.970Z] 13:26:26 INFO - TEST-PASS | dom/tests/mochitest/whatwg/test_postMessage.html | should have been a trusted event
[task 2019-08-28T13:26:26.971Z] 13:26:26 INFO - TEST-PASS | dom/tests/mochitest/whatwg/test_postMessage.html | event has wrong origin
[task 2019-08-28T13:26:26.971Z] 13:26:26 INFO - TEST-PASS | dom/tests/mochitest/whatwg/test_postMessage.html | we posted this message!
[task 2019-08-28T13:26:26.972Z] 13:26:26 INFO - TEST-PASS | dom/tests/mochitest/whatwg/test_postMessage.html | umm, how did we get this?
[task 2019-08-28T13:26:26.972Z] 13:26:26 INFO - TEST-PASS | dom/tests/mochitest/whatwg/test_postMessage.html | postMessage creates events with empty lastEventId
[task 2019-08-28T13:26:26.972Z] 13:26:26 INFO - TEST-PASS | dom/tests/mochitest/whatwg/test_postMessage.html | expected events of type 'message'
[task 2019-08-28T13:26:26.973Z] 13:26:26 INFO - TEST-PASS | dom/tests/mochitest/whatwg/test_postMessage.html | should have been a trusted event
[task 2019-08-28T13:26:26.973Z] 13:26:26 INFO - TEST-PASS | dom/tests/mochitest/whatwg/test_postMessage.html | event has wrong origin
[task 2019-08-28T13:26:26.974Z] 13:26:26 INFO - TEST-PASS | dom/tests/mochitest/whatwg/test_postMessage.html | we posted this message!
[task 2019-08-28T13:26:26.974Z] 13:26:26 INFO - TEST-PASS | dom/tests/mochitest/whatwg/test_postMessage.html | umm, how did we get this?
[task 2019-08-28T13:26:26.974Z] 13:26:26 INFO - TEST-PASS | dom/tests/mochitest/whatwg/test_postMessage.html | postMessage creates events with empty lastEventId
[task 2019-08-28T13:26:26.975Z] 13:26:26 INFO - TEST-PASS | dom/tests/mochitest/whatwg/test_postMessage.html | expected events of type 'message'
[task 2019-08-28T13:26:26.975Z] 13:26:26 INFO - TEST-PASS | dom/tests/mochitest/whatwg/test_postMessage.html | should have been a trusted event
[task 2019-08-28T13:26:26.975Z] 13:26:26 INFO - TEST-PASS | dom/tests/mochitest/whatwg/test_postMessage.html | same-domain response event has wrong origin
[task 2019-08-28T13:26:26.976Z] 13:26:26 INFO - TEST-PASS | dom/tests/mochitest/whatwg/test_postMessage.html | wrong source for same-domain message!
[task 2019-08-28T13:26:26.976Z] 13:26:26 INFO - Buffered messages finished
[task 2019-08-28T13:26:26.976Z] 13:26:26 INFO - TEST-UNEXPECTED-FAIL | dom/tests/mochitest/whatwg/test_postMessage.html | Test timed out.
[task 2019-08-28T13:26:26.977Z] 13:26:26 INFO - SimpleTest.ok@SimpleTest/SimpleTest.js:277:18
[task 2019-08-28T13:26:26.977Z] 13:26:26 INFO - reportError@SimpleTest/TestRunner.js:121:22
[task 2019-08-28T13:26:26.977Z] 13:26:26 INFO - TestRunner._checkForHangs@SimpleTest/TestRunner.js:142:18
[task 2019-08-28T13:26:26.978Z] 13:26:26 INFO - setTimeout handlerTestRunner._checkForHangs@SimpleTest/TestRunner.js:170:15
[task 2019-08-28T13:26:26.978Z] 13:26:26 INFO - setTimeout handler
TestRunner._checkForHangs@SimpleTest/TestRunner.js:170:15
[task 2019-08-28T13:26:26.978Z] 13:26:26 INFO - setTimeout handlerTestRunner._checkForHangs@SimpleTest/TestRunner.js:170:15
[task 2019-08-28T13:26:26.978Z] 13:26:26 INFO - setTimeout handler
TestRunner._checkForHangs@SimpleTest/TestRunner.js:170:15
[task 2019-08-28T13:26:26.978Z] 13:26:26 INFO - setTimeout handlerTestRunner._checkForHangs@SimpleTest/TestRunner.js:170:15
[task 2019-08-28T13:26:26.978Z] 13:26:26 INFO - setTimeout handler
TestRunner._checkForHangs@SimpleTest/TestRunner.js:170:15

Looks like bug 1576814 reenabled this. Maybe this should get re-disabled, Paul?

Flags: needinfo?(pbone)
Regressed by: 1576814

Yes, It looks like I misinterpreted the try results.

Assignee: nobody → pbone
Status: NEW → ASSIGNED
Flags: needinfo?(pbone)
Priority: -- → P1
Pushed by amccreight@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/663df1e9e579
Skip the postMessage tests for fission r=mccr8
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70
Duplicate of this bug: 1572575
You need to log in before you can comment on or make changes to this bug.