Closed Bug 1577207 Opened 7 months ago Closed 7 months ago

Overflow menu arrow is detached from the popup in customize mode

Categories

(Firefox :: Toolbars and Customization, defect, P3)

defect

Tracking

()

RESOLVED FIXED
Firefox 71
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- wontfix
firefox69 --- wontfix
firefox70 --- wontfix
firefox71 --- fixed

People

(Reporter: itiel_yn8, Assigned: bgrins)

References

(Regression)

Details

(Keywords: regression)

Attachments

(2 files)

Attached image Screenshot

This isn't exclusive to RTL btw.

.

Flags: needinfo?(bgrinstead)
Regressed by: 1461793

Which platform(s) are you seeing this on? I just did a quick test on OSX in ltr and rtl and don't see the gap between the arrow and the popup.

Flags: needinfo?(itiel_yn8)

I(In reply to Brian Grinstead [:bgrins] from comment #3)

Which platform(s) are you seeing this on? I just did a quick test on OSX in ltr and rtl and don't see the gap between the arrow and the popup.

I'm on Windows 10. fwiw disabling the Bookmarks Toolbar doesn't help here.

Flags: needinfo?(itiel_yn8)
Priority: -- → P3

I just tested on Windows 7 and am not seeing the issue. I can check on Windows 10 later.

I realized this is only in Customize Mode, not with the actual overflow menu opened from the navbar. I can reproduce this now and will take a look.

Assignee: nobody → bgrinstead
Status: NEW → ASSIGNED
Flags: needinfo?(bgrinstead)
Summary: Overflow menu arrow is detached from the popup → Overflow menu arrow is detached from the popup in customize mode

There's a 4px margin from popup.css that applies here, which causes the content to get detached
from the arrow. When popup.css used to be loaded as a XBL sheet, this stylesheet wuoldn't have
applied to the customize mode overflow menu since it's not a real <panel> but just elements in
the document sharing the same structure.

Pushed by bgrinstead@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3dd48f49b60a
Set margin of 0 for the overflow menu content in customize mode in non-osx;r=Gijs
Status: ASSIGNED → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 71
QA Whiteboard: [qa-71b-p2]
You need to log in before you can comment on or make changes to this bug.