Closed Bug 1577214 Opened 1 year ago Closed 3 months ago

Permafailing Tier 2 GECKO(10759) | Assertion failure: uint32_t(aArgument) < ArrayLength(ProcTypeValues::strings), at /builds/worker/workspace/build/src/obj-firefox/dom/bindings/ChromeUtilsBinding.cpp:60

Categories

(Core :: Widget, defect)

defect
Not set

Tracking

()

RESOLVED WORKSFORME
Fission Milestone M4.1

People

(Reporter: intermittent-bug-filer, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: intermittent-failure, regression)

Filed by: btara [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=263833933&repo=mozilla-central
Full log: https://queue.taskcluster.net/v1/task/Z06t4wDTTaezSv_sWFd3pg/runs/0/artifacts/public/logs/live_backing.log


[task 2019-08-28T10:51:54.039Z] 10:51:54 INFO - TEST-START | widget/tests/browser/browser_test_procinfo.js
[task 2019-08-28T10:51:54.040Z] 10:51:54 INFO - GECKO(10759) | Chrome file doesn't exist: /builds/worker/workspace/build/tests/mochitest/browser/widget/tests/browser/head.js
[task 2019-08-28T10:51:54.155Z] 10:51:54 INFO - GECKO(10759) | ### XPCOM_MEM_BLOAT_LOG defined -- logging bloat/leaks to /tmp/tmpHHtGDt.mozrunner/runtests_leaks_tab_pid11039.log
[task 2019-08-28T10:51:54.319Z] 10:51:54 INFO - GECKO(10759) | Couldn't convert chrome URL: chrome://branding/locale/brand.properties
[task 2019-08-28T10:51:54.444Z] 10:51:54 INFO - GECKO(10759) | WARN 2019-08-28T10:51:54Z: audio_thread_priority::rt_linux: Could not make thread real-time.
[task 2019-08-28T10:51:54.444Z] 10:51:54 INFO - GECKO(10759) | WARN 2019-08-28T10:51:54Z: audioipc_client: Could not promote audio threads to real-time during initialization.
[task 2019-08-28T10:51:54.452Z] 10:51:54 INFO - GECKO(10759) | ++DOCSHELL 0x7f1e5d9b8000 == 1 [pid = 11039] [id = {7875ebc7-077e-49d7-8cc0-10134c6c472e}]
[task 2019-08-28T10:51:54.488Z] 10:51:54 INFO - GECKO(10759) | ++DOMWINDOW == 1 (0x7f1e5e99af20) [pid = 11039] [serial = 1] [outer = (nil)]
[task 2019-08-28T10:51:54.489Z] 10:51:54 INFO - GECKO(10759) | ++DOMWINDOW == 2 (0x7f1e5d96a400) [pid = 11039] [serial = 2] [outer = 0x7f1e5e99af20]
[task 2019-08-28T10:51:54.606Z] 10:51:54 INFO - GECKO(10759) | --DOCSHELL 0x7f80d59b3000 == 0 [pid = 10883] [id = {3609c9c8-88f5-4d78-a27c-4d3d26a230d8}] [url = about:blank]
[task 2019-08-28T10:51:54.742Z] 10:51:54 INFO - GECKO(10759) | ++DOMWINDOW == 3 (0x7f1e5e90c400) [pid = 11039] [serial = 3] [outer = 0x7f1e5e99af20]
[task 2019-08-28T10:51:54.981Z] 10:51:54 INFO - GECKO(10759) | Assertion failure: uint32_t(aArgument) < ArrayLength(ProcTypeValues::strings), at /builds/worker/workspace/build/src/obj-firefox/dom/bindings/ChromeUtilsBinding.cpp:60
[task 2019-08-28T10:51:54.982Z] 10:51:54 INFO - GECKO(10759) | #01: mozilla::dom::ChildProcInfoDictionary::ToObjectInternal(JSContext*, JS::MutableHandle<JS::Value>) const [s3:gecko-generated-sources:1df03f796d8fbcfade30883a87bbf5b55f2a15d73adde69d1c69578dad09557523ba076e16184e6b86053dc15faa403318b3bad6f09df785e29c599266963f06/dom/bindings/ChromeUtilsBinding.cpp::2755]
[task 2019-08-28T10:51:54.982Z] 10:51:54 INFO -
[task 2019-08-28T10:51:54.983Z] 10:51:54 INFO - GECKO(10759) | #02: mozilla::dom::ParentProcInfoDictionary::ToObjectInternal(JSContext*, JS::MutableHandle<JS::Value>) const [s3:gecko-generated-sources:1df03f796d8fbcfade30883a87bbf5b55f2a15d73adde69d1c69578dad09557523ba076e16184e6b86053dc15faa403318b3bad6f09df785e29c599266963f06/dom/bindings/ChromeUtilsBinding.cpp::3390]
[task 2019-08-28T10:51:54.983Z] 10:51:54 INFO -
[task 2019-08-28T10:51:54.983Z] 10:51:54 INFO - GECKO(10759) | #03: void mozilla::dom::Promise::MaybeSomething<mozilla::dom::ParentProcInfoDictionary&>(mozilla::dom::ParentProcInfoDictionary&, void (mozilla::dom::Promise::)(JSContext, JS::Handle<JS::Value>)) [dom/promise/Promise.h:250]
[task 2019-08-28T10:51:54.984Z] 10:51:54 INFO -
[task 2019-08-28T10:51:54.984Z] 10:51:54 INFO - GECKO(10759) | #04: mozilla::dom::ChromeUtils::RequestProcInfo(mozilla::dom::GlobalObject&, mozilla::ErrorResult&)::$_6::operator()(mozilla::ProcInfo) const::{lambda(nsTArray<mozilla::ProcInfo> const&)#1}::operator()(nsTArray<mozilla::ProcInfo> const&) const [dom/promise/Promise.h:0]
[task 2019-08-28T10:51:54.984Z] 10:51:54 INFO -
[task 2019-08-28T10:51:54.985Z] 10:51:54 INFO - GECKO(10759) | #05: mozilla::MozPromise<nsTArray<mozilla::ProcInfo>, nsresult, true>::ThenValue<mozilla::dom::ChromeUtils::RequestProcInfo(mozilla::dom::GlobalObject&, mozilla::ErrorResult&)::$_6::operator()(mozilla::ProcInfo) const::{lambda(nsTArray<mozilla::ProcInfo> const&)#1}, mozilla::dom::ChromeUtils::RequestProcInfo(mozilla::dom::GlobalObject&, mozilla::ErrorResult&)::$_6::operator()(mozilla::ProcInfo) const::{lambda(nsresult)#1}>::DoResolveOrRejectInternal(mozilla::MozPromise<nsTArray<mozilla::ProcInfo>, nsresult, true>::ResolveOrRejectValue&) [xpcom/threads/MozPromise.h:722]
[task 2019-08-28T10:51:54.985Z] 10:51:54 INFO -
[task 2019-08-28T10:51:54.985Z] 10:51:54 INFO - GECKO(10759) | #06: mozilla::MozPromise<nsTArray<mozilla::ProcInfo>, nsresult, true>::ThenValueBase::ResolveOrRejectRunnable::Run() [xpcom/threads/MozPromise.h:399]
[task 2019-08-28T10:51:54.986Z] 10:51:54 INFO -
[task 2019-08-28T10:51:54.986Z] 10:51:54 INFO - GECKO(10759) | #07: nsThread::ProcessNextEvent(bool, bool*) [xpcom/threads/nsThread.cpp:1214]
[task 2019-08-28T10:51:54.986Z] 10:51:54 INFO -
[task 2019-08-28T10:51:54.987Z] 10:51:54 INFO - GECKO(10759) | #08: NS_ProcessNextEvent(nsIThread*, bool) [xpcom/threads/nsThreadUtils.cpp:486]
[task 2019-08-28T10:51:54.987Z] 10:51:54 INFO -
[task 2019-08-28T10:51:54.987Z] 10:51:54 INFO - GECKO(10759) | #09: mozilla::ipc::MessagePump::Run(base::MessagePump::Delegate*) [ipc/glue/MessagePump.cpp:88]
[task 2019-08-28T10:51:54.987Z] 10:51:54 INFO -
[task 2019-08-28T10:51:54.988Z] 10:51:54 INFO - GECKO(10759) | #10: MessageLoop::RunInternal() [ipc/chromium/src/base/message_loop.cc:315]
[task 2019-08-28T10:51:54.988Z] 10:51:54 INFO -
[task 2019-08-28T10:51:54.988Z] 10:51:54 INFO - GECKO(10759) | #11: MessageLoop::Run() [ipc/chromium/src/base/message_loop.cc:291]
[task 2019-08-28T10:51:54.988Z] 10:51:54 INFO -
[task 2019-08-28T10:51:54.988Z] 10:51:54 INFO - GECKO(10759) | #12: nsBaseAppShell::Run() [widget/nsBaseAppShell.cpp:139]
[task 2019-08-28T10:51:54.989Z] 10:51:54 INFO -
[task 2019-08-28T10:51:54.989Z] 10:51:54 INFO - GECKO(10759) | #13: nsAppStartup::Run() [toolkit/components/startup/nsAppStartup.cpp:277]
[task 2019-08-28T10:51:54.989Z] 10:51:54 INFO -
[task 2019-08-28T10:51:54.989Z] 10:51:54 INFO - GECKO(10759) | #14: XREMain::XRE_mainRun() [toolkit/xre/nsAppRunner.cpp:4573]
[task 2019-08-28T10:51:54.989Z] 10:51:54 INFO -
[task 2019-08-28T10:51:54.989Z] 10:51:54 INFO - GECKO(10759) | #15: XREMain::XRE_main(int, char**, mozilla::BootstrapConfig const&) [toolkit/xre/nsAppRunner.cpp:4711]
[task 2019-08-28T10:51:54.990Z] 10:51:54 INFO -
[task 2019-08-28T10:51:54.990Z] 10:51:54 INFO - GECKO(10759) | #16: XRE_main(int, char**, mozilla::BootstrapConfig const&) [toolkit/xre/nsAppRunner.cpp:4792]
[task 2019-08-28T10:51:54.991Z] 10:51:54 INFO -
[task 2019-08-28T10:51:54.991Z] 10:51:54 INFO - GECKO(10759) | #17: _fini
[task 2019-08-28T10:51:54.991Z] 10:51:54 INFO -
[task 2019-08-28T10:51:54.991Z] 10:51:54 INFO - GECKO(10759) | #18: libc.so.6 + 0x20830
[task 2019-08-28T10:51:54.992Z] 10:51:54 INFO -
[task 2019-08-28T10:51:54.994Z] 10:51:54 INFO - GECKO(10759) | #19: _fini
[task 2019-08-28T10:51:54.995Z] 10:51:54 INFO -
[task 2019-08-28T10:51:54.995Z] 10:51:54 INFO - GECKO(10759) | ExceptionHandler::GenerateDump cloned child 11067
[task 2019-08-28T10:51:54.995Z] 10:51:54 INFO - GECKO(10759) | ExceptionHandler::SendContinueSignalToChild sent continue signal to child
[task 2019-08-28T10:51:54.995Z] 10:51:54 INFO - GECKO(10759) | ExceptionHandler::WaitForContinueSignal waiting for continue signal...
[task 2019-08-28T10:51:55.124Z] 10:51:55 INFO - GECKO(10759) | Exiting due to channel error.
[task 2019-08-28T10:51:55.125Z] 10:51:55 INFO - GECKO(10759) | [GFX1-]: Receive IPC close with reason=AbnormalShutdown
[task 2019-08-28T10:51:55.125Z] 10:51:55 INFO - GECKO(10759) | Exiting due to channel error.
[task 2019-08-28T10:51:55.127Z] 10:51:55 INFO - GECKO(10759) | Exiting due to channel error.
[task 2019-08-28T10:51:55.127Z] 10:51:55 INFO - GECKO(10759) | [GFX1-]: Receive IPC close with reason=AbnormalShutdown
[task 2019-08-28T10:51:55.127Z] 10:51:55 INFO - GECKO(10759) | [Child 10808, Chrome_ChildThread] WARNING: pipe error (3): Connection reset by peer: file /builds/worker/workspace/build/src/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 358
[task 2019-08-28T10:51:55.128Z] 10:51:55 INFO - GECKO(10759) | Exiting due to channel error.
[task 2019-08-28T10:51:55.128Z] 10:51:55 INFO - GECKO(10759) | [Child 10990, Chrome_ChildThread] WARNING: pipe error (3): Connection reset by peer: file /builds/worker/workspace/build/src/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 358
[task 2019-08-28T10:51:55.128Z] 10:51:55 INFO - GECKO(10759) | Exiting due to channel error.
[task 2019-08-28T10:51:55.128Z] 10:51:55 INFO - GECKO(10759) | Exiting due to channel error.
[task 2019-08-28T10:51:55.128Z] 10:51:55 INFO - GECKO(10759) | Exiting due to channel error.
[task 2019-08-28T10:51:55.128Z] 10:51:55 INFO - GECKO(10759) | Exiting due to channel error.
[task 2019-08-28T10:51:55.134Z] 10:51:55 INFO - GECKO(10759) | Exiting due to channel error.
[task 2019-08-28T10:51:55.204Z] 10:51:55 INFO - TEST-INFO | Main app process: exit 11
[task 2019-08-28T10:51:55.205Z] 10:51:55 ERROR - TEST-UNEXPECTED-FAIL | ShutdownLeaks | process() called before end of test suite
[task 2019-08-28T10:51:55.206Z] 10:51:55 INFO - Buffered messages logged at 10:51:54
[task 2019-08-28T10:51:55.206Z] 10:51:55 INFO - Entering test bound test_proc_info
[task 2019-08-28T10:51:55.206Z] 10:51:55 INFO - Buffered messages finished
[task 2019-08-28T10:51:55.207Z] 10:51:55 ERROR - TEST-UNEXPECTED-FAIL | widget/tests/browser/browser_test_procinfo.js | application terminated with exit code 11
[task 2019-08-28T10:51:55.207Z] 10:51:55 INFO - runtests.py | Application ran for: 0:00:28.712578

Fission Milestone: --- → M4.1

no failures in >1 month; no record of disabling the test.

Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → WORKSFORME
Whiteboard: [stockwell needswork:owner]
You need to log in before you can comment on or make changes to this bug.