Closed Bug 1577217 Opened 1 year ago Closed 7 months ago

Enable untrusted_modules ping on beta and release

Categories

(External Software Affecting Firefox :: Telemetry, enhancement, P1)

enhancement

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: RT, Assigned: toshi)

References

Details

Attachments

(4 files)

Attached file request.txt

Enable untrusted_modules ping on beta and release to help inform block actions.

Can you please review before I ping CHutten for approval?

Flags: needinfo?(akomarzewski)
Flags: needinfo?(aklotz)
Blocks: 1553455

I would like to suggest that we hold off on doing this until I land bug 1542830, and let enablement on beta and release ride along with that bug.

The reason is because the ping's schema is changing, so I'd rather that we just ride the trains with untrusted modules 2.0, rather than trying to juggle the collection of data using two schemas simultaneously.

Flags: needinfo?(aklotz)

That makes sense, marking 1542830 as blocking this bug.

Depends on: 1542830

Clearing my NI, nothing to add at this stage.

Flags: needinfo?(akomarzewski)

Taking

Assignee: nobody → aklotz
Status: NEW → ASSIGNED
Keywords: leave-open
Priority: -- → P1

We've decided to let this ride through to early beta. We'll evaluate how the
early beta numbers look, and if there are no significant issues we'll follow up
with another patch to ride to release.

This is already covered by the data review for bug 1542830.

Pushed by aklotz@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6fc0c2b4b909
Let third-party-modules ride to early beta; r=mhowell

We're still not seeing data from beta. Probably we need to remove nightly check from TelemetryImpl::GetUntrustedModuleLoadEvents, too.

(In reply to Toshihito Kikuchi [:toshi] from comment #9)

We're still not seeing data from beta. Probably we need to remove nightly check from TelemetryImpl::GetUntrustedModuleLoadEvents, too.

I just ran into this as well. Toshihito, would you mind picking this bug up?

Flags: needinfo?(tkikuchi)

To enable the third-party-modules ping in beta, we need to change
TelemetryImpl::GetUntrustedModuleLoadEvents in addition to
https://hg.mozilla.org/mozilla-central/rev/6fc0c2b4b909.

Pushed by aklotz@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e0cf44dbd7d8
Enable TelemetryImpl::GetUntrustedModuleLoadEvents in beta.  r=aklotz
Regressions: 1604462

(In reply to Jim Mathies [:jimm] from comment #10)

I just ran into this as well. Toshihito, would you mind picking this bug up?

I think necessary changes are done. This will be available in 73.0b1.

Flags: needinfo?(tkikuchi)

No significant issues has been reported since we enabled the ping in early beta
of 73. It's time to enable it in all versions including Release build.

Pushed by cbrindusan@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/73614f918c31
Enable the third-party-modules ping in Release build.  r=aklotz
Assignee: aklotz → tkikuchi
Status: ASSIGNED → RESOLVED
Closed: 7 months ago
Keywords: leave-open
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.