wrong word wrapping of <i>, <b> and other blocks in html

RESOLVED WORKSFORME

Status

()

Core
Layout
RESOLVED WORKSFORME
16 years ago
16 years ago

People

(Reporter: Marius Siegas, Assigned: Marc Attinasi)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1a) Gecko/20020611
BuildID:    2002061104

Words in html document jump on each other making it impossible to read them. The
words that are enclosed in <i>, <b>, <a> and other formatting blocks at the end
of line (where word-wrapping takes action) are painted on top of each other.
This makes reading documentation very difficult :/.

Reproducible: Always
Steps to Reproduce:
1. Open this page: http://03bar.ktu.lt/bugzilla.html
2. Scale your mozilla window down slowly... The shorter word jumps to other
line. Then, when it seems like the longer should jump to the other line too, the
shorter word comes back, on top of the longer one...
3. Scale mozilla window up again. It stays corrupted.
4. Hit 'refresh'. Repeat operation from step 2.

Actual Results:  Two words paint in one place, making it impossible to read them.

Expected Results:  Both words should be wrapped to next line.

Minimal (incomplete) html file to reproduce this bug:

Fill space, fill space, fill space, fill space, fill enough space.
<em>Verylongword shorter</em>

This bug works in both quirks and standard layout modes (whatever this means), i
have tested it with and without the suggested doctype declarations.
(Reporter)

Comment 1

16 years ago
Created attachment 91504 [details]
testcase (same as at 03bar.ktu.lt)

Comment 2

16 years ago
Likely a dupe of bug 148399; WFM in a recent build. Please try a nightly build 
or the upcoming beta.

Comment 3

16 years ago
WFM BuildID 2002071504/win2000. Your build is already one month old. Please use
a more recent build.
(Reporter)

Comment 4

16 years ago
you mean build it myself? that's going to be painful.. :/

Comment 5

16 years ago
Marius, it seems you are using 1.1a release (really old). Please download and
test a newer build from http://ftp.mozilla.org/pub/mozilla/nightly/latest. If it
works then mark this bug as worksforme.
(Reporter)

Comment 6

16 years ago
oh ok, it works.. sorry couldn't find this build myself.. must be this heat...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.