Closed Bug 1577252 Opened 3 months ago Closed 2 months ago

Exceptions in browser.js when editing prefs in about:config

Categories

(Toolkit :: Password Manager, defect, P2)

defect

Tracking

()

VERIFIED FIXED
mozilla70
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox69 --- unaffected
firefox70 --- verified

People

(Reporter: bzbarsky, Assigned: jaws, NeedInfo)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

STEPS TO REPRODUCE:

  1. Load about:config
  2. Click through the warning
  3. Type "foo.bar" in the about:config search field
  4. Click the "Add" button to try to add the pref

EXPECTED RESULTS: No exceptions

ACTUAL RESULTS:

JavaScript error: chrome://browser/content/content.js, line 46: TypeError: nodePrincipal.URI is null

ADDITIONAL INFORMATION: Looking at that URL locally, line 46 is:

  return nodePrincipal.isNullPrincipal || nodePrincipal.URI.schemeIs("about");

in the shouldIgnoreLoginManagerEvent function. This is the code that was added in bug 1550171, as far as I can tell. In this case nodePrincipal is a system principal, so there is no URI and the function throws an exception.

Assignee: nobody → jaws
Status: NEW → ASSIGNED
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/cfdec1350f2e
Ignore login manager events in system principal code. r=MattN
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70
Flags: qe-verify+

In an attempt to verify the fix, I am unable to reproduce the issue.
Is there any extra pref or additional steps missing for it?

Flags: needinfo?(jaws)

Did you have the console open?

Right, saw the error message while the browser console was open. (nightly build from 2019-08-28).
Fix verified with 71.0a1 (2019-10-13) , 70.0b14.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.